Skip navigation

Quicktime Damaged/Missing

1586 Views 26 Replies Latest reply: Aug 30, 2013 9:17 PM by marksto RSS
1 2 Previous Next
XENiCraft Level 2 Level 2 (210 points)
Currently Being Moderated
Jul 20, 2013 4:32 AM

Hello All

 

I have a 2009 iMac which recently had the RAM replaced due to some issues. I have since gotten it back and installed a fresh copy of Mountain Lion and updated it to the latest version (10.8.4).

I have not been able to play any quicktime files, as Quicktime 7 just displays a blank player with 00:00:0 being the time reading, no playhead and no video. I have installed Perian and since removed that along with Flash, as Flash is usually the culprit. Then i recently discovered that Skype no longer works. Just yesterday I was using it fine and the day before yesterday Skype auto updated.

I had not restarted my computer in a while so I decided to do so after finishing up with Skype and when I started the computer up today and tried to open Skype, I got the following error. http://imgur.com/JFGlNh1 I even tried completely uninstalling Skype and reinstalling and I still get it.

I did some looking around on my mac. I looked in Quicktime 7 after uninstalling Perian and still could not play anything, it either locked up and beachballed or game me a strange error code. I then tried to open the same file in Quicktime X and just got an instant crash. So I went to the Finder and tried to quick look a video file and promptly received a crash. The same occurs with really any media file. Audio and video alike. And now I get this in iTunes. http://imgur.com/24VSHoL

 

Everything is updated in the updates section of the Mac App Store. I tried this command

plutil -p /System/Library/Frameworks/QuickTime.framework/Resources/Info.plist

which yields:

/System/Library/Frameworks/QuickTime.framework/Resources/Info.plist: file does not exist or is not readable or is not a regular file

 

I am now absolutely certain the QuickTime frameworks are damaged. Now I just need to know. Do I have to do a fresh clean install? Coz that would be a serious pain in the neck. Can I just reinstall Mountain Lion over the top?

 

It was also suggested to me to try and extract the Quicktime installer from the Mountain Lion installer. I cannot find a single package for quicktime, but I have found the Essentials package in the Install ESD and I just need to know which folders to copy. I will detail steps taken upon request.

 

This suggests that some changes were made to Quicktime, maybe some of them went wrong?

http://support.apple.com/kb/HT5806?viewlocale=en_US&locale=en_US

 

 

Many thanks in advance,

xeni

  • macjack Level 9 Level 9 (50,445 points)
    Currently Being Moderated
    Jul 20, 2013 7:07 AM (in response to XENiCraft)

    Create a new account or log into your Guest user and test QT. Put some video files in Users/Shared first as you won't be able to get to them when logged into the other account.

     

    If QT works as expected in the other account, then you need to troubleshoot your user.

    If not, then re-install ML over the top. This will only replace system files and shouldn't touch anyt of your data or settings. That said, always have a backup.

  • OneBlueSky Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jul 20, 2013 7:34 AM (in response to XENiCraft)

    Be careful. I am experiencing this issue with Skype/Quicktime as well, and I have reinstalled about 4 times. You're probably the one in the Skype thread too? We finally found ONE Mac where the issue seems to actually be Quicktime. It works for a day or so and then the problem appears all over again. There seems to be something that is breaking Quicktime either in this latest version of Skype itself, or some other software we may both have installed. Just saying, don't count on all the work of a reinstall sticking at all.

  • OneBlueSky Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jul 20, 2013 8:36 AM (in response to XENiCraft)

    Right, I can get the older versions to work as well, it's only the newest version of Skype with OS X 10.8.4 and the current version of Quicktime that seems to be breaking. Same here, Skype is necessary for work purposes. (Oh if only people would just move over to Facetime, haha! ) But right, it is annoying to have to revert to old versions of OS X or Skype (Skype 6.3 works on 10.8.4 even if you're getting the error with Skype 6.6) . I hope so too. I had communication with them via support emails, but they insisted it's a problem with OS X and Skype is perfectly fine and there's no issue and nothing they can help with. That's not true at all, as until THIS update to Skype, everything worked flawlessly and nothing broke Quicktime. If I reinstall and don't install Skype, the system works fine. Reinstall, then put in Skype 6.6, Skype is broken, Quicktime is broken... This is purely related to Skype, nothing changed except for Skype. They seem to insist on avoiding even looking into it at all.

     

    Anyway, I will try that when I get home and post the results! Not at that Mac right now, am out of town today but I'll post back tonight or in the morning with the results

  • Eric Root Level 6 Level 6 (13,910 points)
    Currently Being Moderated
    Jul 20, 2013 9:22 AM (in response to XENiCraft)

    Do a backup.

     

    Try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. When you reboot normally, the initial reboot may be slower than normal. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart by using the application uninstaller. For each disable/delete, you will need to restart if you don't do them all at once.

                   

    Safe Mode

     

    Safe Mode - About

     

    General information.

     

    Isolating issues in Mac OS X

     

    Troubleshooting Permission Issues

     

     

    Step by Step to Fix Your Mac

  • OneBlueSky Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jul 20, 2013 4:59 PM (in response to XENiCraft)

    Backing up/restoring didn't help here. Nor does reinstalling just Quicktime, or Skype, I've played with this SO many ways it's unreal. The only thing that gets it working again, is to completely reinstall OS X and Skype, or to just use an older version of Skype lacking some functionality of the current version. (some things on Skype 6.3 will not work anymore, 6.5 gives the same error as 6.6). Yes Xeni, everything works fine upon OS X reinstall and using Skype until the first time Skype is either closed, or the Mac is restarted. If I don't run Skype, nothing breaks no matter how many times I restart. First time I log in to Skype 6.6 and close it, Quicktime and Skype both are broken. I can duplicate this as often as I feel like reinstalling OS X for Skype alone (which is not often, I am so tired of doing that). It's not a fluke. Also, it does that whether I have all my apps reinstalled, or do a purely vanilla install of OS X and only adding Skype, which seems to say that it's not a combo of Skype and another app.

     

    It really seems we are going to have to wait for something from Skype. It's a weird issue as not everyone with a Mac seems to experience it. But all 4 of our Macs are (Mac Pro, Macbook Pro, Macbook Air, and iMac, all 10.8.4 ) are. It's something to do with Skype, as again, never had this problem with 6.5, and NOTHING else causes Quicktime to break. Skype is doing something on some of our machines.

     

    (Still not home, but I will post what you asked for soon as we are!)

  • OneBlueSky Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jul 23, 2013 2:25 AM (in response to XENiCraft)

    The results from the commands you asked me to run the other day -

     

    /System/Library/Frameworks/QuickTime.framework/Resources/Info.plist: file does not exist or is not readable or is not a regular file

     

    and

     

    {

      "CFBundleShortVersionString" => "7.7.1"

      "CFBundleIdentifier" => "com.apple.QuickTime"

      "CSResourcesFileMapped" => 1

      "CarbonLazyValues" => {

        "CodeFragmentManager" => {

          "QuickTime" => "CFMPriv_QuickTime"

        }

        "Gestalt" => {

          "qtth" => "__QTInitializeGestaltValues"

          "qtrs" => 1

          "icmp" => 20

          "qtsf" => 0

          "qtvr" => 15

          "qtvv" => 124878848

          "qtst" => 124878848

          "qtim" => 124878848

        }

      }

      "CFBundleName" => "QuickTime Framework"

      "CFBundleSignature" => "????"

      "CFBundleInfoDictionaryVersion" => "6.0"

      "CFBundleDevelopmentRegion" => "English"

      "CFBundleExecutable" => "QuickTime"

      "CFBundlePackageType" => "FMWK"

      "CFBundleVersion" => "2599.31"

    }

     

     

    So far I have found no solution. Once this happens, Quicktime cannot be reinstalled or restored from an earlier backup using Time Machine, or another backup application I use (Carbon Copy Cloner). Your only course of action from here so far, seems to be just reinstalling OS X, and making **** sure you don't close Skype or restart the machine, ever. At least until the Skype people get off their butts and do something about it. As far as 6.5, no it won't work, it gives the same error. With 10.8.4 you can use 6.3 or older, but some of the features no longer work so it's a bit of a handicap, but seems to work more or less.

     

    I am getting to the point I'd rather just find a way to substitute it. Facetime for video calls, some other client for text chatting. I don't know what to do, especially since Skype staff seem to be avoiding this issue they created like the plague.

  • OneBlueSky Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jul 23, 2013 2:33 AM (in response to XENiCraft)

    I'll check that out, thanks!

     

    Well, some people who are having this issue with 6.6/6.5 and 10.8.4 say that Skype 6.3 doesn't show avatars properly, drops chats/signs you out a lot, and various parts of the "chat" area are broken. But I only use it mainly for video calls, and have not noticed any serious issues there.

     

    I can avoid Skype for many things, but the part that is really getting under my skin is that Skype seems to quite literally be breaking a major part of the OS (iTunes won't even work properly without Quicktime, among other things) for people and they won't even say a word. Not a suggestion on what to do, no help troubleshooting at all, not even a "we're working on the issue". Terrible way to do things, makes me even more angry as I was subscribing to some of their pay services (and they won't refund the latest payments, though their application literally is breaking our machines' functionality).

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.