3 Replies Latest reply: Jul 23, 2013 9:08 PM by BGreg
BCNbox Level 1 Level 1 (0 points)

Hello everybody,

After switching off the power cord from my iMac, it takes a long time (between 25-30min) to respond to the power button, in order to be turned on.

During this period of time, there's no sound at all, no chime, no fan sound.

I would really appreciate your help or tips to solve this problem.

 

I've already done a SMC reset, but the problem persist.

 

Thanks in advance.

 

Cheers.

Marc Cardona Ariza.


iMac (21.5-inch Mid 2010), OS X Mountain Lion (10.8.4)
  • 1. Re: iMac doesn't respond to power button pressing
    BGreg Level 6 Level 6 (17,500 points)

    I would run the Apple hardware test to see if there is a sensor issue. Run the extended test when prompted, which can take over an hour to run.

     

    If your system came with OS X 10.6, then use the original OS X DVD that came with your system. It will say 'AHT Version x.x' in small print on the label.  If it came with OS X 10.7 Lion, follow the directions in the Apple note.

  • 2. Re: iMac doesn't respond to power button pressing
    BCNbox Level 1 Level 1 (0 points)

    Thanks BGreg!

    I have run the Apple hardware test (The complete and simple one) and it didn't found any problem.

     

    Any other idea or suggestion?

  • 3. Re: iMac doesn't respond to power button pressing
    BGreg Level 6 Level 6 (17,500 points)

    Sorry for delay getting back to you .... See steps outlined in this Apple note for systems that won't start. While yours eventually starts, see if any of the steps in the note help you. Otherwise,  you may have to take it in for service.

     

    When asking you to run the hardware test, I was hoping it would show up with a bad temperature sensor. Of course, if the system were genuinely overheating, that could account for a delay in turning it back on. There are several programs available to tell you the system temperature.