Have been unable to find an explanation for this error.
I don't think this is an error.
AirPort Utility 5.6.1 for the Mac is specified to run on Leopard 10.5.6 through Snow Leopard 10.6.8, so it would be logical to expect some kind of pop up warning, or notice of an upgrade if you are trying to use 5.6.1 on a Mac running Lion or Mountain Lion.
You will have to just ignore the message if you want to use 5.6.1 to administer the AirPort Express, since Apple wants you to use Airport Utility 6.x with the AirPort Express if you have Lion or Mountain Lion.
No need to post a screenshot, I know what you are seeing.
AirPort Utility 5.6.1 for Windows is specified to run on Windows 7, so you would not expect to see any type of notice or warning in that situation.
My airport network has 802.11b/g access points for compatibility with 2G iPods. The utility is fine with 802.11n 4th Gen TC on 10.7+. It seems to show this message for the 802.11ac Extreme/TC and 802.11n Express (2nd gen) only.
But I agree with you on version compatibility. My MBP on 10.7.5 was an upgrade from 10.6.8.
Thank you for responding Mr. Timmons. I am glad to see someone like you on the discussions provide 'support' and answer questions.