4 Replies Latest reply: Jul 26, 2013 2:54 PM by iMilti
iMilti Level 1 Level 1 (0 points)

I recently moved my iPhoto library to an external harddrive (my original version was backed up) and just to be sure I did everything right, I got this done at the genius bar. However, when I open iPhoto, I don't see thumbnails - with a few exceptions:

1. Yesterday when I opened iPhoto to import a bunch of pictures, the thumbnails were there, I could scroll through them and all. I then imported my pictures and the thumbnails were still there. When I navigated outside the album to faces - the thumbnails disappeared - from everywhere - events, places, photos, faces, everywhere.

2. I then did some goodle search looked up a few psoting, some on this forum and tried to rebuild the library and recreate the thumbnails, by selectiong cmd+option during startup. It took about 40-50 minutes to do and when it started, the Face page was selected - the one selected when i quit iPhoto the last time and I could see the thumbnails. I navigated to Events, and they disappeared again. I went back to faces, the thumbnails had disappeared from there too.

 

I read somewhere else that iPhoto takes time to recreate everything after a move so I need to use it for sometime or restart it. The mvoe was done a couple months ago and I have tried restarting it quite a few times. Last night I kept iPhot on the whole night or atleast until the system slept.

 

I can still do slideshows and all with the pictures, but I can't see thumbnails, which really is bad, coz navigating picture by picture is tedious and not helpful at all.

 

I have iLife '08. Want to upgrade to iPhoto '11 but the reviews on the App Store made me rethink.

 

Is there any wayto solve this problem once and for all without having to move the library back to the Macbook?

 

Message was edited by: iMilti


MacBook Pro (13-inch Mid 2009), OS X Mountain Lion