Skip navigation

New Macbook Air - wifi connectivity problems

444581 Views 2,049 Replies Latest reply: Apr 16, 2014 9:41 AM by thiagobona RSS Branched to a new discussion.
  • Russets Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2013 10:08 AM (in response to wofsie)

    I am saddened by all this, I have been a dedicated mac user since I discovered mac in 1992. My background is in production engineering, I understand about manufacturing and I suspect there is an engineer somewhere who knows exactly what the problem is but isn't saying anything.

     

    The symptoms suggest to me that the problem is in the hardware. We hear that some people are having problems and others are not, there also appears to be differing degrees of seriousness of the problem. This suggests the problem is in quality variations in hardware manufacture rather than in the software. If it were software the problems would be far more uniform across users. Apple needs very large volume and will be sourcing components from many different places, I suggest that one supplier is supplying dodgy wifi units and it highly likely someone, somewhere is aware of this.

     

    Being a hardware issue would also explain why the "fix" is a softare fudge.

     

    This is deeply disappointing, I have a 2011 11" Macbook Air, it is a great machine. I bought the small one and am so impressed I want to upgrade to a new faster machine with the longer battery life and I planned to get the largest ram and memory available. If the problem was a software issue I would go ahead but, as I say, I am pretty sure it is in the hardware and so will saty with the machine so I am not going to buy one. For my work I travel to remote areas and I have to have a good wifi connection that will work with all sorts of routers.

     

    I am deeply saddened to see how quickly after Steve Job's death Apple seems to be losing its way in so many different ways. With the capital that Apple has behind it there is no excuse for not fully testing the product before it is supplied to the customer. Saving a bit of money on comprehensive testing is strategically foolish and a sure fire way of very quickly squandering a reputation that took decades of hard work and dedication to build.

  • kahlonel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2013 10:12 AM (in response to vhkim)

    Just signing in again to post an update.

     

    I noticed that with my WiMax gateway (ZTE ix380), the wireless connection never drops. Although the internet is disabled on that device but I don't think that matters, does it? I have tested it for different sessions of almost 45 mins each, it never hiccuped. Tested it by constantly pinging my other laptops connected to that device every other minute.

     

    I also tried copying all WiFi parameters I could from that gateway to my original DSL wifi router, but it keeps on dropping on that.

     

    What I think is that its a compatibility issue, either software or hardware can't say. I'll test out other routers in coming days and keep posting.

     

    K.

  • winslomb Calculating status...
    Currently Being Moderated
    Jul 26, 2013 2:53 PM (in response to winslomb)

    I am giving up the fight...

    I was contacted by apple engineers and they told me some specific router config I needed for the mba to work correctly.  That's fine... for home use.  Everywhere else is horrible with the constant drops.  The update just re-connects, which is fine unless you are power surfing or watching youtube.  Windows 8 drivers are even worse still, constant drops every 15-20 seconds.  I have to restart wifi to get it to connect for another 15-20 seconds. 

     

    I am sad to say I am returning the mba...  I only have 3 more days to do so, and I cannot live with such a flaw.  I really do enjoy almost every aspect of the mba; I just wished it worked :C

  • brainyark Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2013 3:28 PM (in response to winslomb)

    Would you mind sharing the configuration you were advised?

  • Benjamin Slack Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2013 7:17 PM (in response to vhkim)

    Just a bit of an update. Decided to extend my trouble shooting a bit and went and picked up a Linksys AC900, Wireless AC router. Low and behond, connects just fine. Drove around town, trying connections to the public networks. Anything N or better, connection. G or less, no go. Still considering a return very seriously. There's a whole lot of Wifi world out there still using "g" and the documentatioin says the MBA is "g" compatible. It's pretty obvious that it's not however, patch or no patch.

  • kahlonel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2013 12:17 AM (in response to Benjamin Slack)

    In my last post, the WiMax device had a 'g' router so I still think there is something else that causes the drops.

  • orchetect Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 27, 2013 12:28 AM (in response to Russets)

    Re: possibly being a hardware issue.

     

    I'm not an engineer -- but if this really is a hardware QC issue, why does my 6th-gen AirPort Extreme connect on 802.11ac beautifully when it puts much higher demand on the "hardware" than an 802.11n or 802.11g connection?

     

    I mean, if it's a hardware defect shouldn't it be the other way around -- the 802.11ac should have the most problems?

     

    (And side note, it feels like we're dealing with one big collective spinning beachball on this issue as we wait...)

  • andQlimax Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2013 3:59 AM (in response to vhkim)

    From wireless diagnostic it seems the problems are the follow:

     

     

    07/27/13 10:36:38.7550No LAN Connectivity
    07/27/13 10:36:38.7550LAN: WiFi interface can ping IPv4 router 192.168.1.1 . . . fail
    07/27/13 10:36:38.7560UNEXPECTED DROP DETECTED!!!

     

    or this:

     

    07/27/13 12:45:06.3320No WAN Connectivity
    07/27/13 12:45:06.3320WAN: WiFi interface can ping DNS server 17.254.0.50 . . . fail
    07/27/13 12:45:06.3330UNEXPECTED DROP DETECTED!!!

     

    I sent the logs to apple engineering.

     

    While the first is an instant short drop, the seconds take more than 30 seconds to get network again.

  • Mike XYZ Calculating status...
    Currently Being Moderated
    Jul 27, 2013 11:13 AM (in response to Russets)

    This is a note of support for those calling on Apple to fix this wi-fi problem as well a message to Apple, Inc. I’ve been an MS-DOS person back to the 1980s. In replacing a laptop, the most important thing for me after reliability is light weight. Upon looking to replace my almost ten year old IBM Thinkpad X40 (a great pioneering 2.9 pound ultralight) the 2013 2.3 pound 11” MBA looked so good that I was prepared to jump ship from the DOS to the Apple world – until I became aware of this still unresolved problem. If it is resolved to the general satisfaction of people in this thread, I’m in.  But in the meantime, I’m still shopping.  The 1.9 pound SONY Vaio Pro 11” with a touch screen seems to have the MBA beat innovation wise except for a deal-breaking noisy fan.  The longer the MBA’s wi-fi issue remains unresolved, I’m sure an attractive alternative will appear.  So I urge Apple to come up with a credible fix.  For the time being, I’d love to buy the 2013 MBA.

    
  • winslomb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2013 11:28 AM (in response to brainyark)

    The config that worked for me (netgear wndr4300) was having wpa2/aes on channel 11 for the 2.4 ghz.  I never used the 5ghz because it always showed as terrible connection for some reason, but it didn't drop on that as well.  Literally everywhere else I have been I have seen constant drops before and post update.

     

    Leaving now to return :C

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Jul 27, 2013 11:53 AM (in response to winslomb)

    If changing channels helped you then you were probbaly just running into too much noise issues on the channel you were. 2.4 GHz is really polluted and its not going to get much better as folks use more and more WiFi. Looks like your machine has no issues imo.

  • brainyark Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2013 12:08 PM (in response to wifiguru)

    Wifiguru, if you truly be a guru, then tell me why my Macbook Pro work fine when / where my Air doesn't?

     

    I love Apple's products too, but we're really not helping anyone by naysaying the problems that customers have instead of trying to help them resolve them.

  • Jet_Cal Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2013 12:22 PM (in response to vhkim)

    I returned my new MBA 2013 last week, new patch didn't work.

     

    Apple please take note.

  • Mikael_B Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jul 27, 2013 3:25 PM (in response to Mike XYZ)

    Its not working as promised, its sadly malfunctioning in a major area.

    Yet you love to buy it?

    I can sell you a LOT of defective hardware, please send your money!

    Thus Apple can continue to make a large profit selling defective units.

    If everyone with a defective unit returned it, Apple would feel a market pressure to deliver what they promised, people acting like you shows Apple that a lot of people gladly pays a premium price for, really, nothing!

    And they wont even complain!

  • flinlov Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2013 3:27 PM (in response to vhkim)

    I ordered my air 8g256 early this july online, I travel around with it and it works good so far with different routers, WPA, WPA2, works good with hotel free wifi with no password

1 ... 59 60 61 62 63 ... 137 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (72)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.