Skip navigation

Random hanging while import?

2249 Views 28 Replies Latest reply: Jan 4, 2014 1:10 PM by Photron RSS
1 2 Previous Next
aapl.crox Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 18, 2013 10:40 PM

I'm not sure what's going on but recently, my Aperture library is getting a lot of hanging while importing. It happens both with my camera and even when just importing photos from a local folder. The library is located in a thunderbolt external drive. Usually I have to force quit aperture because once the import hangs there's no way to stop it. Normal quiting of the application will get stuck "cancelling". How do I fix this?

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jun 18, 2013 10:57 PM (in response to aapl.crox)

    What is your Aperture version, and what is your MacOS X version?

    What changed in your system, before Aperture stopped working? Did you install or update software?

     

     

    What kind of media are you importing? Videos? Raw images, jpegs?

     

    Have you repaired the Library after force quitting?

     

     

    Try to get more information on what is happening by turning on the "Activity Viewer" in Aperture (from the main menu bar: Window > Show Activity").

    Also launch the "Console" window (from the "Applications" folder > "Utilities")

     

    With both windows showing, try to find out the type of files, that makes Aperture hang. Import only small batches if images at once, so you can see, if it is aspecial file or file type that is causing problems.

    If it happens, take note of the message in the Activity viewer and look for new messages in the Console and post back.

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jul 27, 2013 10:55 PM (in response to aapl.crox)

    Sorry, I did not receive notifications of your answer.

     

    Try to check, if there is a problem with the RAW file, that cannot be imported.

     

    When Aperture gets stuck, try to copy the file directly from the card, and check if the file is readable in other programs.

     

    If there are files on your card, that cannot be processed by any program, try to figure out why:

    • Reformat your card or try a different card.
    • Or try, if the card reader is the problem, if you are imorting using a card reader.
    • Or are you importing directly from the camera? Is the camera connected to a power supply during import? If the batteries are low, the import may hang. Also, sometimes the cables have a problem.

     

    While you are trouble shooting this issue, I'd import to a new Aperture library on your system drive first, not to your main library on your external. This way you avoid the corruption of the main library, and also exclude any issues with the  external drive, just to be able to narrow down the problem.

     

    Léonie

  • Mr Spork Calculating status...
    Currently Being Moderated
    Jul 30, 2013 12:32 AM (in response to aapl.crox)

    I have the same problem where Aperture just hangs importing files from an internal hard drive. It stops at different times and files each attempt. there is no significant disk or CPU activity at the time.  I also have to force quit and repair the database after every crash.  I have tried importing for about 3 days now without success.

     

     

    Info:

    Mac Pro 12-core

    12GB RAM

     

    Console log (abridged)

    Process:     Aperture [67552]
    Path:        /Applications/Aperture.app/Contents/MacOS/Aperture
    Identifier:  com.apple.Aperture
    Version:     3.4.5 (3.4.5)
    Build Info:  Aperture-320090000000000~2
    App Item ID: 408981426

    App External ID: 15509373

    Code Type:   X86-64 (Native)

    Parent Process:  launchd [244]

    User ID:     502

     

    Date/Time:   2013-07-29 00:44:36.318 -0700
    OS Version:  Mac OS X 10.8.4 (12E55)

    Report Version:  10

     

    Crashed Thread:  10  Dispatch queue: Import/Export Thread

     

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000010

    ----------------

     

    Screen Shot 2013-07-30 at 12.21.12 AM.png

    (Highlighted process hung)

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jul 30, 2013 12:34 AM (in response to aapl.crox)

    It seems aperture will get it itself into this vulnerable state if I don't repair it every day.

    Have you run a hardware test? Checked your RAM, your drive?  That is not normal.

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Aug 6, 2013 10:54 PM (in response to aapl.crox)

    . I copied all the files first to the desktop and then imported into aperture, still the same hang at "saving preview...".

    The hang at "Saving Preview" typically occurs if one image is being processed, that has a corruption and cannot be processed.

     

    Aperture is processing the previews in the background. That may take a long time. Before you force quit Aperture and suspect a hang, look at the filename in the Activity viewer. If it is hanging at the same filename without getting the preview created, then export the original as original, not the edited version delete that file from Aperture. Check that file in another program and make sure you do not import that particular file again.

     

    Have a look at the screenshot Mr. Spork posted. You can see the name of the currently processed file in the panel. If ithis name does not change for hours, then you have found the file that is making Aperture unresponsive or hang.

     

    Second test, I created a new aperture library immediately after the hang and imported the same folder of files. No hanging.

    You cannot be  sure, until the processing of all the previews has finished.

    If you isolate the file that causes the hang and check only importing that particular file in a separate library and that works well, then you know that it is the library and not the image.

     

    If it is the library, try rebuilding the library instead of repairing. Make a backup of the library before trying that.

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Aug 7, 2013 9:22 AM (in response to aapl.crox)

    No as I mentioned above. If I force quit Aperture, repair the database, the same files will import just fine. So the problem is not with the files.

     

    I am not yet convinced by your test. You imported all files at once in the new library - as you said:

    I created a new aperture library immediately after the hang and imported the same folder of files.

    So you cannot know, if all files can be processed in the new library, only if you import each image on its own, because the processing will happen at some time in the background.

     

     

    Anyway, hanging can be caused by a corrupted library as well, and then rebuilding is necessary, if repairing does not solve the problem.

     

    Also I cannot rebuild the library, because that will reset all my curves. Any other fix?

     

     

    Why do you expect rebuilding to reset your curve adjustments? The adjustments usually survive a rebuild. But before rebuilding it is strongly recommended to backup the library, so you can restore the previous version if necessary.

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Aug 7, 2013 9:33 AM (in response to léonie)

    ...

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Aug 7, 2013 9:53 AM (in response to aapl.crox)

    Can you explain exactly what you are trying to imply? I don't understand your logic. Are you suggesting that the problem is with the files I'm trying to import and not with the library?

    There are at least two very common reasons for this hanging behaviour.

    • A corruption of your Aperture library - e.g. an unwritable database file: This is usually fixed by repairing or rebuilding the library.
    • A corrupted video or or image file.

     

    What I was trying to say is that your tests are not yet excluding any of these possibilities : Your test with importing into a new library is suggesting a library corruption and not a data problem with one imported image, but you cannot yet be perfectly sure, unless you are isolating exactly that file that is making Aperture hang. As I said, processing the imported images and generating previews is a background process, and you do not know, if and when each image will be processed. And if you imported a bad image a long time ago, Aperture will try over and over again to process the image, when it gets around to that particular image.

     

    So be prepared and have the Activitiy viewer up and running, when processing imported images starts, to be able to see the filename. Then you can tell, if it is alwas the same image or video and remove the culprit. Rebuilding will not help in that case.

     

    But it also be a corrupted database file, that makes it impossible to write the edited versions to the database. Then only rebuilding will help.

     

     

    I get this problem with almost everynew batch of photos I take from the camera.

    That is why your import into a new library was a valuable test. Since that works well, your camera, card, cable, card reader seem to be o.k.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.