Skip navigation

problem connecting to server

771 Views 9 Replies Latest reply: Jul 31, 2013 7:13 AM by vladc RSS
Canada Mike Level 1 Level 1 (15 points)
Currently Being Moderated
Jul 28, 2013 11:09 AM

Hi,

When I turn my iMac on it keeps looking for an old computer that's not there anymore. The messageis,

"There was a problem connecting to the server 'Michael's iMac(2)'" How can i get rid of this?

 

TIA

 

Michael

iMac, Mac OS X (10.6), iPhone4; intel iMac 24" 3.06;Macbook Air 13"; iMac 20"; MacBook
  • LowLuster Level 6 Level 6 (11,810 points)
    Currently Being Moderated
    Jul 28, 2013 11:12 AM (in response to Canada Mike)

    Open System preferences then Users & Groups then click on the Login Items tab and remove that entry from the list.

  • LowLuster Level 6 Level 6 (11,810 points)
    Currently Being Moderated
    Jul 28, 2013 11:32 AM (in response to Canada Mike)

    Did you originally enable this in the ROOT user or with a terminal command?

    To my knowledge the login items area is how you Auto login to other computers on your network.

     

    Check out this link. Maybe you used one of their suggestions, or one like it, to enable this.

     

    http://reviews.cnet.com/8301-13727_7-57488165-263/save-remote-server-connections -in-the-os-x-terminal/

  • LowLuster Level 6 Level 6 (11,810 points)
    Currently Being Moderated
    Jul 28, 2013 11:40 AM (in response to Canada Mike)

    How did you open the remove connection to the other computers? Could be, not sure, that you somehow combined all those connections into one Login Items entry? Just a guess.

  • Linc Davis Level 10 Level 10 (108,110 points)
    Currently Being Moderated
    Jul 28, 2013 12:04 PM (in response to Canada Mike)

    Please take each of the following steps that you haven't already tried. Back up all data before making any changes.

    Step 1

    If you get the warning as soon as you log in, it's probably caused by one of your login items or a system modification that loads at startup or login. Ask if you need help identifying it. A common offender is "Adobe Synchronizer," which is a component of some Adobe products.

    Step 2

    If there's an icon representing the server in the sidebar of a Finder window, hold down the command key and drag it out.

    Step 3

     

    In the Finder, press the key combination command-K or select

    Go Go to Server...

    from the menu bar. In the upper right corner of the window that opens is a Recent Servers popup menu represented by a clock icon. From that menu, select

    Clear Recent Servers…

    and confirm. Test.

    Step 4

    Open the Print & Scan pane in System Preferences and delete any network devices you no longer use.

     

    Step 5

     

    Triple-click the line below to select it, then copy the text to the Clipboard (command-C):

    ~/Library/PDF Services

    In the Finder, select

    Go Go to Folder...

    from the menu bar, paste into the box that opens (command-V). You won't see what you pasted because a line break is included. Press return. A folder may open. If it does, move the contents to the Desktop, or to a new folder on the Desktop. Log out and log back in. Test. If there's no change, put the items you moved back where they were and continue.

    Step 6

    Open the folder

    ~/Library/Preferences

    as in Step 3 and move the file named "loginwindow.plist" items in that folder to the Trash, if it exists (it may not.)

    Log out and back in again, and test.

      
    Step 7
      
    Other possible causes are references in the iPhoto, iTunes, or iMovie library pointing to the server, and bookmarks in the Preview application.

    Try rebuilding the iPhoto library.

    Step 8

     

    Triple-click the line below on this page to select it:

    /System/Library/CoreServices/Directory Utility.app

    Rght-click or control-click the highlighted text and select

    Services Open

    from the contextual menu.* The application Directory Utility will open.

    In the Directory Utility window, select the Directory Editor tool in the toolbar. Select Mounts from the Viewing menu in the toolbar, and /Local/Default from the node menu, if not already selected. On the right is a list of names and values. By default, the list is empty. If it's not empty, post a screenshot of the window and stop here.

    *If you don't see the contextual menu item, copy the selected text to the Clipboard (command-C). Open a TextEdit window and paste into it (command-V). Select the line you just pasted and continue as above.

    Step 9

     

    Open the following file as you did in the last step:

    /etc/auto_master

    It will open in a TextEdit window. The contents should be exactly this:

     

    #
    # Automounter master map
    #
    +auto_master          # Use directory service
    /net               -hosts          -nobrowse,hidefromfinder,nosuid
    /home               auto_home     -nobrowse,hidefromfinder
    /Network/Servers     -fstab
    /-               -static

    If there are any other lines in the window, post them. Otherwise, close the window.

  • Linc Davis Level 10 Level 10 (108,110 points)
    Currently Being Moderated
    Jul 29, 2013 12:31 PM (in response to Canada Mike)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, by a peripheral device, or by corruption of certain system caches.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including sound output and Wi-Fi on certain iMacs.  The next normal boot may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • vladc Calculating status...
    Currently Being Moderated
    Jul 31, 2013 7:13 AM (in response to Canada Mike)

    Hi, I have this same problem (although for me it's not on startup, it's when I open mail or when my iphone/ipad try to sync with iTunes). This all began when I bought an iMac to replace my MacPro and used the Migration Assistant in February. In the morning it said the migration had failed but there was no way to try again so I've been using the machine as it is and aside from this error message it seems to function normally.

     

    Linc you seem incredibly knowledgeable and I am very excited to even see your suggestions. I wanted to ask if you have any further ideas as I have tried every single thing on your list and I'm still seeing exactly the same problem. I have also done a grep for the name of the "server" (my old computer which my new one is still trying to connect to for some reason) and removed everything that contained a reference to the old machine (which meant I had to reinstall iWork as it stopped working) and I have completely removed iTunes from my system and then rebuilt it from scratch by copying in all the music files again. I have also searched Keychain for any reference to the old machine but cannot see anything.

     

    I still see the same Cannot Connect to Server message every single time I open Mail and in fact it freezes my machine for about 30 seconds each time as well.

     

    With the guest account I'm not sure how much I learned as I couldn't open Mail normally (should I set up all my usual accounts while logged in as a temporary guest?) and iTunes opened with the first-time use screen. I didn't see any messages about the missing server while logged in as a guest.

     

    In safe mode, the computer seems very slow and sluggish and the "Cannot connect" message pops up as always as soon as I open Mail.

     

    I have followed every single one of your instructions to the best of my ability and would be very keen to try and take the investigation further if you have any suggestions for next steps. This error drives me absolutely crazy. If I could completely rebuild my machine from scratch to get rid of it I would.

     

    Thanks so much for all the effort you've already put into answering this. I hope that other users have already been able to solve their problem with the steps you've outlined.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.