10 Replies Latest reply: Apr 3, 2014 5:46 PM by Flying Pelican
jamesrward Level 1 Level 1 (0 points)

I am looking for a way to turn off alerts on my iOS device for calendars that a shared with me via iCloud.

 

There seem to be a lot of conversations about this but the terminology gets muddled so I want to be very clear what I am talking about.  There are 3 things that are discussed interchangably in a lot of threads for both iOS and OSX so I will clarify between them here. 

 

They are:

1.) The iDevice or OSX notification center

2.) The iCal/Calendar in-app notification tray

3.) Event Alerts - the sounds or messages that play to remind you of an upcoming event

 

I only care about number 3.  If someone on my team sets an alert for 30 minutes before an event in her calendar I do not want an alert to play on MY iphone for HER event.

 

This problem is fixed in OSX mountain lion by going into Calendar->Preferences->Alerts and checking Turn off shared calendar messages in notification center.  A similar setting exists in iOS under Setting->Mail, Contacts, Calendars scroll to the bottom and you will see Shared Calendar Alerts.  Notice that the terminology does not quite match and neither does the effect.  Turning this off gets rid of the sounds and pop-ups that would be generated for #1 (notification center) but does nothing to take care of #3 (event alerts).

 

It seems like this is an oversight or a misunderstanding internally at Apple due to the vague naming of each of the 3 different items and failure to clarify how each one is handled.  There should be a setting somewhere in iOS that has the same effect as the OSX shared calendar alert setting.

 

For those of you who have seen multiple threads on the #1 and #2 using the settings I listed above will quiet the notifications center pop-ups and noises but the in-app tray will always show changes to all your shared calendar changes.  I didn't like this at first but now that it doesn't make any noise I don't mind seeing what my team is up to by scrolling through the tray.  It would be nice if I didn't have to click ok to get rid of them though.

 

The problem with #3 has forced us as a team to try not to set alerts on our calendar items to avoid annoying each other.  It defeats the purpose of one of the key features of any calendar app, being reminded of something you need to do.  I'm getting a lot of push-back from my team to ditch iCloud because of this issue.


iOS 6.1.4
  • 1. Re: Turn off iCloud iOS shared calendar alerts
    jamesrward Level 1 Level 1 (0 points)

    I realized after posting this that I missed an important setting to suppress #3 on OSX that I had hoped would solve the problem in iOS but did not.

     

    For each of the calendars shared with me I have right clicked the calendar from within the calendar app in OSX click Get Info and checked the box next to Ignore Alerts.

     

    This has no effect on the event alerts in iOS but does stop them from coming up on OSX.

  • 2. Re: Turn off iCloud iOS shared calendar alerts
    jdubyaelliott Level 1 Level 1 (25 points)

    Go to Mail, Contacts, Calanders in Settings, and scroll to the bottom. You'll see a slider that allows you to turn off shared calendar notifications.

  • 3. Re: Turn off iCloud iOS shared calendar alerts
    jamesrward Level 1 Level 1 (0 points)

    Per my original post:

     

    A similar setting exists in iOS under Setting->Mail, Contacts, Calendars scroll to the bottom and you will see Shared Calendar Alerts.  Notice that the terminology does not quite match and neither does the effect.  Turning this off gets rid of the sounds and pop-ups that would be generated for #1 (notification center) but does nothing to take care of #3 (event alerts).

     

    This has no effect on event alerts.  For example a member of my team had an alert set to go off 30 minutes prior to a conference call which has nothing to do with me, I am not a participant in this event.  My phone played the alert sound and popped-up a message about the conference call.

  • 4. Re: Turn off iCloud iOS shared calendar alerts
    jdubyaelliott Level 1 Level 1 (25 points)

    Sorry.. I had not read your post clearly enough. What I have done as a work-around which seems to work on both OS X and iOS is to have the person change from sharing the calendar with users to making it a public calendar to which others can subscribe. In order to make this change effectively, you first have to have the person sharing their calender REMOVE the individuals who are sharing the calender, THEN close the dialogue box to confirm. After that they can then publish the calendar and invite those they choose. When the subsribers accept the link, they need to be sure to check the "remove alarms" option. The only drawback here is that there is no way that a subscriber can edit the published calendar. Only the owner can do it. That's actually not a bad thing, but just be aware of that.

  • 5. Re: Turn off iCloud iOS shared calendar alerts
    jamesrward Level 1 Level 1 (0 points)

    jdubyaelliott wrote:

     

    ...The only drawback here is that there is no way that a subscriber can edit the published calendar. Only the owner can do it. That's actually not a bad thing, but just be aware of that.

    That is an interesting work around.  Losing the ability to edit each-others calendar is not a big deal for us but I would say another large drawback is the fact that the calendars have to be public.  I don't think anyone in the organization would like the idea of our calendars being publicly accessible.

  • 6. Re: Turn off iCloud iOS shared calendar alerts
    jdubyaelliott Level 1 Level 1 (25 points)

    I think "public" is a bad description for Apple here. My suggestion is to take a look at the URL that is generated and see if you feel better. To try and find a publicly shared calendar of the nature you're describing would be quite difficult. But the point is well taken. Good luck!

  • 7. Re: Turn off iCloud iOS shared calendar alerts
    jamesrward Level 1 Level 1 (0 points)

    After testing for a month I can confirm that this solved my issue.  I am still a bit reticent about the fact that the calendars are publicly accesible but it is worth it to no longer have alarms going of for everyone's appointments.

  • 8. Re: Turn off iCloud iOS shared calendar alerts
    cjbigham Level 1 Level 1 (0 points)

    Thank you, thank you, THANK YOU!!! I've been looking for a solution for this problem for 2 years. My wife and I share each others cal's and I share my work cal with our secretary. The alerts were driving us crazy. Making the calendar public might not be preferable but I think the chance of anyone stumbling upon it or even being able to use the information for nefarious reasons is highly unlikely.

    It would be appreciated if Apple at some point could address this issue for shared private calendars. Not only that, very few people are even aware of this work-around. I will be visiting a number of forums to share this info. Again, thank you!

  • 9. Re: Turn off iCloud iOS shared calendar alerts
    La Corte Jester Level 1 Level 1 (0 points)

    :-)

  • 10. Re: Turn off iCloud iOS shared calendar alerts
    Flying Pelican Level 1 Level 1 (5 points)

    jamesrward wrote:

     

    I realized after posting this that I missed an important setting to suppress #3 on OSX that I had hoped would solve the problem in iOS but did not.

     

    For each of the calendars shared with me I have right clicked the calendar from within the calendar app in OSX click Get Info and checked the box next to Ignore Alerts.

     

    This has no effect on the event alerts in iOS but does stop them from coming up on OSX.

    Thank you - this solved the issue on Mac OSX.  Silly that they hid this feature and made it only accessible by a right clicking on something that didn't seem clickable.   Even sillier that it can not be done on iOS normally at all.