Skip navigation

Screensaver source says Loading... for ever

19996 Views 53 Replies Latest reply: Feb 3, 2014 10:48 PM by edward67 RSS
  • Greg Parks Level 1 Level 1 (135 points)
    Currently Being Moderated
    Mar 13, 2013 4:52 PM (in response to hedgert)

    I have resolved the issue on my machine, too. I had tried just renaming the Aperture and iPhoto libraries, but hadn't opened those apps or created new libraries. Once I did that, the screensaver worked and I could choose any folder I want. Once I reverted to the old iPhoto library it stopped working again. My conclusion is that there's a problem with the way the libraries are shared with the screensaver when there are photos in the library that have missing originals causing the screensaver system prefs panel to hang.

  • PrettyGreenParrot Calculating status...
    Currently Being Moderated
    Mar 14, 2013 12:10 AM (in response to hedgert)

    Thanks for that extra info. Sounds like I need to create a new library and try importing the old library into it.

  • jfaughnan Level 3 Level 3 (780 points)
    Currently Being Moderated
    Mar 18, 2013 6:35 PM (in response to hedgert)

    Lots of good tips in this thread. I saw mentions of several things that can cause an Aperture based screensaver slideshow to fail including referenced images, inclusion of videos, etc.

     

    In my case, after months of the screensaver unpredictablly failing to start (thus creating a security issue) the problem was resolved.

     

    I don't know what the fix was, as I did 3 things:

     

    • upgraded to 10.8.3
    • ran Aperture repair database [1]
    • ran Aperture fix permissions

     

    If I had to bet I'd say repairing the database did the trick for me.

     

    [1] http://documentation.apple.com/en/aperture/usermanual/index.html#chapter=27%26se ction=10%26tasks=true

  • jrhaskew Calculating status...
    Currently Being Moderated
    Mar 19, 2013 6:37 PM (in response to jrhaskew)

    The problem with malfunction of the screen saver was resolved magically when I downloaded a free screen saver "Mandelbrot Screen Saver".  Maybe this will help others experiencing this frustrating problem.  I hope so and wish you success.

     

    Rich

    iMac, OS X Mountain Lion (10.8.2), iMac
  • H100 Calculating status...
    Currently Being Moderated
    Mar 22, 2013 6:32 AM (in response to jrhaskew)

    What worked for me was booting into recovery mode and fixing the disk and permissions, then running all three of the Aperture repair options

  • georgefromniagara falls Calculating status...
    Currently Being Moderated
    Jul 30, 2013 6:11 PM (in response to Sean Hassett)

    boo hoo.

  • vitaal Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2013 9:12 AM (in response to jfaughnan)

    In my case the problem with screensaver loading pictures for ever was in damaged iPhoto library.

    It contained reference to photos stored on network drive which was not in use anymore.

     

    I tried all tools & methods described here, but here's two that were helpful in my case:

     

    1. Renaming iPhoto/Aperture library - worked out, but such solution just temporary.

    As soon as you connect renamed library to iPhoto/Apperture the problem reiterates.

     

    2. Use iPhoto Library Manager - that's what did solve the issue.

    I completely rebuilt library with it and finally fixed all "broken" references.

    Whole thing took a long time but it's worth to try.

     

    Just try it

  • sarahipad2user Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2014 11:30 AM (in response to edward67)

    Hi edward67,

     

    I've been having the same issue. I have 2 monitors plugged in, one with through the Thunderbolt and one through the USB on my MB Air (OS 10.9.1). If I unplug them the external monitors, I can get the screensaver to work... if I then plug in the one through the Thunderbolt, it still works. However, as soon as I plug in the monitor through the USB, the screensaver stops working. Were you able to find any solutions?

  • edward67 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2014 10:48 PM (in response to sarahipad2user)

    Hi sarahipad2user

     

    I'm afraid not.  What was working (2 new thunderbolt displays with late 2012 MBP Retina) has now stopped working since upgrading to 10.9.1.  I've given up trying to use the screensaver / photo option, and am back to 'Flurry' - a waste of time and energy.

     

    Sorry not to be of more help,

     

    Edward

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.