Skip navigation

Mac App Store updates repeating

35272 Views 77 Replies Latest reply: Jan 24, 2014 4:39 AM by Cowboooy RSS
  • gattomatto Calculating status...
    Currently Being Moderated
    Aug 2, 2012 11:52 AM (in response to Macsterguy)

    Same problem with OSX 10.7 or 10.8 and iPhoto

  • gattomatto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 2, 2012 3:44 PM (in response to Macsterguy)

    SOLVED (at least in my case)

     

    It seems that the App Store application recognises that there is more than one copy of the application and continues to report available updates as long as all the copies are updated.

    The problem is that, in my understanding, just one copy is then updated, even if the operation is repeated more times.

     

    In my case I have an old version of IPhoto on another disk and this copy is not updated. As soon as I dismounted the disk, the problem disappeared.

     

    Maybe would be nice to have the possibility to select where App Store should search for the applications. A sort of filter similat to that of the Time Machine.

  • Maan Waggass Calculating status...
    Currently Being Moderated
    Aug 12, 2012 12:35 PM (in response to Macsterguy)

    Delete /Library/Printers/hp/Frameworks/HPSmartX.framework and reinstall the HP update

     

    To make sure that it worked, press update again, if the update disappear then you are done


    Will work for all such problems

  • brian163-apple Calculating status...
    Currently Being Moderated
    Sep 20, 2012 3:59 PM (in response to gattomatto)

    Thanks for the post. Having a second drive with the same pre-updated apps on it was causing me the same false positive depending on whether or not it was mount.

     

    Until I came across your post I was banging my head on the table!

     

    I'm guessing a work around for this may be to exclude the drive from Spotlight searches. I'm going to give that a shot.

  • Ron Herrmann Level 1 Level 1 (50 points)
    Currently Being Moderated
    Feb 6, 2013 10:51 AM (in response to Macsterguy)

    I, too, came here looking for a solution, but accidentally found the solution on my own.

    I have an old HP4MV that still works reliably, so I naturally don't want to delete my HP printer driver software, just to prevent those annoying update reminders.

    Here's what I've found:

    When the update pops up, go to the Mac App Store (MAS), and Right-Click on the update **Name** - then choose "Hide Update".

    If the update is grouped with another update (or other updates), you must first click on the small "More…" button/link to expand the list. Then Right-Click on the **Name** of the specific update you want to hide.

  • zeichensprecher Level 1 Level 1 (55 points)
    Currently Being Moderated
    Apr 25, 2013 3:18 AM (in response to Macsterguy)

    I had the same issue on 10.8.3: The Mac App Store was showing the 1 update badge, as was the tabBar, but as soon as I changed to the Updates tab, it said "No Updates available".

     

    I could fix it by switching to the "Purchases" tab left to the Updates Item and I found one app that I could update. That fixed it.

  • alexmandl Calculating status...
    Currently Being Moderated
    Jun 7, 2013 4:23 AM (in response to zeichensprecher)

    I'm experiecing the same problem with 10.8.4. It keeps prompting me to update firmware of my MBA 11. Any workaround is more than welcome.

  • Dah•veed Level 7 Level 7 (29,620 points)
    Currently Being Moderated
    Jun 7, 2013 7:43 AM (in response to alexmandl)

    Have you checked to see if the firmware has actuually taken? Firmware has to be applied while the power adapter is plugged in and supplying electricity.

    Mac mini, OS X Mountain Lion (10.8.4), iPad 4, iPhone 5 (iOS 6.1.4)
  • alexmandl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 8, 2013 5:17 PM (in response to Dah•veed)

    Yeah, I tried that and it's still prompting me.

  • Cowboooy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 2, 2013 2:44 AM (in response to Macsterguy)

    I'm still having these update issues:

     

    I have moved my backups drives into the private folder in Spotlight and rebuilt the spotlight index - no sucess, i have demounted my backup drives and rebuilt spotlight - no success.

     

    I even ran a command in Terminal to force a spotlight index re build again with no success.

     

    This is a pain  - even if i redo the update (which is not needed) it still will not take, the app store keeps asking me to update, I am running FCPX 10.0.8 and it wants to keep updating to 10.0.8 a 1.64 Gbyte download, worse than that i cant update to 10.0.9 as its frozen in this 10.0.8 cycle

     

    help Apple

  • Toyah55 Calculating status...
    Currently Being Moderated
    Oct 12, 2013 4:25 AM (in response to bobbyco57)

    Finally this solved my problem.

    Thanks from the Netherlands bobbyco57

  • Cowboooy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2013 4:15 AM (in response to Toyah55)

    Many thanks to all who offered solutions and replied to me regarding this issue, I finally got it resolved.

    To summarise:

     

    This problem occurs when the App store interrogates you computer to see if any Apps need updating, the App store uses Spotlight (the inbuilt app that tracks all of your hard drives content). the problem arises when you make clones or back ups of your main hard drive (the one that the OS runs on) Index tells the app store you have more than one OS drive and hence the app store keeps wanting to update your machine.

     

    Solution: follow the instructions in this link,

    http://reviews.cnet.com/8301-13727_7-57590306-263/tackle-a-hung-app-store-update -in-os-x/

    The user Worksafe (above)  kindly posted it,

     

    1.- remove your backup drives from the Spotlight list.

    2.- rebuild the spotlight index

    3.- let your machine do its updates

     

    thanks again

  • Bickity Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 16, 2013 4:46 PM (in response to Cowboooy)

    After trying everything, this cnet.com solution finally fixed it once and for all.

  • Michael Battenfield Level 1 Level 1 (135 points)
    Currently Being Moderated
    Jan 3, 2014 9:06 AM (in response to Macsterguy)

    LOLOLOL!!!  I'm running Mavericks, and the problem STILL isn't fixed!!!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.