Skip navigation

Mountain Lion x Adobe CS6

11597 Views 12 Replies Latest reply: Aug 2, 2013 6:25 AM by Kurt Lang RSS
Gilson Victor Calculating status...
Currently Being Moderated
Jan 17, 2013 12:52 PM

How can I do to proceed a correct instalation and fully operating the Adobe CS6 Pack in a OS 10.8.2 Mountain Lion? The CS6 requires a Java SE 6 (the suite don't recognize Java 7!!!!). After uninstalling and activating the Java version 6, that remains invisible in Finder and System Preferences, including the Utilities folder, but appears working in the official Java Tester web page. Until the CS6 recognize a succesful installation of Java SE6, I cannot install the Adobe Illustrator, indeed. How can I do this installation? Where is the Java SE 6 I had installed in my Mountain Lion? Sorry about mistakes and thank you both.

Mac mini, OS X Mountain Lion (10.8.2)
  • William Lloyd Level 6 Level 6 (19,220 points)
    Currently Being Moderated
    Jan 17, 2013 1:37 PM (in response to Gilson Victor)

    Java isn't necessary at all for Adobe CS6, as far as know?  I'm running Photoshop CS6 and I don't even have Java installed on this machine.

  • jimhere Calculating status...
    Currently Being Moderated
    Jan 18, 2013 6:10 AM (in response to William Lloyd)

    I just got this message for Illustrator CS6. Indeed Photoshop opens OK. Odd that Adobe uses different methods...

  • jimhere Level 2 Level 2 (455 points)
    Currently Being Moderated
    Jan 18, 2013 1:38 PM (in response to Gilson Victor)

    I think the reason I was running AI *before* was that I actually had java installed. Now I remember that the IT dept. recommeded removing it. I figured that was mainly for browser reasons. But I guess Illustrator depends on it for secret reasons of its own.

     

    Trying to launch AI gives you a button to install Java, which I clicked (I need to use the app! I had to do it!) So now I have java 1.6.0_37. Maybe I had that before IT said it was bad and just didn't know it.

     

    So I think its more an Adobe thing than an Apple thing...

  • jimhere Level 2 Level 2 (455 points)
    Currently Being Moderated
    Jan 20, 2013 10:52 AM (in response to jimhere)

    I saw this on

    http://securitywatch.pcmag.com/none/307129-if-you-can-t-disable-java-what-can-yo u-do

     

    "Several Adobe applications also require Java to run certain components. Nothing to worry about, as these are standalone Java applications, and not the ones that run within the Web browser."

     

    So... ok... I guess...

  • Chris Welbon Level 1 Level 1 (70 points)
    Currently Being Moderated
    Jan 22, 2013 6:57 PM (in response to Gilson Victor)

    Gilson Victor wrote:

     

    Java is required for Adobe Illustrator, as said by jimhere, in the begin of installation process and during the software operation! But the version 7 just don't be recognized by CS6. So, I've been searching for tutorials to reverse the version, from 7 to SE6, and found this step-by-step instructions in this link:

    http://support.apple.com/kb/HT5559?viewlocale=pt_BR

     

    After this procedures, the Java still don't appearing in Finder, but works fine as Java SE 6 update 37 in Java Tester: http://www.java.com/en/download/testjava.jsp

     

     

     

    I believe the instructions at http://support.apple.com/kb/HT5559 only work if you still have Java 6 installed after installing Java 7. I've tried them and still can't get CS6 to launch with Java 7 installed.  Java 6 for Mac seems to have been pulled from Oracle's site (which makes sense, since they're EOLing it in February) and Apple's existing Java 6 installations (like this one: http://support.apple.com/kb/HT5493, or the risky MacUpdate one at http://macupdate.com/app/mac/39490/apple-java) fail for me because it claims a newer version of that same package is stalled.

     

    So I'm stuck with a non-functional CS 6 that won't recognize Java 7, and no way to download the version it does recognize, so I can hack it together.

     

    Is anyone running CS6 with Java 7?

  • thomas witt Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 30, 2013 12:39 PM (in response to Chris Welbon)

    Is anyone running CS6 with Java 7?

     

    I am, yes. I finally found a solution after hours of searching through different threads. My solution:

     

    1. I went to /System/Library/LaunchAgents and moved com.apple.java.InstallOnDemand.plist away. This suppresses the annoying "Install Java" dialogue
    2. I went to /Applications/Adobe Illustrator CS6/Plug-ins and located the "FXG File Format"-Plugin. It's actually two files, FXGFileFormat.aip and FXGFileFormatUI.aip. I moved them out of the plugins folder.

     

    That's it. Illustrator CS6 now starts and works fine. Hope that helps!

    iMac (27-inch, Late 2012), OS X Mountain Lion (10.8.3)
  • James Chastney1 Calculating status...
    Currently Being Moderated
    May 10, 2013 2:51 PM (in response to thomas witt)

    Hi,

    Was having the same trouble since i got rid of java 6 and don't want Java 7 installed, just deleted:

     

    FXGFileFormat.aip

     

    &

     

    FXGFileFormatUI.aip

     

    From /Applications/Adobe Illustrator CS6/Plug-ins folders now CS6 works fine without any form of java installed!

     

    james.

  • Kurt Lang Level 7 Level 7 (31,495 points)
    Currently Being Moderated
    May 10, 2013 3:24 PM (in response to Gilson Victor)

    Hmm, not seeing any of these issues. I do have Java 7 installed, but that doesn't seem to make any difference with the Adobe CS6 Master Collection. Illustrator, Photoshop and all other apps work without issue without Java 6 installed, or removing any of the items mentioned above by thomas witt or James Chastney1.

  • Xevio.us Calculating status...
    Currently Being Moderated
    Aug 2, 2013 4:55 AM (in response to thomas witt)

    Thanks for the tip about FXGFileFormat and FXGFileFormatUI. I removed those and was able to run Illustrator. However when Adobe Update Manager tried to update Illustrator to version 16.0.4, the update failed with an error U44M1P7.

     

    Adobe Illustrator CS6 Update (version 16.0.4)

    Installation failed. Error Code: U44M1P7

     

    The solution was to restore the two missing plug-ings. Fourtunately I did not delete the plug-ins but moved them to a new folder I called "Plug-ins (Disabled)". The updater ranto completion and both plug-ins were updated from MXGFileFormat version 16.0.0 to 16.0.3. I decided to try to run Illustrator with the plug-ins in place and it launched successfully.

     

    Either Adobe has removed Java from those plug-ins or updated it to recognise Java 7 which I have installed. I've never had Java 6 or older on this computer. So with this update, the issue seems resolved.

  • Kurt Lang Level 7 Level 7 (31,495 points)
    Currently Being Moderated
    Aug 2, 2013 6:25 AM (in response to Xevio.us)

    Installation failed. Error Code: U44M1P7

    That has been a pretty common error message with the CS6 apps in particular. Your fix meant that the update was trying to update two components (the plug-ins) it couldn't find in the location it expected them to be. Adobe has never been good about just skipping things like that. If it isn't there, go past it! Nope, it stops.

     

    You get errors like that even if you manually remove something extremely simple and useless, like EULA PDF files in languages you can't read. If they have a change, the update stops. Why!? I don't care about a PDF in a language other than the one I left which I can read.

     

    You were fortunate indeed to figure out an easy one for that. Usually, you end up having to uninstall and reinstall the app to get an update to work.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.