Skip navigation

Changing permissions on my Time Machine backups.

2042 Views 13 Replies Latest reply: Aug 3, 2013 11:23 AM by Eric Root RSS
Murgy1 Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 10, 2013 8:01 AM

What would be a quick way to change permissions on 33 TM backup dates?  All I'm interested in is the Documents folders.

 

My new laptop has a different user ID than the one it replaced. I am unable to view the contents of my Users/oldUserID folders in any of the TM backups. I realize TM won't restore to a different computer so wish to copy some older Documents folders to the new computer. I am missing some files which may have not been in the Time Machine backup Migration Assistant used when the new laptop was set up at the Apple Store last year. I was able to change permissions for one userID directory in one TM backup but not for the subdirectories. I thought it would take less time to change permissions for the entire TM backup folder for the old laptop. I was wrong. In Get Info > Sharing & Permissions for the TM backups of the main MacBook folder the Names are greyed out and one says "Fetching...".

What does "fetching" mean wrt users on a directory tree?  Is it looking for all the users? How long should that take? Folder contains 990 GB, computer sleep=Never. This has taken over 24 hours and I have no idea what, if any, progress is being made with the fetching or with my attempting to change permissions down the directory tree.

 

System is using MacOS X.8.4

 

Message was edited by: Murgy1

MacBook Pro (13-inch Late 2011), OS X Mountain Lion (10.8.2)
  • Daniel Ebeck Level 4 Level 4 (1,540 points)
    Currently Being Moderated
    Jul 10, 2013 8:57 AM (in response to Murgy1)

    Are you doing this through the TM interface, or have you mounted the dmg on the desktop?

     

    990GB is a lot of data...

  • Eric Root Level 6 Level 6 (13,790 points)
    Currently Being Moderated
    Jul 10, 2013 9:22 AM (in response to Murgy1)

    You might be able to inherit the backup using the information in the 1st two links. The third link is general troubleshooting.

     

    Inherit a Backup


    Inherit a Backup (2)

     

    Time Machine Troubleshooting

  • Linc Davis Level 10 Level 10 (107,375 points)
    Currently Being Moderated
    Jul 10, 2013 9:56 AM (in response to Murgy1)

    Turn Time Machine OFF temporarily in its preference pane. Leave the window open.

     

    Navigate in the Finder to your backup disk, and then to the folder named "Backups.backupdb" at the top level of the volume. If you back up over a network, you'll first have to mount the disk image file containing your backups by double-clicking it. Descend into the folder until you see the snapshots, which are represented by folders with a name that begins with the date of the snapshot. Find the one you want to restore from. There's a link named "Latest" representing the most recent snapshot. Use that one, if possible. Otherwise, you'll have to remember the date of the snapshot you choose.

         

    Inside the snapshot folder is a folder hierarchy like the one on the source disk. Find one of the items you can't restore and select it. Open the Info dialog for the selected item. In the Sharing & Permissions section, you may see an entry in the access list that shows "Fetching…" in the Name column. If so, click the lock icon in the lower right corner of the dialog and authenticate. Then delete the "Fetching…" item from the access list. Give yourself read access if you don't already have it. Click the gear icon below the list and select Apply to enclosed items from the popup menu.

     

    Now you should be able either to copy the item in the Finder or to restore it in the time-travel view. If you use the time-travel view, be sure to select the snapshot you just modified. If successful, repeat the operation with the other items you were unable to restore. You can select multiple items in the Finder and open a single Info dialog for all of them by pressing the key combination option-command-I.

      

    When you're done, turn TM back ON and close its preference pane.

  • Linc Davis Level 10 Level 10 (107,375 points)
    Currently Being Moderated
    Jul 13, 2013 9:54 PM (in response to Murgy1)

    Don't empty the Trash securely.

  • Eric Root Level 6 Level 6 (13,790 points)
    Currently Being Moderated
    Jul 14, 2013 8:35 AM (in response to Murgy1)

    Information.

     

    Trash – Can’t Empty or Move File To Trash

     

    Trash FAQ       

                                 

    Trash – Empty When File is Locked or in Use

  • Linc Davis Level 10 Level 10 (107,375 points)
    Currently Being Moderated
    Jul 14, 2013 10:20 AM (in response to Murgy1)

    It's not clear whether you tried to empty the Trash insecurely with the option key down.

     

    By the way, there's a tendency for people to make comments on this site to the effect that you should empty the Trash using a shell command (in Terminal.) Don't do that.

  • Eric Root Level 6 Level 6 (13,790 points)
    Currently Being Moderated
    Aug 3, 2013 11:23 AM (in response to Murgy1)

    Move the files you want to keep to your desktop, empty the trash, and then return the desktop files to the trash.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.