Skip navigation

Garageband unable to locate sampler instruments?

1036 Views 7 Replies Latest reply: Aug 6, 2013 5:46 PM by Sky5tudent RSS
Sky5tudent Calculating status...
Currently Being Moderated
Aug 4, 2013 6:38 PM

EXS24 instrument (ect ect ect)

Audiofile not found. I see the files in the sampler library in /library/application support/garageband/instrument library/sampler/sampler instruments

 

All the files are there. I tried the spotlight thingy too and it still doesn't work. HELP! ;'(

GarageBand (Mac) '11, Mainstage 2013
  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Aug 5, 2013 12:48 AM (in response to Sky5tudent)

    Are all sampler instruments not found, or only some of them. If it are only some instruments, is it one of the instrumets you installed with MainStage? Could you post the names of some of the missing audio files, so we can check, where that particular instrument should be installed?

  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Aug 5, 2013 12:46 PM (in response to Sky5tudent)

    For me all these instruments are recognized and are playing well. Are yours from MainStage 2 or MainStage 3? My installation is from MainStage 2.

     

    Originally I had a few instruments that were not found, because for a few instrument samples the names seem to have changed between the original JamPAck versions and the versions included in MainStage.

     

    And the original JamPacks prevented the installation of the newer files, that MainStage wanted to download.

     

    What helped, was to delete the Instrument Library completely (I copied it to a different drive for safe keeping), also the Loop Folders, and then install again first GarageBand and then MainStage 2, and reloaded the additional contents in MainStage 2.

     

    I actually uninstalled Garageband and Mainstage together deleting all their files, and reinstalled them again,

    What were the files you removed?

    I removed all files in

    /Library/Application Support/GarageBand/Instrument Library/

    and

    /Library/Audio/Apple Loops/Apple/

  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Aug 5, 2013 11:57 PM (in response to Sky5tudent)

    Empty the Trash is not necessary - just putting it into the Trash should suffice.

     

    the "Logic Pro & Mainstage Additional Content"

    A week ago MainStage 3 and LogicPro X have been released. I sincerely hope, that this has not removed the support for the download of MainStage 2 files.

     

    Send a bug report to Apple: Apple - GarageBand - Feedback

     

    If your Mainstage 2 is a recent aquisition, I'd contact Apple Support and request help with downloading those files.

     

    Is there any other solutions I could try?

    Try, if you can download additional contents with the software update tool from the Terminal, see mteeps post here:  I never tried, if that will work for MainStage loops:

    Re: GarageBand '11 won't download additional loops

  • léonie Level 8 Level 8 (46,355 points)

    Added:

     

    I just tried again to download the additional content on my iMac and it worked well - perhaps there simply was a transmission error. Have you tried again?

    Screen Shot 2013-08-06 at 11.46.58.png

     

    Check, if the Logic <pro Additional Content has been installed in

    /Library/Application Support/Logic/Sampler Instruments/

    instead of

    /Library/Application Support/GarageBand/Sampler Instruments/

     

    You could try to copy the instruments to the GarageBand folders.

     


Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.