Skip navigation

Stop safari from opening new tabs every link click?

4443 Views 8 Replies Latest reply: Nov 28, 2013 5:09 PM by stoffert RSS
jennakay_3 Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 23, 2013 8:41 PM

Not sure when it started, all I know is that it's been very iritating ever since. 

 

On the pad, phone, mac, and mac book, web browsing has become a pain in the a$$ because every (ok high 90%) on a link opens a new tab on the macs a new browsing window on the phones....in a minute or so the macs have 10 taps open and the phone is maxed out with 8 new windows all on the same thing.

 

 

 

 

how do i switch this off?  I just want the "old?" way where i got one window and the web session can move forward and back at my choosing in the same tab, and if i want to open a tab, i right click on the link and select "open in new tab"

 

 

Whatever happened to that?  Am I the only one who hates this new way of safari operating?

 

Thanks.

iMac
  • Carolyn Samit Level 10 Level 10 (84,160 points)

    Might not be Safari causing the problem ...

     

     

    If you are using iCloud to sync Bookmarks between OS X and iOS devices ...

     

    On the Macs, open System Preferences > iCloud

     

    Deselect the box next to Safari then reselect it.

     

     

    On iOS devices, tap Settings > iCloud

     

    Switch Bookmarks off then back on.

     

     

    Give iCloud a few minutes to resync the data.

     

    See if that made a difference.

  • Erick Mikiten Level 1 Level 1 (25 points)

    I'm having what I think is the same problem. I click on a link in Apple Mail, say, and Safari opens with that link AND a tab behind showing my Home Page. This seems to slow the loading of the page I clicked on, so I wanted to turn it off.

     

    In Safari, go to menu Safari > Preferences, then click on the Tabs icon. UNcheck the checkbox called "When a new tab or window opens, make it active". That checkbox name is not a very clear description of the results we see, but it will fix it.

  • rockpapersmiles Level 1 Level 1 (0 points)

    I'm having the SAME problem.. I don't think the guy who responded to your post understands what you mean.

     

    Google search: Cowboys game

    Click on first link in Google search = a new tab pops up.

    Then you click a link, for fun & common sake.. let's say "Players"... then, a new tab (which automatically becomes active) pops up with player info.

     

    You now have THREE active safari tabs open, all for the same search.

    How do you enable one-click, one-window; unless I opt for a tab... options?

  • stoffert Level 1 Level 1 (0 points)

    I also have this problem. And it is recent. No matter which link I click, it will take me to the webpage (which I want) AND open a blank new window in the back (which I don't want). HELP!

  • sf340b Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2013 10:38 AM (in response to stoffert)

    Here is what I am experiencing.

     

    Randomly Safari additionally opens a new blank window or tab when I click on a link.

     

    I have changed preferences to verify the window or tab and my preferences are for Safari to open blank.

     

    So, a random click will open the link as I have preferenced (in the current window or in a new tab or whatever) AND Safari opens a new blank tab (or window depending on preference setting). 

     

    *** Safari?  I did not ask for the duplicate opening so something is up.  And that something is wrong.

     

    Let the wizards explain.

  • sf340b Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2013 2:23 PM (in response to sf340b)

    May have a fix per Bill;

     

    "I am seeing the same problem in Snow Leopard and Safari 5.1.10 as are many other people with various versions of Safari on several forums.

     

    I've done routine maintenance including emptying caches and clearing out cookies. I've changes tab/window preferences to update Safari's plist all without effect. The blank full-screen window in the background has no code. I've even looked for differences in the HTML and CSS from the originating pages gotten from Chrome and Safari. No differences.

     

    The only thing I can remember changing was a Glims update which dated 11/25/13. Since Glims messes with Tabs it is possible.

     

    This is a pain.

     

    Bill"

     

    https://discussions.apple.com/message/23948654#23948654

  • stoffert Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2013 5:09 PM (in response to sf340b)

    sf340b - that was the trick for me. Although I didn't install the latest update - it somehow still changed my settings in Glims. a BIG thank you.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.