Skip navigation

iCal not connecting to Google Calendar - HTTP 404 error

68331 Views 120 Replies Latest reply: Apr 16, 2014 12:32 PM by CussinSailor RSS
  • isaac* Level 1 Level 1 (10 points)

    I'm having the same issue. This is ridiculous!

  • isaac* Level 1 Level 1 (10 points)

    Thank you! Your trick (clearing the iCal cache) fixed my problem! --> http://kb.mit.edu/confluence/pages/viewpage.action?pageId=12386508

  • Fulltime_AIrstreamer Level 1 Level 1 (0 points)

    Had a similar problem with iCal unable to login into Google. I kept getting server did not recognize username password combination. Checked this site: http://support.google.com/calendar/bin/answer.py?hl=en&answer=99358&topic=13949& ctx=topic

     

    Went through the instructions for iCal 5.x and up and discovered that problem was cockpit error. I had changed how I interact with Google to 2-step verification. I followed the instructions and created an application specific password for iCal. Plugged the password in and I am back in synch.

  • Basho.a Level 1 Level 1 (0 points)

    Hey guys, i HAD the same issue - i fixed mine hope this helps + hope i hasn't already been said.

     

    Under the heading 'Google' Delete the calender causing the issue. If it is under any other heading delete it there too. In preferences, take accounts offline by unticking 'enable this account' expically if a google account is linked to the mac (mine was) then click your link again and it'll import the same, then you should be able to enable the accounts and cross finglers it'll work fine!

  • NeuroBrain Level 1 Level 1 (0 points)

    I had the issue for months and was part of this discussion months ago. But some time ago, my issue was somehow fixed - I didn't do anything to fix it.

  • oliverj Level 1 Level 1 (0 points)

    Following those directions (http://kb.mit.edu/confluence/pages/viewpage.action?pageId=12386508) plus deleting my accounts in System Preferences and re-adding them fixed it for me as well.

     

    For good measure, I deleted ~/Library/Calendars directory entirely.

  • zozohan Level 1 Level 1 (0 points)

    Hey, I had problems adding a calendar from a website (adding an URL to my Google calendar):

    the web calendar wouldn't sync/work...

     

    For info my iCal was setup to sync with my Google account that had different calendars, one of them being the non-woking url.

     

    This was all because of the provider, because my online Google calendar nor iCal would work.

    The online Google calendar would simply not show anything from this newly added web calendar (no big deal), but iCal would give me the famous 404 error, refusing to work properly after that (really annoying).

     

    The problem was, as easy it is to add a calendar sync on an URL, that you cannot see nor delete the url calendar if there is that specific error 404. What to do then?

     

    I tried deleting and adding my Google account from iCal but nothing...

     

    It actually resolved when I deleted my Google account from iCal once again, then deleted (and NOT simply not displaying) the problematic calendar online in my Google calendar.

    Then adding my Google account once again to iCal, everything worked smoothly again.

     

    Hope that helps some of you!

     

    Cheers

     

    Yo

  • rob0mitch Level 1 Level 1 (0 points)

    I don't know if this is the place for this solution, but I found a simple fix for syncing [max osx 10.8.4 - calendar via caldav] with almighty google.

     

    I changed my login from *@gmail.com to @googlemail.com and it seems to be still working. After thirty minutes. If feels good tho!

     

    Hope it helps somebody with this very annoying problem.

     

    Rob

     

    35minutes....

    p.s. i did flush some Library stuff according to one of the steps suggested in these forums. but didn't feel that was the problem after seeing the ongoing and  pained responses.

    40 minutes...

    holding my breath...

  • rob0mitch Level 1 Level 1 (0 points)

    I posted this on the end of the thread...

    I don't know if this is the place for this solution, but I found a simple fix for syncing [max osx 10.8.4 - calendar via caldav] with almighty google.

     

     

    I changed my login from *@gmail.com to @googlemail.com and it seems to be still working. After thirty minutes. If feels good tho!

     

    Hope it helps somebody with this very annoying problem.

     

    Rob

     

    35minutes....

    p.s. i did flush some Library stuff according to one of the steps suggested in these forums. but didn't feel that was the problem after seeing the ongoing and  pained responses.

    40 minutes...

    holding my breath...

     

    And now I'm 'dead'.

     

    Well, dead certain at least that it is a fix for me with all the 404s and the 'location that does not support this request' and the re-appearing moved and deleted appts and annoyance I was getting between mac and google calendars.

  • rob0mitch Level 1 Level 1 (0 points)

    double dead.

    so thus re-incarnated

    for the sake of sceince i deleted the account and added it again with the @gmail login. and sho nuff

     

    The server responded:

    “403”

    to operation CalDAVWriteEntityQueueableOperation.

     

    So i removed the account again and tried to put in the @googlemail login.

    HERE I discovered another detail in the problem. The Automatic setting FORCED RESOLVED MY LOGIN NAME back to @gmail.com.  Didn't work. (see above).. . So I chose CalDav on the options. The server is : calendar.google.com .  The important thing is It kept kept my login name with @googlemail.com. (It may be the other way around for you - googlemail to gmail. I noticed on my google calendar settings online, my username in the list below. (in settings / sharing)  has " quotes  " around it - it's it's in the '@googlemail' form.

     

    I'm scared to try it again. But you can. Take it to your labs.

    Please consider this one published. It's working fine for me

    Good Luck!!!

  • rob0mitch Level 1 Level 1 (0 points)

    ..to extend this conversation with mysef. I see @ottootoo

    on this thread https://discussions.apple.com/message/20501104#20501104

    had this solution back in 2012. and found problems later 

     

    For now, at least, I am grateful it is still working for me.

    So should work for some others too.

    at least for a while.

  • Robbo2010 Level 1 Level 1 (0 points)

    We have a mixture of Windows and Apple users in our company.

     

    Before the latest OS X update the situation was worse; ANY calendar entries created by the Windows/Outlook users would cause this error.

     

    After the latest OS X update, the situation is slightly improved.  Now the FIRST calendar entry comes into Mac Calendar without any problems.  But if that entry is updated (eg the date changed) then we see the same error.

     

    Two steps forward, one step back it seems.

     

    We tried some of the weird and wonderful work-arounds described, but none of it worked.  The only soln is for Apple to get off their backsides and do some thorough testing.

  • rob0mitch Level 1 Level 1 (0 points)

    Thanks for the update Robbo.  I missed the worst-ness it would seem.  As it happens, I am on transition as a former windows user who is now at least three months 'clean'! Tho, for some reason(!) I still have an Exchange account.

     

    However during these few months, the calendar was working fine until upgrade to OSX 10.8.4.  After that Exchange was still synching fine but problems started with Google Calendars, with errors on any changes I tried to make from Mac Calendar.! 

     

    The username @googlemail thing worked in this circumstance.

     

    Rob0

  • defilm Level 1 Level 1 (0 points)

    Exactly as Robbo stated.  THis is a major problem.  Everytime the secretary or anyone on Windows Outlook changes the meeting, often just moves it back an hour, the changes take place with no issues on Max OS X.

    The error comes about on SYNC and icloud tries to sync the change of the meeting in the local ical to the ical on icloud. 

     

    Apple indeed has to fix this problem, or we really have no choice here but to move to OUTlook.  Outlook on the MAC has it's issues as well, hence why we all moved back to ical.  This is just pretty sad Apple chooses not to fix this problem.  I have submitted a ticket 3 times.  They keep pointing me at the forums!

     

    This months MACWORLD notes that APPLE leads the pack in "customer service".  I would like to see the results in 6 more months.  We live and die by our business calendars and the ability to sync across multiple devices.  If I have to move off ical, I won't use MAC Outlook,  I will pick up a new Windows tablet/PC, run windows 8, and switch back to Windows never to migrate to Mac again.  Heck, I can run VMWARE there and pull up Solaris, and Linux on the hardware that will run Win8, and even get 64GB RAM in there with a dual quad core with the same 512GB SSD and dirt cheap compared to Apple hardware.....  It is really too bad as I have come to love my Apple products "It just works".... 

  • eXcuvator Level 1 Level 1 (0 points)

    "The URL https://calendar.google.com/calendar/dav/******@googlemail.com/user///calendar.google.com/calendar/dav/******@googlemail.com/user/ encountered HTTP error 404. Make sure the URL is correct."

     

    So, it didn't help..

1 ... 5 6 7 8 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.