Skip navigation

detaching audio troubles

2700 Views 12 Replies Latest reply: Aug 7, 2013 8:49 AM by reynolds washam RSS
Crystal Dittrick Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 27, 2011 1:33 AM

Hello,

I am having troubles with detaching audio on my imovie 11 project (updated version of imovie 11 9.0.2).

 

I have detached about 20 clips for a movie I am making for my sister-in-law's wedding...various clips from different sources such as video cameras, youtube, etc. NOW all of a sudden whenever I detach a audio clip there is NO SOUND...the ones I had done previously still work BUT any new detached audio does not have sound...when I hit undo and put the audio back attached...it works again...HOWEVER, I need the audio detached as I am interlacing pictures with audio and video where some needs sync'd audio (with the associated video) and some of the audio needs to be a voiceover above other pictures and videos.

 

Please help!! I really do not want to let down my sister in law...the video was almost done and I thought I would finish tonight BUT now I have been struggling for a few hours and she wants it done ASAP.

 

Thanks, Crystal

MacBook AIr
  • John Cogdell Level 5 Level 5 (4,595 points)
    Currently Being Moderated
    Apr 27, 2011 3:01 AM (in response to Crystal Dittrick)

    Hi Crystal,

     

    Pardon me asking, but are you sure you need to detach the audio? Are you moving the detached audio to different locations in your Project - is that why you are detaching it? Would it work for you if you simply adjusted volume levels on individual tracks, and/or used the Ducking feature in the Inspector - Audio tab? Another thought is to use the Cutaway feature where you can place video or stills over an existing clip whilst retaining the audio on the existing clip (or vice versa).

     

    iMovie '11 has quite a few new audio features (some hidden away) that may work for you, rather than detaching audio.

     

    Just thought I'd throw a few thoughts at you - you never know what might help!

     

    John

  • John Cogdell Level 5 Level 5 (4,595 points)
    Currently Being Moderated
    Apr 27, 2011 3:37 AM (in response to John Cogdell)

    Another point. When you double-click on the detached audio, in the Inspector that opens is the volume slider set to an appropriate level, or is it muted (at zero level)? I saw another post recently where it was commented that sometimes when detaching audio the volume becomes muted. Certainly on the video track itself (from which the audio was detached), the volume will be lowered to zero. The audio doesn't actually get removed from the video - it's still intact but now silent. The detached audio is just a copy of the original audio embedded in the video.

     

    So, check the detached audio levels either in the Inspector or on the volume line in the waveforms under the audio track. Also, make sure that other audio tracks (if any) running parallel with the detached audio don't have Ducking activated, where ducking is set to zero volume for the other tracks. To check this, double-click on all other tracks in turn to open the Inspector. Now look at Ducking in the Audio tab. If the check box is ticked, you need to uncheck it.

     

    John

  • John Cogdell Level 5 Level 5 (4,595 points)
    Currently Being Moderated
    Apr 27, 2011 3:51 AM (in response to Crystal Dittrick)

    Looks like my last post (which I was editing) crossed paths with your last post Crystal, but you've covered all the points.

     

    You might find my discussion in this post of interest. Particularly Shawn's last post.

    https://discussions.apple.com/message/15073319#15073319

     

    If I think of anything else I'll get back to you promptly. For example, you may need to delete iMovie's preference file. Come back if you need help with that.

     

    John

  • John Cogdell Level 5 Level 5 (4,595 points)
    Currently Being Moderated
    Apr 27, 2011 5:12 AM (in response to Crystal Dittrick)

    I've been away from my Mac - just got back. One thought I have - open one of the problem clips in QuickTime 7 (you may need the Pro version). Save the clip as an audio file. To do this, in the QT menu select File>Export. In the Export window, for Export choose Sound to AIFF and save it to your Desktop. Import that file into iTunes so you can access it from the Music Browser panel in iMovie. Now drag it into the appropriate place in your Project and trim as desired. Mute the original track in that section of the original clip that you are covering with the new audio.

     

    I may have worded this a bit clumsily, but I think you will understand where I'm coming from. Trying to get it to you as quickly as I can.

     

    Note: QuickTime X may also be able to do this - I'll check and come back. Also, GarageBand might do the trick.

     

    John

     

    Message was edited by: John Cogdell

  • John Cogdell Level 5 Level 5 (4,595 points)
    Currently Being Moderated
    Apr 27, 2011 5:22 AM (in response to John Cogdell)

    Forget QuickTime X. Also, don't worry about QT 7 Pro if you don't have it. Use MPEG Streamclip, available from Squared 5 here: http://www.squared5.com/svideo/mpeg-streamclip-mac.html

     

    MPEG Streamclip is free. Open your clip (or Clips) in Streamclip and from the menu choose Export Audio. You will be presented with a window like this:

     

    Screen shot 2011-04-27 at 9.49.05 PM.png

     

    Save and import to iTunes as I described earlier.

     

    Hope this does the trick for you Crystal.

     

    John

  • Bojan Landekic Calculating status...
    Currently Being Moderated
    Dec 28, 2012 4:49 AM (in response to Crystal Dittrick)

    I have a solution that works perfectly!

     

    Executive Summary:

    DELETE ANY GREEN CLIPS WHICH HAVE YELLOW TRIANGLES!!!!!

     

    Full Details:

    I was working on a tiny project, maybe 14 minutes about violence on television, and I wanted to add background music.  So I added an aiff file at the start, but NOT as a background track.  Then I did some desktop cleanup and I moved that file into a folder for my film's resources.  I didn't think it would be a problem since I alreay added it to iMovie.  I figured iMovie worked like iTunes in that it copied it's media to it's own folder!

     

    WRONG!

     

    Suddenly the background sound didn't work anymore.  I looked at my project, and now there was a tiny little yellow triangle only at the front of the green audio clip.  None of the clips that reference the moved file worked anymore!  Pathetic of Apple, really!  I double clicked it, there is NO WAY to pick the new location of that clip.  You have to delete it from the project and make all the adjustments again.  So i tried adding it again, however this time, it was completely silent.  I figured maybe iMovie doesn't support properly AIFF files made by Audacity.  Then I tested other portions and noticed that many of my detauched audio clips weren't playing either.

     

    This ****** me right off.  iMovie '11 has a TON of bugs if you've used it fully.  It is absolutely pathetic of Apple to have released it!!!    So I read on here that I can use a cutaway by dragging a video on top of another video, so I used the clip trimmer to extend a cut clip to cover the additional minute that was detached.  This was problematic since you can only extend a clip by 10 seconds at a time.  Another stupid crippled feature by the geniuses at Apple!  But I am immortal, so I wasted my time.  And I used cutaway without detaching audio, and it worked.  Then I tried adding a crossfade, and discovered this was another crippled feature!  You can't add a transition onto a cutaway.  This absolutely angered me.

     

    I looked throughout my entire project.  And I found at the very end another broken green clip with a yellow rectangle from the background track I used.  I used it for both opening and closing!  I deleted it!

     

    And ta-da!  All my detached audio clips started working properly again!!!!  Everything is now okay!

     

    I know it's a year late, but I hope it helps others.  Since Apple clearly has NO PLANS to fix iMovie nor add features which we already paid for in '06!!  Really pathetic that a company can remove a room from your house without penalties!!

  • kaitmckinney Calculating status...
    Currently Being Moderated
    Apr 25, 2013 8:08 PM (in response to Bojan Landekic)

    THANK YOU!!! This has just saved me hours of redoing everything on Final Cut Pro.

  • reynolds washam Calculating status...
    Currently Being Moderated
    Aug 7, 2013 8:49 AM (in response to Bojan Landekic)

    Bojan,

    You just saved me hours and hours of work and frustration. Thank you so much. Apple is definitely not perfect, but better than PC.

    Thanks for sharing your discovery. I'm in debt.

    reynolds

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.