Skip navigation

Random hanging while import?

2268 Views 28 Replies Latest reply: Jan 4, 2014 1:10 PM by Photron RSS
  • léonie Level 8 Level 8 (46,525 points)
    Currently Being Moderated
    Aug 7, 2013 10:53 AM (in response to aapl.crox)

    O.k., than a library corruption is more likely.


    Try a rebuild, after you checked, that your backup of the library is current.


    You said, that the repair (permissions, database) did not help, right?


    Just to exclude another rare issue: You never said, how your library originally has been created. Did you import an older iPhoto library as library, with smart albums? That has occasionally caused weird hangs in Aperture. In that case it would help to delete all smart albums imported from iPhoto.

  • Courier_Six Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2013 5:15 AM (in response to aapl.crox)

    I was running into similar problems all the time, just like you. All the standart recommendations (repairing/rebuilding/recreating library, two different macs, cameras, file types, etc) led to nothing, same hangs when importing and saving preview. One day I eventually deleted that "iStat Menus" system monitoring app and since then, everything is just fine. Imports go as they should, no more stalls. Seems like some sort of low-level incompatibility between two apps. Maybe this will help.

  • léonie Level 8 Level 8 (46,525 points)
    Currently Being Moderated
    Nov 7, 2013 6:17 AM (in response to Courier_Six)


    Interesting - iStat Menus version 4.1 claims to be compatible with Mavericks. What was the version that you were running?

  • Courier_Six Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2013 7:16 AM (in response to léonie)

    It was exactly iStat Menus 4.1, running on Mavericks. Also it's worth noting that the problem persisted with prior versions of iStat Menus and OS X, back to 10.6 as far as i remember. I had that strange import behavior all the time back then.

  • Courier_Six Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2013 9:17 PM (in response to léonie)

    Freeze happened again. This time I have launched System Monitor app and came across this:


    "QTKitServer-(375) Aperture" process not responding

    Снимок экрана 2013-11-12 в 8.47.21.png

    While Aperture itself looks like this (import activity stopped at 38%) while responding and working just fine except that import job stalled

    Снимок экрана 2013-11-12 в 8.48.43.png

    And in System Monitor...

    Снимок экрана 2013-11-12 в 8.48.08.png

    After i have terminated that QTKitServer process, nothing has happened


    I did "killall Aperture" in console, and started Aperture again

    Hung project showed 0 photos, while 1197 items were in trash with broken reference badges (exclamation in yellow triangle)


    I trashed the trash and did the import again. This time it worked as it supposed to.

    I don't know, maybe it is because of cyrillic symbols in the name of importing folder. Next time will try to catch this bug with latin folders.


    I'm on MacBook Pro 13 Retina late 2012, Mavericks, Aperture 3.5.

    Library is newly created on external LaCie Rugged 1Tb hard drive connected via Thunderbolt

    Importing folder is on the same drive. However, issue happened with different hardware combinations and OS X versions back to 10.6 as i mentioned before.

  • Altan Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 17, 2013 7:06 AM (in response to aapl.crox)

    Found this thread... I'm having EXACTLY the same problem.   Aperture gets stuck importing a single file (when I do a folder import).   I also found that when I try and quit Aperture during this condition, it will not quit.   It gets stuck "canceling" and I need to force quit.


    I've deleted my library and tried a couple of times... the file it gets stuck on changes.   I can "start from scratch" because I'm trying to build a new Library --- so corruption of the Library isn't a problem.


    For the files I've seen it get stuck on, I can preview them just fine with Preview and even open them in a Windows version of Photoshop (in a VM).


    This is Aperture 3.5.1 on Mavericks on a "Late 2009" 27-inch iMac (i5).


    Quite disappointing.   Importing is never something you want to question... as it's very difficult to prove the entire import was successful.   This leaves you wondering whether other files are being skipped.   And, of couse, it's simply not usable.

  • Courier_Six Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2013 11:22 AM (in response to Altan)


    This one helped me.. at least I don't force quit Aperture when it hangs on import anymore - yes, you can't just simply cancel the hung import process, as it shows "Cancelling" forever and activity wheel spinning all the time.

    Running 'killall Aperture' though console does the job of "soft exit" in such cases and does seem to tell Aperture to close opened Library pretty much safely, and there's no need to repair it every time when it happens.

    When I open Aperture after that, there's empty project and a trash folder full of unimported items.

    So, all that you need is to get rid of them and import files again.

    Hope someone at Apple will fix this one day.

  • AxeBox360 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 29, 2013 1:12 PM (in response to Courier_Six)

    Thanks for sharing this . I just got Aperature, and it kept getting stuck on generating Thumbnails. Through trial and error I found and moved the files that got stuck on, restarting the import every time. Finally it got through the non-troublemaker files .



    Did you locate the source of your problems? I put my troublemaker files into a separate folder so that I can examine them for something in common that caused Aperture not to like them.

  • Courier_Six Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2013 3:56 AM (in response to AxeBox360)

    Problem is, it hangs randomly. So there's no chance of isolating "troublemaker" files because it is Aperture that makes trouble. As I wrote before, "killall Aperture" command in console does the job. On next launch Aperture simply copies all files to project and lets you to continue working with them.

  • Photron Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 4, 2014 3:15 AM (in response to Courier_Six)

    I too have this problem. Bought a new Macbook Pro Retina 13" on nov 29th 2013. Installed Aperture and started to import images from an external USB3 drive and encountered this problem immediately.


    So in terms of "fresh", my setup is as fresh as they come. So this is definitely a problem with Aperture.

    And it's a huge one at that becuase if you can't import images into your image program it's pretty much useless.


    Apple, PLEASE fix this!

  • Photron Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 4, 2014 1:10 PM (in response to Photron)

    This guy seems to have the same problem

  2010!!!! How could Apple not do anyting about this?

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.