Skip navigation

Macbook pro 10.8.4 will not connect automatically to wifi

5277 Views 16 Replies Latest reply: Oct 19, 2013 9:25 PM by drkmenon RSS
1 2 Previous Next
ARMartinez0984USN Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 20, 2013 5:36 PM

I have a Macbook Pro with Mountain Lion v. 10.8.4 and it will not automatically connect to wifi after waking from sleep. Any advice I've tried everything I've seen already anything new that might help.

 

Thank you,

Alex

  • Linc Davis Level 10 Level 10 (107,830 points)

    Is the network listed as a Preferred Network in the Network preference pane, and if so, do you have the same problem with other preferred networks?

  • Linc Davis Level 10 Level 10 (107,830 points)

    Are there any other preferred networks, and if so, do you have the same problem with them?

  • Linc Davis Level 10 Level 10 (107,830 points)

    Back up all data before making any changes.
         
    Step 1
      
    Take all the applicable steps in this support article.
      
    Step 2
       
    If you're running OS X 10.8.4 or later, run Wireless Diagnostics and take the remedial steps suggested in the summary that appears, if any. The program also generates a large file of information about your system, which would be used by Apple Engineering in case of a support incident. Don't post the contents here.

    Step 3

    If you're not using a wireless keyboard or trackpad, disable Bluetooth by selecting Turn Bluetooth Off from the menu with the Bluetooth icon. If you don't have that menu, open the Bluetooth preference pane in System Preferences and check the box marked Show Bluetooth in menu bar. Test. Continue if you find that Wi-Fi is faster with Bluetooth disabled.

    From that same menu, select Open Bluetooth Preferences. If the box labeled Discoverable is checked, uncheck it. Click the Advanced button, and in the sheet that opens, uncheck the top three boxes, if any are checked. Click OK. Enable Bluetooth and test again.

    If the application called "Bluetooth Setup Assistant" is running, quit it.

      
    Step 4

    This step will erase all your settings in the Network preference pane. Make a note of them before you begin, and recreate them afterwards. It may be helpful to take screenshots of the preference pane.

    Triple-click the line below on this page to select it:

    /Library/Preferences/SystemConfiguration

    Right-click or control-click the highlighted line and select

    Services Reveal

    from the contextual menu.* A folder should open with an item named "SystemConfiguration" selected. Move the selected item to the Trash. You may be prompted for your administrator password.

    *If you don't see the contextual menu item, copy the selected text to the Clipboard (command-C). In the Finder, select

    Go Go to Folder...

    from the menu bar, paste into the box that opens (command-V). You won't see what you pasted because a line break is included. Press return.

    Reset the System Management Controller.

  • bureljo Level 1 Level 1 (0 points)

    Hi ARMartinez0984USN,

     

    I recently had the same issue you were having where my computer would force me to manually select my preferred network.  I found your thread and read a few other articles online and was able to fix the problem.  I hope you have solved the issue by now, but if not this article helped me: http://www.askdavetaylor.com/how_to_have_mac_autoconnect_wifi_network.html

     

    Essentially all I had to do was delete my network from the preferred networks list and then ad it back.  After this my problem was solved.  Hope this helps with your problem.

  • Brianfit Level 1 Level 1 (0 points)

    I had the identical issue after upgrade to 10.8.4


    The recommendation to simply delete my network and re-add it didn't work. And the down side of deleting com.apple.network.identification.plist is that you lose all your Network preferences.

     

    An alternate, less destructive fix that worked for me: add a location, change to that location. Bam. Done.

     

    >SystemPreferences >Network > Location > Edit Locations +to add a new location, Apply, then Reboot.

     

    I kept all my preferred networks intact AND solved the issue of Wifi not connectiong automatically.

     

    Not sure what the root issue is, and that bothers the geek in me, but having lost my Saturday Morning trying different solutions, I'm going to let that sleeping dog lie and be glad it's working. ;-)

  • 3000ways Calculating status...

    I finally fixed this annoying issue. Here is what I did (I'm not sure which step actually fidex the problem).

     

    Remove all networks.

    Remove all wifi passwords stored in keychain.

    Re add the network(s).

    (still not connecting after waking up from sleep at this point)

    Update OS to latest version 10.8.4

    Restart!

     

    Bazinga it WORKS!!!

  • kkulkarni Calculating status...

    I had tried deleting and the network several times before, to no avail.

     

    This is what I noticed:

    On the 'Advanced' page where it lists all the networks, notice the entry in the Security column.

    For mine it said 'None', this was even after I had picked WPA2 Personal and added the password several times before.

     

    Here is what worked:

    I deleted the offending network, while adding the new network selected the security type as "Any (Personal)", entered the password and saved. Now the security type says "Any (Personal)" and the network starts on wake up from sleep

  • Linc Davis Level 10 Level 10 (107,830 points)

    That was in Step 1 of my comment of July 21.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.