Skip navigation

MacBook Air no audio output device found ???????? *please help*

314374 Views 385 Replies Latest reply: Apr 11, 2014 2:31 AM by Paula Hunts RSS
  • nothstar Level 1 Level 1 (0 points)

    Yes, unlikely as it semed, this solved this problem on a 2007 (I bought it because they last a long time) imac. I cannot be absolutely certain of the trigger which caused the loss of sound output but the problem certainly arose at about the time I upgraded the operating system to Mountain Lion.  Internal speakers continued to work ok.

     

    I used headphones and for what is worth I plugged and unplugged them a couple of times and then (this seemed to be the important bit) adjusted the volume in the system preferences and the sound returned after what has been several weeks without use of a Bose speaker system.

     

    Thankyou rynelandt.

  • jcrg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 15, 2013 2:14 PM (in response to Joe Holt)

    Joe Holt solution solved my audio problem. Probably when I installed a new battery I moved the audio cable connectors.

     

    Many thanks for your perfect explanation and pictures.

     

  • civix74 Level 1 Level 1 (0 points)

    Fixed!

     

    I first tried every solution in this thread, with no success. I reset the PRAM, fixed file permissions (disk utility), rebooted multiple times, plugged in USB-headset, plugged in minijack, and even tried to install the latest combo update (which for some reason fails). The sound device was missing also when i booted into safe mode.

     

    However, I did manage to fix the problem by booting into recovery mode (hold cmd+r while booting), and then simply reinstalling OS X. This doesn't erase or change any user content, so everything will be just as before when the installation is finished. (But as always - do have a backup just in case!) It just reinstalls the system files. And, the sound device problem was fixed. Yay!

  • ShawnCS Level 1 Level 1 (0 points)

    Yes!  1000 times yes!  Apple told me I was going to need a new logic board but that sounded like a heap.  If you have the problem with the greyed out volume and no inputs, don't pay Apple a dime until you try the trick in this video.  Just move the audio cable from under the battery to the top of the battery.  Pure effin magic.

  • Scott Svenska Level 1 Level 1 (0 points)

    Exactly the same to me. No sound, no source. 1st gen MBA, 80 GB.

     

    I tried everything. The SMC. Reinstallation of SL, plugging and unplugging headphones, deleting plist, repair permissions, toying with settings, zap PRAM. Nada. Nothing.

     

    I suspect it's the cable, probably because of overheating placement under the battery, poor design with folding ribbon cable.

     

    Then the hinge broke... Apple is no longer standing behind that problem.

    I've stood behind Apple since day one. I have a bushel basket of their products. 

     

    We are all getting rotten Apples!!!!

  • Spray Guy Level 1 Level 1 (0 points)

    I had the same problem no sound I tried resetting holding command option and P,R it would work for an hour then be gone again.

    Then I tried holding command and D down while I restarted my computer the whole way through the restart and shazam it worked and I still have the sound for a full day now.

    Fingers Crossed

  • LiatMGat Level 1 Level 1 (0 points)

    This fixed my problem too! Thank you. I just went to System Preferences > Sound, clicked "output," and selected "headphones" (while wearing my headphones.

  • Paula Hunts Level 1 Level 1 (0 points)

    Headphones in and out and in and out. Do this until you see in system Preferences / Sound that Digital Output changes to Internal Speakers.

    Such an old problem, but stil existing in the latest OS X releases.

    (And I hate the situation when I really need my internal speakers and there is no headphones around me to be found)

  • Danlowe2014 Level 1 Level 1 (0 points)

    Civix74 was right. I spent 2 hours reinstall OS X last night. After it was done, my mba restarted twice still no speaker. I gave up, went to bed. This morning when I turned on my mba the magical chime came with the boot screen! I turned it off during lunch, and turned it on again. Again the heavenly chime came out from the speaker. It's fixed! Halleluya!

  • nvictoria87 Level 1 Level 1 (0 points)

    I'm having the same problem, tried the PRAM reset but that just seems to be a temporary fix, so i ended up taking it to the genius bar and getting the logic board replaced. Then a month later to the date, it started happening again. So now i'm at a loss of what to do.

  • Paula Hunts Level 1 Level 1 (0 points)

    Plug some normal headphones in and out again, repeat until you see the 'Internal Speakers' entry showing up again in 'System Preferences / Output'

    There is no other fix available.

1 ... 22 23 24 25 26 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.