Skip navigation

Safari 6 randomly stops loading pages until I relaunch.

39448 Views 49 Replies Latest reply: Jan 27, 2014 8:47 AM by Amosbadamos RSS
  • pjw_028 Calculating status...

    I also have this problem.  Started about a week ago. 

     

    Safari randomly can't load pages and images. 

     

    Tried unplugging and replugging my wireless router.

     

    Tried 32-bit mode for Safari.  Tried resetting Safari which helps temporarily.

     

    Tried Chrome.

     

    Have no plug-in's or add-on's.

     

    Tried everything else listed on this discussion.

     

    Anyone have an update on a fix for this issue?Screen Shot 2013-05-29 at 7.15.58 PM.png

  • Alexander Sean Calculating status...

    Guys hi! I have noticed...even on 10.8.3 that if the web pages come to a screeching hault it can be fixed untill the next time by turning off the airport at the top right hand of the screen and then turn it right back on...even without restaring safari it starts working again when i refresh the page after. I have noticed the web pages stop loading if i stop using my computer for 10 minutes or so. But it has happened even while surfing...so just a few things I wanted to point out. I hope this helps somebody.

  • yo2lux Calculating status...

    Had the same issue and fixed it by using OpenDNS.

  • Scophi Calculating status...

    I tried OpenDNS, disabling prefetch, empying caches, disabling caches, turning on/off extensions, turning on/off plugins, and so on. None of those work for long.

     

    The only thing I've found that works is disabling javascript. Stalled websites reload immediately. It also fixes jittery scrolling. It's amazing how fast Safari becomes.

     

    But a browser without javascript is useless.

     

    It's a shame because I really want to use Safari. But this is a problem that has been going on for years now.

     

    Either Apple isn't aware of this problem, which is hard to believe, or they can't fix it, which is hard to believe.

     

    My only choice is to use another browser, which means that I can't use iCloud Keychain.

     

    Was really hoping Mavericks would fix this problem, but alas...

     

    -----

     

    Late-2012 rMBP "13, OS X Mavericks, Safari 7.0 (9537.71) 

  • Amosbadamos Level 1 Level 1 (0 points)

    FWIW, I tried a lot of different things! I was starting to get worried I was going to change some obscure setting I didn't totally understand and warp my system for good!

     

    I fixed it with a very simple 2 step process;

     

         1. Reset router

         2. Turn Wi-Fi off and back on again.

     

    This was the order I took. On re-evaluating it, it may be better to turn off the wifi, then reset the router. After the router has re-cycled, then turn wifi back on. It was simple; but it worked! Good luck.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.