Skip navigation

Help for advanced use of fsck to repair a disk

1135 Views 5 Replies Latest reply: Aug 15, 2013 5:34 AM by Kentuckienne RSS
Kentuckienne Calculating status...
Currently Being Moderated
Aug 14, 2013 4:06 AM

I have a PPC PowerBook 17" from 2005 running Leopard that has worked like a CHAMP for all these years. I have to upgrade, because I'm tired of all the incompatibilities, but hope to keep it going until the end of the year for financial reasons. Problem is, it has a disk problem and Repair Disk fails.


I ran Apple diagnostics from my original system install disk. It failed: Mass Storage - error detected Error code 2STF/8/3:ATA-100 ata-6 - Master


Tried to boot into Safe Mode but it just dies after a while.


Booted into Single User Mode to run /sbin/fsck -fy and results are: 


...Checking catalog file

disk)s3: I/O error

invalid key length


** volume check failed

/dev/rdisk0s3 (hfs) EXITED WITH SIGNAL 8


ran the command again with identical results. I was hoping to see some change in the error code.


The computer does boot and run "normally". I have a full Time Machine backup but can't figure out how to restore. Have other backups as well, but want to fix this disk problem before I go erasing and reformatting anything. It's at least working now. I seem to remember that fsck takes additional parameters, including telling it to use an alternate superblock (is 32 still an alternate superblock - used to be in BSD) - would this help? Can anyone advise me on the correct parameters for repairing the drive from Single User Mode?


What version of Unix is the OS based on? Is it BSD?

  • a brody Level 9 Level 9 (62,045 points)
    Currently Being Moderated
    Aug 14, 2013 7:48 AM (in response to Kentuckienne)

    Your drive is almost dead and needs replacing.  To restore, boot the 10.5 installer disc with the Option key, and use the Time Machine restore option under Utilities after replacing the hrad drive.

  has 2.5" Parallel ATA IDE hard drives you can replace the one in your Powerbook.

  • a brody Level 9 Level 9 (62,045 points)
    Currently Being Moderated
    Aug 14, 2013 8:53 AM (in response to Kentuckienne)

    It is NetBSD based with some components of AT&T Unix.   That said, the permissions are a tangle compared to some Unix systems, and you can royally mess yourself up trying to untangle them for anything but folders you create yourself.  


    You could as you say format the Firewire drive.  I would make a second partition for when you do find the 10.5 installer, so you can recover the entire backup with Time Machine.    Don't forget, many things that may have been upgraded to 10.5 won't work with 10.4.   So you are in a bit of a bind until you find that 10.5 disc.


    The Apple Store could put your machine in Target mode and recover everything with their copy of Time Machine, if you want to work with them on that.  Also a nearby usergroup might have someone who has the discs or at least the ability to do what the Apple Store can.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.