Skip navigation

MAC Mail not saving all sent items

140590 Views 575 Replies Latest reply: Apr 4, 2014 6:36 AM by __kckc__ RSS Branched to a new discussion.
  • John Grzeskowiak Calculating status...
    Currently Being Moderated
    Jul 9, 2013 12:52 AM (in response to Xairoo)

    That was ms - for the abandoned sync's I've managed to capture and log (3), mail aborted the attempt at 34ms each time.  Curious if you have other relavent info to add - I'm exploring ways of extending (or working around) this behavior and any help or observations would be much appreciated.

  • John Grzeskowiak Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 9, 2013 12:54 AM (in response to John Grzeskowiak)

    What version of mail are you running Xairoo?

  • Csound1 Level 7 Level 7 (32,250 points)
    Currently Being Moderated
    Jul 9, 2013 4:58 AM (in response to John Grzeskowiak)

    I have 5 imap accounts in mail, all work correctly.

  • Xairoo Calculating status...
    Currently Being Moderated
    Jul 9, 2013 5:20 AM (in response to John Grzeskowiak)

    I don't think that this short timeout is really used. Also 34 ms is a good time. Not everyone has a fast connection. Some providers still have much higher values. And also the thing with the mobile connections, dial up and so on...

     

    Let me give u a great example: Inside a driving car, check your mails... this could take a long time - ways more than 10 seconds!

     

    I'm currently not at my mac, but I always have the latest public version.

     

    It's too funny to talk about this. I'm still waiting for an action from Apple to have a real look at this problem. But as I said so many times: It's cheaper and easy to let the consumers do the work.

     

     

     

    @Csound1: Number of accounts shouldn't matter.

  • Csound1 Level 7 Level 7 (32,250 points)
    Currently Being Moderated
    Jul 9, 2013 5:45 AM (in response to Xairoo)

    Xairoo wrote:

     

     

     

    @Csound1: Number of accounts shouldn't matter.

    The fact that they all work is what matters.

     

    Your hypotheses seems to be invalid.

  • Csound1 Level 7 Level 7 (32,250 points)
    Currently Being Moderated
    Jul 9, 2013 5:46 AM (in response to John Grzeskowiak)

    John Grzeskowiak wrote:

     

    How far away is your server located Xairoo?  Mail.app's sync attempts appear to time-out at 35ms (log entries actually show 34) - network latency could conceivably last longer than that and trigger the same result.

    How far can an 802.11 signal travel in 35ms?

  • Richard_69 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 9, 2013 9:14 AM (in response to John Grzeskowiak)

    My problem is not what you describe - 'messages lost forever'.

    They are not lost -- they arrive! It is just that I get no record of having sent them.

    But thank you.

  • Mitchell Group Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 9, 2013 9:20 AM (in response to razzo)

    Hi razzo,

     

    Any news from your discussion with apple and their schedule for a fix at this point!

  • J.Watts Calculating status...
    Currently Being Moderated
    Jul 9, 2013 9:26 AM (in response to John Grzeskowiak)

    John -  I think you are right on to the core of the issue.  I've always noticed that when I travel overseas and connect to my various imap servers (via a less stable DSL connection) I have a greater tendency to have this issue.  Here in the US on a stable connection via a cable modem I haven't had any issues.  -  Thanks for your input, now if Apple will only address this...   

  • Xairoo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 9, 2013 9:40 AM (in response to Richard_69)

    @Richard_69: Yeah, thats the point. Nice to ask the receiver to send the mail back to you...

     

    My mails are sent for 100% but not stored always on the sent (or what ever) folder.

  • John Grzeskowiak Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 10, 2013 5:34 PM (in response to Xairoo)

    Sorry for any confusion guys - my post referred to items that mail.app syncs up to the mailserver (Sent, Drafts & Trash), NOT messages that are fetched from the server (new messages to your Inbox for example).

     

    When you send a message using IMAP, your mail client (mail.app) first pushes the message through the mailserver - upon successful completion of the send, the client app moves the sent message to your local Sent folder and immediately requests a connection from the server to sync the message to the Sent folder on the server.

     

    Mail.app is apparently deleting the message from the local folders (Sent, Drafts and Trash) if it doesn't get a connection in a very short period of time.  Many of you have probably seen this in action - you send a message and then nav to your Sent folder - your sent message appears there for an instant and then vanishes.

     

    I'm 99% confident that this is what's happening.  And there is no workaround that will totally eliminate it.  As I mentioned in an earlier post, you can reduce the loss of sync'd messages by extending your fetch interval, disabling IDLE and/or asking your mail host to move your account to a less busy server.  You could also use an alternate mail client if you need garanteed archival of sync'd messages using IMAP.

     

    For those of you worried that your messages may not have actually been sent if you don't find a copy in the Sent folder, rest assured - mail.app seems to be rock solid about caching these up if they don't succeed - an Outbox will be dynamically created and the message will be stored there while successive delivery attempts are made.

     

    If I discover anything new or helpful, I'll post here.

  • Todd Kessler Calculating status...
    Currently Being Moderated
    Jul 10, 2013 7:20 PM (in response to John Grzeskowiak)

    John -- Your explanation sounds very plausible to me. I could not prove it at my end, but my experience matches your descriptions as well. Many pages back, though, I thought some folks posted that they had this issue (messages not stored in "Sent" after sending) using a different mail application. Maybe those Apps experienced a different failure mode, but it sounded similar at the time.

     

    In any case, I feel like your technical description is correct. Let's hope someone at Apple can confirm and create a fix. Hope springs eternal!

     

    Thanks. Todd

  • bratman91 Level 1 Level 1 (125 points)
    Currently Being Moderated
    Jul 17, 2013 9:43 AM (in response to John Grzeskowiak)

    John,

           Your explanation sounds very plausible so I had a close look at my email accounts. I noticed that, for my preferred account, the "use only this server" box was unchecked for my Outgoing Mail Server (SMTP). It seems to me that, whenever a message never gets into the "sent" folder, it is always at a time when the progress bar was very slow before the "wooshing" sound. I have other accounts using, for example, Hotmail and iCloud, and I wonder if the outgoing mail uses one of these servers if the preferred server is slow or unavailable. Perhaps in such cases, the mail app doesn't work properly and place the message in the "sent" box. I have now checked the "use only this server" and will see if this makes any difference. However, because the problem is only an occasional one, it might take some time to get a reliable indication of whether or not this is the cause.

  • sakohn Calculating status...
    Currently Being Moderated
    Jul 17, 2013 4:27 PM (in response to chrisaxe21)

    I have similar problem with Mac Mail but the messages displaying in my SENT folder are emails I sent to a different person 1-2 years earlier. This happens about every 100 emails. I called Apple and they told me to check with my email service host. They investigated very thoroughly and informed me that it isn't their doing. Unfortunately for me this only happens to me when I send a critical email. I know the email has gone through correctly but the one in the sent file is not. If I haven't copied myself on the email - it is lost and can't be retrieved unless I ask the recipient to send me back a copy.

  • rabbit_ch Calculating status...
    Currently Being Moderated
    Aug 17, 2013 3:54 AM (in response to chrisaxe21)

    I have to deal with the same problem with my IMAP Account. It's very annoying.

1 ... 32 33 34 35 36 ... 39 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (32)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.