Skip navigation

operation can't be completed because an item of same name already exist

132723 Views 129 Replies Latest reply: Mar 13, 2014 4:08 PM by Mike Cuenca RSS
  • NEO3663 Calculating status...

    Hi Everyone,

        I've had similar problems copy files onto and FAT32 formated hard drive and unable to use the drive to move files back and forth from my new iMac to my IBM PC.  Finally, I was pointed towards Tuxera that enables NFTS formatted drives to be read and written to by apples.  So I reformatted the drive on my PC back to NFTS.  I've installted Tuxera and it seems to be working like a charm.  The cost is just over $30 and its free for 15 days.  If it continues to work I am very happy with this solution.


  • irow Level 1 Level 1 (5 points)

    I was having a similar problem in Mountain Lion 10.8.2. In my case, it turned out to be a cache issue. I was able to resolve the problem by deleting the Finder cache:


    1. Open a finder window and select “Go to Folder” in the Go menu
    2. Type in ~/Library/Caches
    3. This is optional, but you can highlight & copy everything to a different folder in case anything goes wrong.
    4. Highlight everything and press CMD and Backspace
    5. Restart your machine
  • eSchmidt2 Calculating status...

    Thank you, irow, you saved my life.


    MAC OS X Mountain Lion 10.8.2.

    Copied one 2 TB partition from Hitachi 4 TB eSata => another 2 TB partition on Hitachi 4 TB FireWire 800.

  • eSchmidt2 Level 1 Level 1 (0 points)

    It seems as this was not the only problem.


    After deleting the cache files, copying my files stopped again. After many attempts, I found that there are some icon files missing. It is a lot of work to find which icon file produces the problems.


    I am still working on the solution.

  • DjEtchaSkratch Calculating status...

    Hey everyoe idk if this helps but i solved my problem. I have about 70,000 files i am copying from my mac to an external hard drive, but it stops halfway through with the error message "operation can't be completed because the files already exists".


    It is because of a symbol in the name of a certain file. I dont know how to type it, but it looks like a squiggily hyphen. Go to the destination you are trying to copy the files to and go to the last file that was copied before the error came up. EVERYTIME with me, it stops copying the files when it runs into a file that has that squiggily hyphen in the file name. Rename the file whatwever you want just make sure you get rid of that ridiculous squiggily hyphen, and it should work. at least it does for me.


    I hope this is a help to someone cause it worked for me.


    ps i am using lion 10.6.8



  • Inchmurrin Calculating status...

    The solution posted here worked for me:



    It appears to be an issue with drop n drop using finder.  Short circut it by using terminal.  I remember having to do similar in early Windows 98 days using Command.  Seems like a bug Apple should be aware of (or at least the symptoms of a bug).

  • Dark-Star Calculating status...



    Most of you seem to have NAS drives. If so, many of them can be accessed outside of you home net.


    For exampe my 4TB Buffalo Linkstation, has a iwebaccess which I can access via an app on my iphone, or any browser, if I chose to use the buffalo website for this service.


    In my case it worked and deleted a very stuborn file and folder.


    I am certain that most companies that manafacture NAS drives have this service.


    I'll be intrested to find out how you got on.


    All the best - Steve

  • Wilbur Wright Calculating status...

    First post because I had the same issue and found simple fix that I think others may really want to know. Through another program i found out that the error number is error 48 ...

    dupFNErrDuplicate filename (rename); File found instead of folder


    This is probably obvious to you but another user posted that this is the issue...

    "I have discovered why this happens. In every case, the folder that generates this bug has items inside it that have identical names except for differences in capitalization. For example, the folder "Metallica" has one subfolder called "Master of Puppets" and another subfolder called "Master Of Puppets". Apparently iTunes is (or some former version was) case sensitive in creating folder names for albums. That case sensitivity seems to confuse the Finder, causing this confusing error. In the case described above, the error would be, "The operation can't be completed because an item with the name 'Metallica' already exists." As you can see, this makes no sense at all, since it is actually the subfolder that has the same name, but the parent folder that the finder references in the error.

    So the solution (for me) was simply to open the folder that is referenced in the error, make sure you are sorted alphabetically, scan through the list of subfolders (in my case it was always a subfolder) to find the duplicates, consolidate the items into one of the folders, and delete the errant folder. "


    FIX:*****So basically there is some confusion with the file name, could be two file names with same name but some letters are capitalized while others aren't (making the program think that there is a file with the same name). My case, however, was solved by renaming a file that had a tilde ('~') symbol (Presuming that this is a special or reservered character that cannot be handled by OSX). I dont know why the symbol is there but I did not need it and it caused problems so I renamed the file without the tilde (~) symbol. Then I attempted to copy files to my external hard drive with no issues. If you have a large quanitity of files this could be a little more difficult but what you can do is go to the folder in which the error message claimed contained the same file name and you open the folder and use the Finder search bar to search for any files that have the tilde symbol (~) in it. (to search this, just type a ~ into the search bar. Hopefully you will not have many files like this to rename).


    I also wanted to point out that in my case I did not need the tilde symbol (~) to use the file with my program which is actually just a song file I use in itunes, but if the program you are using requires a tilde symbol (~) to recognize/use/play file then obviously you may want to reconsider whether it is a safe idea to remove the tilde symbol from the filename. I guess if it didn't work then you could always add the symbol back into the file name. I don't think removing the tilde symbol would affect functionality of the file but I am not sure and wanted to put a little disclaimer. But if your issue is an mp3 file then you can assume that its safe to remove this tlde symbol.

  • dieg0 Calculating status...

    I got a weird solution that works 99% of the time, but is simple to do,so.. it doesnt hurt to try.


    Just CLOSE the file location finder window AND the file destination finder window BEFORE the file finishes copying/moving... and TADA!... it works, weird, sometimes to make sure everything goes ok I close ALL my finder windows and I minimize the copying/moving progression bar.


    I think is a problem with finder showing the file in the finder window folder while being copied so when the destination and location windows are closed the error doesnt happen and you hear that lovely file drop sound


    I hope apple fixes this stupid error soon...

  • Mike Cuenca Calculating status...

    YES! This was the solution for me. I was trying to restore an old Microsoft Entourage identity, which the Microsoft Data Utility had automatically named with a bunch of hypens, parentheses and spaces. I made a new folder for the contents on my current drive and then did a "Restore to ..." from Time Machine and it worked!


    Thanks for the tip.

1 ... 5 6 7 8 9 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.