Skip navigation

MacBook Battery Won't Charge...Get "Not Charging"

532633 Views 230 Replies Latest reply: Mar 10, 2014 6:04 PM by l.aluffi RSS
  • Kenneth Keen1 Level 1 Level 1 (15 points)

    Back again. I bought a replacement here in Portugal (never heard of Pa or Md - is that Africa? or Australia not really important is it?) and that worked, everything ok. Hence I got the confidence to take the other one apart and have just managed to fix it too. Thus since I live in a civilised place (thank FNAC) at the minute I can take the new one back and continue to use the Kensington which is repairable in contrast to Apple products which are as we all know non-repairable and are tossed in the rubbish once something fails. Once you have experienced civilisation you really won't want to go back to a primative toss-world but then most of you won't even be able to grasp that very concept - try explaining walking to a fish.

     

    Best of luck with the trash all of you, my trash has been rescued for the minute, but we never know.

  • Imaan Hisham Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2013 5:26 PM (in response to Gatsby216)

    The new power cord you have is a MagSafe 2? Or the 1st gen version?

  • Kenneth Keen1 Level 1 Level 1 (15 points)

    I presume it is called Magsafe2, it has only a small plug, but it goes back to the shop tomorrow as I don't need it. I use a 1st gen magsafe plug cut off a defective apple power source and the two wires connected to the more reliable Kensington power source which has lasted now some five years. There is a good page showing how you can repair all this apple trash at:

     

     

    http://www.sunrisepage.com/computers/machardware/pwradtrs.htm        

     

     

    so look around and get enlightened!

     

    Then enlighten others.

  • P_Mac Calculating status...
    Currently Being Moderated
    Mar 29, 2013 7:48 AM (in response to RC-CA)

    My Mac would not operate without the charger anymore. So with the charger plugged in and the laptop turned on i simply flipped over the laptop, disconnected the battery and then plugged it back in. Its now back working perfectly.

    I hope this helps. 

  • Imaan Hisham Level 1 Level 1 (0 points)

    The battery is not functioning properly, and my computer's charger is broken. I have a MagSafe 1 charger, 80 watts.

  • funkyronster Calculating status...
    Currently Being Moderated
    Apr 27, 2013 10:42 PM (in response to Gully)

    Here's what worked for me.

     

    My magsafe started playing up a year or so ago. It would just stop working. Sometimes for a day or more.

     

    Several times I was on the point of buying a new one, then it would come back to life again.

     

    Gradually I got suspicious.......because it was really bad when I am in Thailand, but not so much in the UK.

     

    To cut a long story short - I put it in the freezer/refrigerator for 10 minutes. Works every time for me!

     

    Basically it seems that if you live in a hot climate, or just a hot room!, and even more, if your grid electricity is unstable, or you are in a place with lousy wiring and bad earths, the magsafe will "trip out" ..... and often takes ages to reset. Chilling seems to accelerate this process.

     

    Obviously this will not work all the time, but it has really worked for me!! Maybe my magsafe just has an over sensitive protection circuit (is it called a thermistor?).

     

    But if your magsafe suddenly stops working, check the fuse ...... while the magsafe is in the fridge!

  • tim71725084 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 1, 2013 4:10 PM (in response to Gully)

    Hi

    Had the problem of "battery not charging" on Macbook Pro 2006

    Charger connecter lit up green

    It was very new non apple battery from OWC

    Looked at the System Profile only 16 cycles on the battery

    AC charger was shown as "connected"

    Battery showed up so not a problem with poor connection or not properly inserted (I had tried taking the battery in and out several times) but the profiler said "Charging: No"

    Charger worked on another Macbook so that wasnt the problem

    I tried the SMC reset where you sleep, shutdown, take out the battery, press power supply for 5 secs, reconnect AC, reinsert battery etc - No luck

    Then I read the SMC also controls the sleep wake cycle and lid closure.

    I cant exactly remember what I did because I was so ****** off by this stage and starting to lose concentration but I think I closed the lid and let the computer go to sleep and then opened it again to rewake.

    After doing this 3 times the bloody thing now shows the battery is charging

    A bit random I know but saved me having mental breakdown

    I would love to know if this helps anyone else!

  • danaefromca Calculating status...
    Currently Being Moderated
    Jul 14, 2013 8:38 AM (in response to zkhtay)

    That did it for me.  You ROCK!

  • Cobraboy Calculating status...
    Currently Being Moderated
    Jul 14, 2013 11:57 AM (in response to Gully)

    I don't know if this will help anyone or not, but I had the same issues.  Did all the stuff that has been suggested.

    Reset the everything

    Booted without battery and then with

    Checked for latest software being installed

    "Smacked the battery a bit when installing, to make sure it was seated"

     

    Nothing worked

     

    So, I checked the pins on the Magsoft connector and all the pins seemed fine.

     

    But, there was some crud on the laptop connector.

    So, I used a pencil eraser and lightly cleaned the connectors

    Then, used a toothpick to clean around the edges.

     

    All is well and charging normally.

     

    I think there was just enough dirt to keep something from connecting correctly.

    Thanks,

  • tim71725084 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2013 4:34 PM (in response to Cobraboy)

    HI

    Thanks for your contribution but the problem I was having and many others were having was nothing to do with the battery, charger or connector.

    When I was going into the Mac system profiler it was clearly showing the charger was connected but the bit where it says "Charging" was coming up as "No"

    The problem was something in the SMC software that was not allowing the battery to charge even though everything was saying it was connected properly

    This is why many solutions involved attempts to reset the SMC (System Management Controller) like the one on YouTube involving taking the battery out etc

    The one taking battery out did not work for me but opening and closing the lid which put the laptop to sleep and then reawakened it seemed to fix the problem as the SMC also controls sleep wake.

  • Kenneth Keen1 Level 1 Level 1 (15 points)

    Hello Tim and others with power problems.

     

    I found that:

     

    1. taking the "magsafe" plug off and knocking it sharply against a hard surface enabled the tiny pins to become fully extended again.

     

    2. Better still is cleaning them with hi pressure air or a cleansing fluid.

     

    Take a close look at all the pins. If they are not all the same length, then you will have a fault. They have to all sit parallel and fully extended. Swinging the magplug on the end of about an arm's length of cable against something hard will jolt them into position. If this works for a short time then you KNOW that this is the problem - dirt around the pins. Once cleaned all the other methods of resolving this problem will be irrelevant.

     

    Best of luck, and

     

    3. As a last resort there are macpowersupply copies in EBAY which are cheap (20€ each instead of 75€), made in China (where the Mac originals are also made) and so far mine has not let me down used for four months now.

  • NoMan99 Calculating status...
    Currently Being Moderated
    Aug 17, 2013 12:58 PM (in response to Encephalon)

    My new MacBook went 11 cycles and died. I replaced it with an Anker battery -- got to be better than an Apple.

  • slindsay198 Calculating status...
    Currently Being Moderated
    Aug 18, 2013 9:13 PM (in response to Gully)

    I was having the same problem...plugged in, green LED dimmer than usual, and "not charging" next to the battery icon.  Also, the screen would brighten up when plugged in so I knew the charger itself was working. 

     

    As Kenneth Keen1 suggested above, I tried firmly tapping the magsafe connecter on a hard surface.  Viola!  Plugged it back in and it started charging, amber LED, back to normal.

     

    Thanks!

  • bsauls Calculating status...

    I didn't get this far in the discussion until now, but I thought I would post what finally worked for me. First I finally got 13" MacBook to run on the battery during the course of the numerous resets, when I tried booting up without the magsafe connected, and it booted, which was a huge step forward. Still saying "Not Charging" on the menu bar indicator, though. In doing the SMC reset for the umpteenth time, I plugged in the magsafe, which went to green, and then installed the battery and the indicator on the magsafe went orange! I booted up and it continued to charge.

  • Full_Mountie Calculating status...
    Currently Being Moderated
    Sep 2, 2013 5:43 PM (in response to Gully)

    MacBook early 2006 white model

    OS X 10.7.5

    I keep having the problem like others with a green light or no light on the magsafe and "Not Charging" in the status bar.  I'm on my second replacement battery (which has 2 cycles on it).

    I've tried the SMC reset which actually does work...until I unplug the computer and use it for a while, then it goes back to "Not Charging".

    I guess I can keep resetting the SMC whenever I want to plug it back in - but this is rather painful...anything else to suggest trying?  Maybe I'm wrong in my assumption, but doesn't the fact that the SMC reset works (even if briefly) suggest that it's not a magsafe or battery problem?

     

    Thanks for the help

     

    Battery Information:

     

      Model Information:

      Serial Number:          W***********A

      Manufacturer:          SMP

      Device Name:          ASMB016

      Pack Lot Code:          3230

      PCB Lot Code:          30db

      Firmware Version:          ddae

      Hardware Revision:          dac2

      Cell Revision:          2b39

      Charge Information:

      Charge Remaining (mAh):          4675

      Fully Charged:          No

      Charging:          Yes                   <- I've just reset the SMC

      Full Charge Capacity (mAh):          4711

      Health Information:

      Cycle Count:          2

      Condition:          Normal

      Battery Installed:          Yes

      Amperage (mA):          225

      Voltage (mV):          12595

    MacBook, Mac OS X (10.7.5), iPhone 3GS iOS 5.1

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.