4 Replies Latest reply: Aug 20, 2013 12:43 PM by natenaterollerskate
Jerome.Oneil Level 1 Level 1 (0 points)

I can use SIU to create NetBoot images from my install package just fine.   They end up in the Library/NetBoot/NetbootSP0 directory.   But the Server NetInstall images pane tells me that "No images available" regardless of where I place them.  The client sharepoints are available in the File Share service. I've followed the instructions from multiple sources (the all say essentially the same thing) to no avail.

 

Now I'm just stuck.  This should be working, but I can't figure out what I'm missing.


Mac mini, OS X Mountain Lion (10.8.3)
  • 1. Re: NetBoot Images Not Recognized by Server
    Rick Warren Level 2 Level 2 (235 points)

    I am running OSX Server 10.6.8. I have the folder where the images are stored, shared Admin read write, admin group read write, everyone read only.

    In Netboot, general I have the drives where I store my images and where I want client data to be stored, ticked.

     

    Not sure where in Lion server these items may be. Also my images are NFS Protocol. I hope this may help.

  • 2. Re: NetBoot Images Not Recognized by Server
    Luke Siemaszko1 Level 1 Level 1 (35 points)

    I'm not sure if I am answering the correct question or not...

     

    And my experience was on 10.6.8 server, with NetRestore rather than NetBoot.  Nevertheless I'll mention what I found in case it is helpful as they are very nearly the same process.

     

    I had awful problems in the past getting the whole process to work, it seems that it matters which machine you use to do the imaging.  What I found worked was to:

    - clone the disc you want to image onto a USB disc.  I can't remember what I used to do this, would have been either ditto or SuperDuper!  (I found in the past that CarbonCopy Cloner worked less well)

    - plug the USB disc into the server and run Disk Image Utility on the server

     

    For me this was the "Eureka" moment that made the whole thing suddenly work.

     

    Also I should mention that I found that it matters which network switch you use.  A TPLink switch didn't pass something that was needed for the NetRestore process to work, whereas an HP Procurve switch worked fine.

     

    HTH

  • 3. Re: NetBoot Images Not Recognized by Server
    Brian Nesse Level 4 Level 4 (2,780 points)

    When the images don't appear in Server.app, there's really only 2 reasons.

    1) The images are incomplete (didn't finish building.)

    2) Server.app is looking in the wrong place.

     

    The images should have a .nbi extention on the folders, and there should be a NBImageInfo.plist file inside the folder. If either of these is wrong, Server.app will ignore it.

     

    Otherwise, make sure that Server.app is configured to look for the images where they are physically stored. For example, if you are storing your images on the Boot drive, and it's named "Macintosh HD", make sure "Macintosh HD" is checked in in the list of sources (sorry, don't have Server.app sitting in front of me, so I can't be more specific.)

  • 4. Re: NetBoot Images Not Recognized by Server
    natenaterollerskate Level 1 Level 1 (0 points)

    I had the same problem, and this last post got me half way there.

     

    "2) Server.app is looking in the wrong place."

     

    Very helpful. In my case, I created a folder "/Library/Netboot/NetbootSPO" 

     

    Looks right, right? WRONG!  That last character, I mistakenly placed a capital "o" instead a zero "0"

     

    So, all I did was rename the folder "/NetbootSP0" (with a zero) and Server.ap was happy again, and all was right with the world.