Skip navigation

Aperture Libraries won't Merge

1300 Views 8 Replies Latest reply: Aug 20, 2013 1:43 PM by jackmcdw RSS
Heyyoumen Calculating status...
Currently Being Moderated
Jan 10, 2013 8:39 PM

Major Bug/Problem


Already tried re-install, doesn't work

Problem: I have multiple libraries for Aperture, and Aperture 3.4.3 is currently the most updated version , all of my libraries are upgrade to 3.4.3 compatable too, but if i try exporting a project from 1 library and on the 2nd library, i choose Import, Library, and it shows the progress bar of "Merging Library" but afterwards, it doesn't import the pictures from the 1st library, and this only occurs on some of my major libraries which is really frustrating, i know this function always worked for me from previous updates, and the button used to be called Import>Library as new project" instead of just "Library"


Please Help, Working on big projects now


Thank You.

Aperture 3, OS X Mountain Lion (10.8.2)
  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Jan 10, 2013 9:52 PM (in response to Heyyoumen)

    How exactly are you exporting from the first library?

    but if i try exporting a project from 1 library

    • I assume you are selecting a project in the source list of your library inspector and using "File > Export project as New Library"?
    • And then switch to your other library and use "File > Import > Library"?

     

    That should work - exactly as described. I am doing it all the time. You say, you already tried to reinstall - did you also try the Library First Aid Tools? Perhaps your library needs repairing, see this manual page: Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library

     

    There are some things to be aware of:

    • The export as library works in the background and may take a long time, if the partial library is large. Aperture will notify you, when the export has finished. You cannot switch to another library to import into, while the export is still happening, or the export will be terminated.
    • Aperture will not import a library into itself. If the exported library is assumed to be an exact copy of the library you want to import into, Aperture simply will not do it. You have to modify the library you want to import by importing a new picture into it, to force Aperture to recognize it as a new library that needs merging.
    • And there is a big bug with merging libraries, that contain images imported from Photo Stream. We found that Aperture pretends to import the Photo Stream images, but skips them when merging the libraries. If all images are Photo Stream imports, nothing may be added when merging Libraries.

     

    You may want to have a look at these threads for workarounds:

                 Re: Photo stream imported pictures missing after importing library                                            

                 Re: Aperture will not import an aperture library any more                                            

     

    Regards

    Léonie

  • heff_sf Calculating status...
    Currently Being Moderated
    Jan 11, 2013 11:38 AM (in response to Heyyoumen)

    Hi Heyyoumen-

     

    You wrote that you exported a project from Library1 (let's call it "Lib1-exp"), and when you open Library2 and import it you get the merge progress bar but when it finishes nothing seems to happen. When you imported Lib1-exp into Library2 (via File > Import > Library...), did you get a dialog box giving you the option to Merge the library or to Add it? Choosing Merge will give you the behavior you described, where any common images in Library2 and Lib1-exp will have their information (metadata, adjustments, etc) combined on the version already in Library2.

     

    If instead you choose to Add Lib1-exp, it will be imported as a new project.

  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Jan 11, 2013 12:26 PM (in response to heff_sf)

    heff_sf,

    did you get a dialog box giving you the option to Merge the library or to Add it

    what you say is what should happen, but unfortunately this behaviour is buggy right now.

    Aperture will only show the merge/add prompt, if it detects duplicates. If it does not prompt, it should do an "Add", but that will not always happen. 

     

    Sometimes you have to force the appearance of this panel by adding an images to the imported library, that will ensure that that Aperture sees at least one duplicate.

  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Jan 11, 2013 2:28 PM (in response to Heyyoumen)

    Then try the workaround to import one single image that is comes from one of the libraries into the other. This way you will be sure to have a duplicate and Aperture should prompt you if you want to add or to merge.

     

    But does your Aperture library contain Photo Stream images? That caused this problem for other posters here.

  • jackmcdw Calculating status...
    Currently Being Moderated
    Aug 20, 2013 1:23 PM (in response to Heyyoumen)

    I have a related problem in that under no circumstances can I persuade Aperture to actually sync my files when I try to merge 2 libraries.  I always get the choice of adding or merging.  If I select Add there is no problem - the library is duly added.  If I select Merge and I am trying to merge an updated project which is already in my main library the computer appears to be doing something but, in fact, it gives up and nothing happens.  However, if I have opened the original project as a separate library and import the new library (same project but files which have been worked on) and select Merge, it still refuses to sync the amended files, although in this case it will add the files.  I have taken note of all the suggestions that have been made, such as deleting, adding files so that the projects do not look exactly the same and I have no Photo Stream photos in my libraries.

     

    At the end of the day I can just delete the original project and keep the added (updated) project in my main library but that is really not the point since, in my opinion, Aperture should be doing what it is supposed to be able to do - it seems to me that there is still a bug here.

     

    I am using an iMac 27" December 2009 and an MBP 13" December 2012 - both on OSX 10.8.4 and Aperture 3.4.5.

     

    If anyone can help resolve this I would be most grateful.

  • jackmcdw Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 20, 2013 1:43 PM (in response to Heyyoumen)

    Thanks for your very prompt response, Heyyoumen.  i had been wondering whether a switch to Lightroom might be the answer - but I've invested so much time and effort into getting to grips with Aperture that I'm reluctant to switch, especially as I can always add and then delete.  But I'll keep your suggestion in reserve!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.