Skip navigation

MacBook Pro (10.8.4) suddenly very slow, hardware OK. Problem with System Launch Agents and Daemons?

2442 Views 16 Replies Latest reply: Aug 28, 2013 10:27 AM by Andyrattle RSS
1 2 Previous Next
Laalo Calculating status...
Currently Being Moderated
Aug 23, 2013 11:58 PM

I am desperately looking for help. My MacBook Pro (Mid 2012, 13 inch, i5, 500GB HD, 4 GB RAM)

 

It's annoyingly slow most of the times and the "beach ball" of death appears regardless of the program I use. It sometimes appears even if I am in Finder and try to open a folder. After many seconds, the ball disappears, and I can operate the software. Periodically it comes back. Quicktime, Chrome, Safari, all programs experience this problem.

 

I have already clean installed Mountain Lion and even formatted the hard drive. But the problem persists. All hard drive and memory check utilities pass tests, including Voltans Smart Utility and Rember. Disk Util also says hard drive is ok and no problem found. No Anti virus, MacKeeper, Flip4MAC or Easy find.

 

Activity Monitor does not show any process with abnormally high CPU usage while the beach ball is busy with its dance of death!

 

Following is the EtreCheck report. What are these System Launch Agents and Daemons?

 

I would truly appreciate anyone's help!

 

Hardware Information:

          MacBook Pro (13-inch, Mid 2012)

          MacBook Pro - model: MacBookPro9,2

          1 2.5 GHz Intel Core i5 CPU: 2 cores

          4 GB RAM

 

Video Information:

          Intel HD Graphics 4000 - VRAM: 512 MB

 

System Software:

          OS X 10.8.4 (12E55) - Uptime: 1 day 8:40:34

 

Disk Information:

          TOSHIBA MK5065GSXF disk0 : (500.11 GB)

                    disk0s1 (disk0s1) <not mounted>: 209.7 MB

                    Untitled (disk0s2) /: 499.25 GB (211.46 GB free)

                    Recovery HD (disk0s3) <not mounted>: 650 MB

 

          MATSHITADVD-R   UJ-8A8 

 

USB Information:

 

 

          Apple Inc. Apple Internal Keyboard / Trackpad

 

          Apple Inc. BRCM20702 Hub

                    Apple Inc. Bluetooth USB Host Controller

 

          Apple Computer, Inc. IR Receiver

 

          Apple Inc. FaceTime HD Camera (Built-in)

 

FireWire Information:

 

Thunderbolt Information:

          Apple Inc. thunderbolt_bus

 

Kernel Extensions:

          com.globaldelight.driver.BoomDevice          (1.1)

 

Problem System Launch Daemons:

          [failed] com.apple.coresymbolicationd.plist

          [failed] com.apple.wdhelper.plist

 

Problem System Launch Agents:

          [failed] com.apple.accountsd.plist

          [failed] com.apple.scopedbookmarkagent.xpc.plist

 

Launch Daemons:

          [not loaded] com.adobe.fpsaud.plist

          [loaded] com.google.keystone.daemon.plist

 

Launch Agents:

          [loaded] com.divx.dms.agent.plist

          [loaded] com.divx.update.agent.plist

          [loaded] com.google.keystone.agent.plist

 

User Launch Agents:

          [loaded] com.divx.agent.postinstall.plist

 

User Login Items:

          Alarm Clock

          WiTopia

 

3rd Party Preference Panes:

          Flash Player

          Perian

 

Internet Plug-ins:

          DivX Plus Web Player.plugin

          Flash Player.plugin

          FlashPlayer-10.6.plugin

          googletalkbrowserplugin.plugin

          JavaAppletPlugin.plugin

          npgtpo3dautoplugin.plugin

          o1dbrowserplugin.plugin

          OVSHelper.plugin

          QuickTime Plugin.plugin

 

User Internet Plug-ins:

          Picasa.plugin

 

Bad Fonts:

          None

 

Top Processes by CPU:

               6%          coreaudiod

               2%          Boom

               2%          WindowServer

               1%          iTunes

               1%          EtreCheck

               1%          activitymonitord

               1%          Activity Monitor

               0%          ps

               0%          SystemUIServer

               0%          storeagent

 

Top Processes by Memory:

          160 MB             Google Chrome

          160 MB             mds

          102 MB             iTunes

          102 MB             Transmission

          82 MB              MPlayer OSX Extended

          78 MB              Finder

          74 MB              WindowServer

          66 MB              DashboardClient

          61 MB              SystemUIServer

          57 MB              Dock

 

Virtual Memory Statistics

          576 MB             Free RAM

          1.36 GB            Active RAM

          983 MB             Inactive RAM

          1.12 GB            Wired RAM

          5.02 GB            Page-ins

          167 MB             Page-outs

MacBook Pro, OS X Mountain Lion (10.8.4)
  • Ocean 17 Level 1 Level 1 (30 points)

    Do you have Applecare?

     

    If yes, make an appointment at the Apple store. They will solve it, one way or the other by repair or replacement.

  • clintonfrombirmingham Level 7 Level 7 (26,740 points)

    While beachballing & general overall lag can be indicative of a coming hard drive failure, if Disk Utility reports that the disk is good, you MAY BE able to rule this out.

     

    Because your machine does not have a discrete graphics card, some apps (Chrome, QuickTime, etc.) may run more slowly.

     

    My first suggestion would be to increase the RAM - 8GBs is the 'sweet spot' but your machine can handle up to 16GB of RAM, allowing you to keep more apps open concurrently and allowing you to actually use that RAM (576MB of free RAM is actually kind of small).

     

    Go to the Crucial website and click on the System Scanner tab. You'll download a small app that will report your model, etc., back to Crucial and you'll be given recommendations for upgrades. I can't recommend a minimum of 8GB of RAM strongly enough.

     

    Clinton

    MacBook Pro (15-inch Late 2011), OS X Mountain Lion (10.8.4), 16GB RAM 512GB SSD Apple TB Display
  • Linc Davis Level 10 Level 10 (107,700 points)

    First, back up all data immediately, as your boot drive might be failing.

     

    There are a few other possible causes of generalized slow performance that you can rule out easily.

     

    • Reset the System Management Controller.
    • If you have many image or video files on the Desktop with preview icons, move them to another folder.
    • If applicable, uncheck all boxes in the iCloud preference pane.
    • Disconnect all non-essential wired peripherals and remove aftermarket expansion cards, if any.
    • Check your keychains in Keychain Access for excessively duplicated items.
    • Boot into Recovery mode, launch Disk Utility, and run Repair Disk.
    • If you're booting from an aftermarket SSD, see whether there's a firmware update for it.

     

    Otherwise, take the steps below when you notice the problem.

     

    Step 1

     

    Launch the Activity Monitor application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Activity Monitor in the icon grid.

     

    Select the CPU tab of the Activity Monitor window.

     

    Select All Processes from the menu in the toolbar, if not already selected.

     

    Click the heading of the % CPU column in the process table to sort the entries by CPU usage. You may have to click it twice to get the highest value at the top. What is it, and what is the process? Also post the values for % User, % System, and % Idle at the bottom of the window.

     

    Select the System Memory tab. What values are shown in the bottom part of the window for Page outs and Swap used?

     

    Next, select the Disk Activity tab. Post the approximate values shown for Reads in/sec and Writes out/sec (not Reads in and Writes out.)

     

    Step 2

     

    If you have more than one user account, you must be logged in as an administrator to carry out this step.

     

    Launch the Console application in the same way you launched Activity Monitor. Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left. If you don't see that menu, select

    View Show Log List

    from the menu bar.

     

    Select the 50 or so most recent entries in the log. Copy them to the Clipboard (command-C). Paste into a reply to this message (command-V). You're looking for entries at the end of the log, not at the beginning.

     

    When posting a log extract, be selective. Don't post more than is requested.

    Please do not indiscriminately dump thousands of lines from the log into this discussion.

    Important: Some personal information, such as your name, may appear in the log. Anonymize before posting. That should be easy to do if your extract is not too long.

  • Linc Davis Level 10 Level 10 (107,700 points)

    If you have more than one user account, these instructions must be carried out as an administrator.

      

    Triple-click anywhere in the line below on this page to select it:

    syslog -k Sender kernel -k Message CReq 'GPU D|I/O' | tail | open -ef

      

    Copy the selected text to the Clipboard (command-C).

     

    Launch the Terminal application in the same way you launched Console.

     

    Paste into the Terminal window (command-V).

     

    The command may take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear.

     

    A TextEdit window will open with the output of the command. Normally the window will be empty. If you get output like this:

    kernel[0] <Debug>: disk0s2: I/O error

     

    the boot drive is failing, or there's some other hardware fault in the storage subsystem.

      

    If you get output like this:

    kernel[0] <Debug>: ** GPU Debug Info Start **
    kernel[0] <Debug>: ** GPU Debug Info End **

      

    there's a fault in the graphics processor or logic board. The two kinds of output are not mutually exclusive, but if you get both, a logic-board fault is likely.

  • Linc Davis Level 10 Level 10 (107,700 points)

    Please enter the following command in the Terminal window as before and post the output:

    diskutil list | open -ef

  • Linc Davis Level 10 Level 10 (107,700 points)

    You have a recovery partition, so you should be able to boot from it. If you can, but only if you can verify that it's working, then I suggest the following course of action.

     

    Back up all data to at least two different storage devices.

     

    Boot into Recovery mode, launch Disk Utility, and erase the startup volume. This operation will destroy all data on the volume, so you had be better be sure of your backups. Quit Disk Utility and install OS X. If your Mac was upgraded from an older version of OS X, you’ll need the Apple ID and password you used to upgrade, so make a note of those before you begin.

     

    When you reboot, the Setup Assistant will launch to take you through the initial setup process. Follow the prompt to transfer the data from one of your backups. Don't transfer the Guest account, if it was enabled on the old system.

    If you installed the Java runtime distributed by Apple and still need it, you'll have to reinstall it.

  • Linc Davis Level 10 Level 10 (107,700 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, by a peripheral device, or by corruption of certain system caches.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled on some models, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including sound output and Wi-Fi on certain iMacs.  The next normal boot may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • Andyrattle Calculating status...

    Had this same problem, went through everything i could find on the net, nothing wrong with my software or settings though, so took it back to apple who did a wipe clean and re install, still same problem, then replaced a front sensor? cable...still was no good so they replaced the hard drive now it works fine.

     

    All the tests said my previous hard drive was ok too.

     

    Hope this helps and hope yours is under warranty. seems a small number of machines are affected this crops up occasionally if you google it.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.