Skip navigation

HT1492: Mac OS X: How to start up in single-user or verbose mode

Learn about Mac OS X: How to start up in single-user or verbose mode

HT1492 Start-up disk is full and can't go past the blue screen; can't delete read-only files on single-user mode. Please help.

1611 Views 2 Replies Latest reply: Aug 27, 2013 10:40 AM by YY9499 RSS
YY9499 Calculating status...
Currently Being Moderated
Aug 27, 2013 1:45 AM

I have had my Mac mini for about 6 years and I guess it had enough of me (haha), so the start-up disk got full and it shut down before I could empty files on my drive. Unfortunately, all these years I hadn't backed up anything and now I can't access anything since it won't boot past the apple logo (and the blue screen for that matter). I have tried rebooting (holding shift as the mac mini loads), but that didn't help since the start-up disk will still be full and stuck on the blue screen. I am now trying the single-user mode (holding command key+s), and I tried to delete files in the trash bin but all of the files are read-only and access is denied! so I basically can't delete anything on the mac mini (it says "Root device is mounted read-only"). So the key here is to change the permissions but I don't know how to exactly do that. Can someone help me figure this out? (and type the command in the unix language please!!) [ Note: We have two users on this mac mini if that helps.]

Mac mini, Mac OS X (10.5.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.