9 Replies Latest reply: Aug 27, 2013 11:38 PM by LaPastenague
d00dbro Level 1 Level 1 (40 points)

I have an AEBS set up as the router in my house. It is connected to an ethernet switch to which computers and AirPort Expresses are connected. Macs and iPhones are connected with ethernet and wifi, respectively. It all works, and so does Linux. On no Windows 7 machine (tried 3, including my Mac running Windows 7) does the connection work properly over ethernet or wifi. I can connect to the network, but there is no Internet access. HOWEVER, if I connect it to a Mac using Internet Sharing either by wifi or ethernet, and that Mac is on my network, it works fine. And it works in Windows XP, just not 7. It also won't work with Vista or 8, but nobody cares.

 

To clarify, this is NOT a wireless issue. It does it over wired ethernet and wifi (N). Somehow, the router is not treating Windows properly and is not giving it access, or Windows is just doing something stupid. Is there something I have to set up for it to work?

  • 1. Re: AirPort Extreme will not work with any Windows 7 computer.
    LaPastenague Level 8 Level 8 (35,415 points)

    Please give me the full info .. copy and paste from command window

     

    ipconfig /all

     

    And it would help to also see a working result from any Mac..

     

    List of IP, subnet, gateway (router) and DNS.

     

    I have win7 working fine and windows 8.

     

    Also good to know what model AE and what firmware it is running.

     

    Have you loaded the airport utility on the windows machine?

     

    Can it see the AE at all??

  • 2. Re: AirPort Extreme will not work with any Windows 7 computer.
    d00dbro Level 1 Level 1 (40 points)

    I haven't loaded AirPort Utility onto the Windows machine. It can see the AEBS's wifi network and connect to it with the WPA password, though, but it doesn't get Internet access from it.

     

    My Mac running 10.8.4 on ethernet as an example:

    IPv4: 192.168.1.12

    Subnet Mask: 255.255.255.0

    Router: 192.168.1.1

    DNS: 192.168.1.1 (gets DNS from router's DNS settings)

     

    The AEBS firmware is 7.6.4. IP address is 192.168.1.1.

     

    ipconfig /all isn't valid usage of the ipconfig command, it says. Here is the netstat result from Network Utility, if that's what you're looking for:

     

    Routing tables

     

    Internet:

    Destination        Gateway            Flags        Refs      Use   Netif Expire

    default            192.168.1.1        UGSc            3        0     en1

    127                localhost          UCS             0        0     lo0

    localhost          localhost          UH              4      758     lo0

    169.254            link#5             UCS             0        0     en1

    192.168.1          link#5             UCS            10        0     en1

    192.168.1.1        f8:e4:fb:85:73:b7  UHLWIir         5       78     en1   1191

    192.168.1.9        0:25:4b:8:56:60    UHLWIi          0        0     en1   1192

    192.168.1.12       localhost          UHS             0        0     lo0

    192.168.1.14       0:25:4b:6:c:8      UHLWIi          0        0     en1   1187

    192.168.1.15       e4:48:c7:27:53:d2  UHLWIi          0        0     en1   1187

    192.168.1.21       d8:d1:cb:9d:3f:69  UHLWIi          5       95     en1   1188

    192.168.1.24       cc:8:e0:8f:ed:ff   UHLWIi         17      582     en1   1187

    192.168.1.30       0:1b:63:f1:cf:37   UHLWIi          0        0     en1   1190

    192.168.1.33       0:25:4b:3:bf:20    UHLWIi          0        0     en1   1187

    192.168.1.47       0:1b:63:f1:cf:37   UHLWIi          0        0     en1   1190

    192.168.1.255      ff:ff:ff:ff:ff:ff  UHLWbI          0       28     en1

     

    Internet6:

    Destination        Gateway            Flags         Netif Expire

    localhost          link#1             UHL             lo0

    fdb1:4092:ac7b:c13 fe80::9043:c1c7:16 Uc            utun0

    fdb1:4092:ac7b:c13 link#8             UHL             lo0

    fe80::%lo0         localhost          UcI             lo0

    localhost          link#1             UHLI            lo0

    fe80::%en1         link#5             UCI             en1

    alecs-mac          0:1d:4f:48:fb:c5   UHLI            lo0

    kitchen.local      0:25:4b:0:d6:60    UHLWIi          en1

    terrace.local      0:25:4b:3:bf:20    UHLWIi          en1

    gameroom.local     0:25:4b:4:5c:42    UHLWIi          en1

    master.local       0:25:4b:6:c:8      UHLWIi          en1

    float.local        0:25:4b:6:c:78     UHLWIi          en1

    kathleens-imac.loc 3c:7:54:79:63:f8   UHLWIi          en1

    apple-tv-4.local   7c:d1:c3:2c:34:ca  UHLWIi          en1

    alecs-iph          cc:8:e0:8f:ed:ff   UHLWIi          en1

    alecs-iph          d8:d1:cb:9d:3f:69  UHLWIi          en1

    fe80::%en2         link#6             UCI             en2

    fe80::%utun0       fe80::9043:c1c7:16 UcI           utun0

    fe80::9043:c1c7:16 link#8             UHLI            lo0

    ff01::%lo0         localhost          UmCI            lo0

    ff01::%en1         link#5             UmCI            en1

    ff01::%en2         link#6             UmCI            en2

    ff01::%utun0       fe80::9043:c1c7:16 UmCI          utun0

    ff02::%lo0         localhost          UmCI            lo0

    ff02::%en1         link#5             UmCI            en1

    ff02::fb%en1       link#5             UHmW3I          en1   3555

    ff02::%en2         link#6             UmCI            en2

    ff02::%utun0       fe80::9043:c1c7:16 UmCI          utun0

  • 3. Re: AirPort Extreme will not work with any Windows 7 computer.
    LaPastenague Level 8 Level 8 (35,415 points)

    Change the DNS in the PC to 8.8.8.8

     

    If you have local access to the network and can ping local IP but not internet you probably simply cannot resolve addresses.

     

    You have moved the IP of the AE from default.. this is not always wise.

  • 4. Re: AirPort Extreme will not work with any Windows 7 computer.
    d00dbro Level 1 Level 1 (40 points)

    I am able to ping the Windows PC. It has an IP address when I connect it (192.168.1.43).

     

    Another thing: Some Windows computers are actually able to connect to the Internet if they connect to the AEBS wirelessly but not over wired ethernet. I didn't know this before. The one I just tested was one of them.

  • 5. Re: AirPort Extreme will not work with any Windows 7 computer.
    d00dbro Level 1 Level 1 (40 points)

    Forgot to mention that this started happening when I switched my old router (Verizon Actiontec router) with an AEBS for various reasons, mainly because the old router seemed to be slowing down DNS lookups really badly. I made the AEBS's IP address 192.168.1.1 since that's what the old router's was.

  • 6. Re: AirPort Extreme will not work with any Windows 7 computer.
    LaPastenague Level 8 Level 8 (35,415 points)

    So did you bridge the Verizon router? Or do you have double NAT?

     

    Double NAT will cause issues..

     

    Local DNS cache on a router can be a problem.. we have had lots of modems and routers that had very poor DNS implimentation. It is much better to use directly a DNS server on the internet either your ISP or the general Google ones.

  • 7. Re: AirPort Extreme will not work with any Windows 7 computer.
    d00dbro Level 1 Level 1 (40 points)

    No double NAT. I didn't bridge it either. The serviceman switched our fiber modem to output ethernet instead of coax, then I connected the AEBS to it directly.

     

    I forgot to say in my other post that I changed the DNS without problems, but it still could not connect to the Internet. I originally wrote that it wasn't letting me change it, but I was doing it wrong (IPv6 instead of IPv4), then I removed that sentence but forgot to say that I tried it.

     

    I just realized that it might be a good idea to try connecting to a site by its full IP address, not a domain name, and see if that works. I'll try that once I have the chance.

  • 8. Re: AirPort Extreme will not work with any Windows 7 computer.
    d00dbro Level 1 Level 1 (40 points)

    I can't ping any outside servers such as 8.8.8.8, so it's not a DNS problem.

  • 9. Re: AirPort Extreme will not work with any Windows 7 computer.
    LaPastenague Level 8 Level 8 (35,415 points)

    If you cannot ping out you have no connection.. can you ping the main router??

     

    You stated you can ping the windows PC and the windows PC works over wireless.. just fails over ethernet..

     

    Did you replace the ethernet cord?

     

    Do the connectivity LEDs come one?

     

    Try fixing the speed of the ethernet in the computer.. you cannot do this in the AE.. or is the PC plugged in by the switch??

     

    Make sure jumbo frames is not turned on.. I am not at all sure Apple products work with jumbo frames.

     

    Make sure the whole listing in ipconfig is correct.. gateway and DNS in particular..

     

    Ping from windows 192.168.1.1

    If that works and 8.8.8.8 fails.. then the router is the issue.. it is not forwarding packets from the windows computer via ethernet although it works via wireless.. that is pretty odd combo..

     

    BTW.

    My strategy to fix this. or any network fault.. simplify and substitute. 

     

    1. Reduce the network to bare min.. Modem in router mode. and one windows computer plugged in by ethernet.. wireless off.. everything reset and reconfigured. Plus a full power cycle.

     

    If it works then add one more piece. The AE.. in bridge.. if it works add the next ie switch.. add one more piece each express.. until you build out the network again. You can also change the modem to bridge and the AE to router if you want that configuration.. use only the one windows computer though.. and ethernet only.

     

    2. If it fails.. get the latest ethernet drivers.. test with at least 2 or 3 known good patch cables.. test with static IP in the computer.. in the end test with another router. Keep replacing things until you find the culprit and replace it.