Skip navigation

MacBook won't connect to the internet!!!

519635 Views 168 Replies Latest reply: Apr 8, 2014 10:42 AM by Bladnoch RSS
  • esgray Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2013 6:37 PM (in response to Rigelface)

    OMG THANK YOU!! That worked!

     

    I don't know what it is about AT&t...

  • marsdenmanor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2013 12:44 AM (in response to mayfi944)

    I tried many of the solutions above. Here's what worked for me for my iMac to talk to my macbook.

     

    The problem was the self-assigned ISP one which meant the mac couldn't go on the net, despite the airport connection showing ok.

    First, I had to restore internet sharing.

    Second, I think I'd been trying to use the IPv6 (under the TCP/IP protocol) all the time. But I found an ISP (101.114.152.142) somewhere in the settings, and copied it to IPv4 (maybe because the macbook only has version 10.6.3?), and bingo. Miracles never cease.

     

    Thanks all for the shared wisdom.

  • esgray Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2013 1:06 AM (in response to marsdenmanor)

    Actually, that re-create solution only worked temporarily. Today the internet went out again, so I recreated the airport again, and it worked, then minutes later it went out and nothing would work.

     

    Turns out something was off with my ISP...I think I did it when I was screwing around with it earlier. So I had to reconfigure my network settings, and now it is working, and the ISP number was automatically reconfigured in the process.

  • Arifmac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 31, 2013 11:57 AM (in response to mayfi944)

    After trying all the solutions on this thread the only thing that worked for me is resetting the SMC. This is an old trick that we used to use in the 90's but I totally forgot about since I didn't need it for many years now.

     

    Step #1: Shut down you computer and unplug from mains power source. leave for 15 seconds or more

     

    Step #2: Plug power cord and after 5 seconds start up your Mac.

     

    That's it.

     

    Read more here: http://support.apple.com/kb/ht3964

     

    The problem I had: For no reason my iMac disconnected from internet even though all other Macs, iphones, ipad are connected and working as normal.

     

    It refuses to get an IP address from DHCP router provided by my ISP. Getting connected on wi-fi.

    I tried ethernet cable but still no IP adress on that port.

     

    Tried every solution mentioned here but it didn't work. After more than 24 Hours of frustration and system reinstall it hit me. why don't try an old trick and viola! It worked.

     

    **** how we're dependant on the internet.

  • BDAqua Level 10 Level 10 (114,685 points)
    Currently Being Moderated
    Aug 31, 2013 3:52 PM (in response to Arifmac)

    Thanks for the tip/post!

  • pinkruby Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 8, 2013 6:21 PM (in response to SocialGen)

    socialjen you rock my sox I have been trying to figure this out for months now womps to have to keep connecting to wifi everytime you need to use the intenet thanks so much your post finally helped me.

  • Winxz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 10, 2013 12:24 AM (in response to BDAqua)

    i'm running mac os x 10.6.8

    i have a problem with connection of my mac

    i was connected to Wi-Fi but when i open safari and open facebook.com

    it say that i'm not connected to internet

     

    can help me with this problem?

  • moom73 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2013 12:26 PM (in response to Winxz)

    This happened to me about 5 yrs ago, with my old mac. Now today evertyhing MacBook, Iphone, Ipad all wont connect, exactly the same oddness as before. The system even tells me my password is wrong, which it isn't. I am currently wired in to try and solve this. This seems like its a very old problem which is still going on.

  • mng241 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 8, 2013 3:40 PM (in response to mayfi944)

    Hi, I have had my mac for at least 5 years now and have had the same EXACT problem for about a year. I have figured a way to temporally fix the problem: in safari click network diagnostics then click airport then your network name then you type in your password and if it says that anything about your network has changed you have to click start over and repeat the process all over again. I know this isnt the best solution but I have learned to deal with it. Hope you fix your computer!

  • PeterLuangPrabang Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 4, 2014 9:09 PM (in response to SocialGen)

    Thanks a lot SocialGen. Your struggle of last year wasn't wasted. I could finally reconnect to my own wifi system!!

  • dima_st Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2014 10:13 AM (in response to Rigelface)

    Works for me, Thanks !

  • sahilformind Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 6, 2014 1:56 AM (in response to mayfi944)

    i have found a solution...

    it turn out that there was no ip address in dns settings...so i just put 192.168.1.1 and it worked

     

    go to preferences>network (select wifi in the left panel)>advance>dns>then just press the + sign and add 192.168.1.1 or whatever is shown and apply

     

    it worked for me i do not know if it is a temporary fix but it did work fot me.

  • run4life2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 15, 2014 3:53 PM (in response to mayfi944)

    Hello mayfi944 or others who have similar issues,

     

    If your Macbook shows it has no issue with connecting to your home router or gateway router,  then the problem may be there is a possible bug in OS X. 

     

    How do you know if your Macbook has no issue with connecting to your home router?  just check http://192.168.0.1/  or http://192.168.1.1/ etc. depending on your router's configuration.

     

    If this is the case, you need reset your Macbook DNS cache.  Something like

     

    MacOS® 10.7 and 10.8

     

    1. Click Applications.
    2. Click Utilities.
    3. Double-click the Terminal application.
    4. Type the following command:sudo killall -HUP mDNSResponderALERT! Warning: To run this command, you will need to know the computer's Admin account password.

    #MacOS 10.5 and 10.6

    1. Click Applications.
    2. Click Utilities.
    3. Double-click the Terminal application.
    4. Type the following command: sudo dscacheutil -flushcache

     

     

    Good luck!

  • GwenFromNV Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 16, 2014 5:34 PM (in response to mayfi944)

    I had this same problem, and tried every fix suggested on this thread.  None worked, so I called support.  The fix was this:  on the systems preferences, network, advanced, select DNS.  I added (using the +) two lines (at the direction of support).  8.8.8.8 and then 8.8.4.4.  OK, then Apply, then restart the machine.  Works fine now. 

  • HoopSTB Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 26, 2014 11:53 AM (in response to GwenFromNV)

    Thanks Gwen!  Worked gr8 for me!

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.