Skip navigation

Safari can't verify the identity of the website

141917 Views 76 Replies Latest reply: Feb 25, 2014 6:49 PM by kjcamille RSS
  • sister mary constance Calculating status...
    Currently Being Moderated
    Aug 29, 2013 10:35 AM (in response to wiscgirl)

    Did just getting a new Mac actually stop all the internet nonsense? I updated everthing and hoped it would work, but I would have to talk my husband into a new Mac - and I don't see that happening soon, lol!

  • Cesar Perez Calculating status...
    Currently Being Moderated
    Aug 29, 2013 3:17 PM (in response to RussyPlum)

    I have been busing Comcast for about 12 years now, never had a issue with them. Since, the error only appears when I am on my private network, then it must be some malicious script somewhere. I have a external hard drive hooked to my router, where I keep movies, music, pictures and backups. If I turn the WiFi off on my iPad or iPhone, then I never get the error, its only while I use my network. 

  • Karoleva Calculating status...
    Currently Being Moderated
    Sep 4, 2013 8:01 AM (in response to RussyPlum)

    Hi guys, it's the time and date for me! Thank you! those msgs from every browser were so annoing!

  • Cesar Perez Level 1 Level 1 (25 points)
    Currently Being Moderated
    Sep 4, 2013 11:43 AM (in response to RussyPlum)

    My date and time are perfect and I still get the error ... Still only get it with my Wifi network.

  • foung Calculating status...

    Hi, I had the same problem and didn't want to continue putting information at risk.  I had the right time and date also, but i knoticed a box that said Set date and time automatically so I clicked/checked on it.  I think that worked because i didn't get that alarming message going into my tmobile site or my bank account.  Hope this helps. 

  • Cesar Perez Level 1 Level 1 (25 points)
    Currently Being Moderated
    Sep 8, 2013 4:35 PM (in response to RussyPlum)

    The date and time did not work for me.

  • cm010 Calculating status...

    Thanksssss, it worked

  • robin199 Calculating status...

    This totally worked for me.

  • dca2 Calculating status...
    Currently Being Moderated
    Nov 21, 2013 6:28 AM (in response to RussyPlum)

    I have been getting the same error, only in Safari, only when on the school network where I work. I have NO issues at home (ATT uVerse). None of the keychain, date, or plist suggestions fixed it.

     

    My solution: Firefox or Chrome = no issues.

  • KALAFUT Calculating status...
    Currently Being Moderated
    Dec 29, 2013 11:35 AM (in response to RussyPlum)

    SOLUTION:

     

    Open terminal:

    sudo bash

    <put in your login password> (this will give your root access)

    cd /Library/

    mv Keychains Keychains.bad

    REBOOT THE MACHINE.  The system will then rebuild the required keychains and certs.  From there on, you will manually have to provide passwords to each site you log into.  (BTW, if the system tells you that rename is not allowed, quit all programs that may be using the Keychains.  Being root, shouldn't stop you from completing the rename though.)

     

    It's probably malware.  Happened to my Air after a few months of use, tweaking the system, and allowing non-signed apps to run.  I also ran in developer mode (less secure).  Something got a hold of the Keychains and conveniently broke them (to the attacker's advantage).  When I got my Mavericks, I did a backup and a clean install.  All was fine.  I then had to restore some files off the backup (Time Machine, which is limited in use in the first place).  Since I used the same login, it asked me to rename the user.  Which I did.  But, I did not expect it to overwrite my sytem files, nothing to say about Keychains and iCloud.  After the restore, I logged into my Mavericks account, and of course, ANY Internet access was met by a certificate error.  Even Kaspersky couldn't connect and download the latest virus definitions.  The AppStore couldn't connect either.  Chrome, Safari, FireFox - all the same cert issues.

     

    I followed the above procedure and it resolved the problem.  I am now rebuilding the Keychains site by site.  I changed my iCloud password just in case.

     

    Hope this solves your issue.  Remember, you will lose ALL saved Internet passwords.  But you'll have a piece of mind that it's now clean and working.  Watch out for any programs you are launching that don't have a CODE signed cert (Mavericks usually will tell you that and prevent launching the program.  There are several ways to bypass this, the easiest being right-clicking on the program and selecting OPEN. But you are dealing with programs that are usually either open source (and are too cheap to buy a code-signing cert) or they're malware.

     

    You may also want to rename the klif.kext - I have not searched what uses that, but Mavericks told me that it's from an unidentified developer.  I went to /System/Library/Extensions/ and renamed klif.kext to klif.kext.bad_do_not_use and rebooted.

     

    Good luck.

    MacBook Air, OS X Mavericks (10.9.1), internet cert errors keychain
  • KALAFUT Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2013 12:08 PM (in response to KALAFUT)

    Ok - a quick reply.  I have to resolve an issue with the AppStore - UPDATES fail to verify the preflight file and I get a message that it is not signed by Apple.  Stand by,

  • Cesar Perez Level 1 Level 1 (25 points)
    Currently Being Moderated
    Dec 30, 2013 1:56 PM (in response to KALAFUT)

    Hey,

     

    I am still getting the same errors. I just wanted to add that it happens with ALL devices connected to my home network, ex. iPhones, iPads, MacBooks, iMacs. So I am assuming that it is something on the network, router. Since it happens with everyone that connects to it. I also have an external hard drive attached to the router via ethernet. I am not 100% sure that it is related but seems to me like there is a connection.

     

    btw ... still getting all those crazy messages ...

  • KALAFUT Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 31, 2013 6:02 AM (in response to Cesar Perez)

    Coud be Cesar.  A malware program spread through all of your Apple devices and perhaps, using your saved passwords to your WiFi or router in a shared keychain, did some bad joojoo there.  But I don't think it is hardware related.  Do you own any smart devices other than Apple to prove the hardware theory?  A Win PC or a smart TV? If those don't show any signs of this problem, it is not tied to your network hardware.

     

    I was a bit preoccupied and did not get the chance to figure out the AppStore issue, but I noticed that after the restore of the second account, a lot of the applications are owned by root:wheel as well as <login>:admin or <old login>:admin.  There are some that are owned by user 503:admin.  That's very odd.  I'll continue my investigating. But given that in some countries it's New Year's Eve, or already passed, today doesn't look promising.

     

    Also, at my login screen, a third user appeared (as an option): Guest.  That warrants another investigation.  And I do need to re-register my Kaspersky, as it keeps crying about not all options not being enabled.  Ugh.

     

    Happy 2014.

  • jrs1957 Calculating status...
    Currently Being Moderated
    Jan 8, 2014 8:46 AM (in response to Cliff-R)

    This trick just fixed muliple problems for me- the iTunes store now works, the Mac App Store now works, those "can't verify" messages went away, the PayPal site now loads with proper formatting in Safari.  This is with Lion (though now the Mac App Store is working, I can upgrade to Mavericks).  Thanks!

  • Cesar Perez Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jan 11, 2014 12:25 PM (in response to jrs1957)

    The problem is that all devices connected to the router have the same issue, I have been testing an Android based tablet and it has not shown the same error as ALL types of Apple products. I have read elsewhere that some people have changed their routers, and that seems to fix the problem. So it looks like a router issue. I am not making a statement, but so far is what makes more sense to me.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.