Skip navigation

MacBook Pro early 2011 with Seagate sshd gets I/O errors

1577 Views 17 Replies Latest reply: Sep 3, 2013 2:14 AM by LexSchellings RSS
1 2 Previous Next
Espen Vestre Level 1 Level 1 (140 points)
Currently Being Moderated
Aug 28, 2013 2:02 PM



I've mounted a 1TB Seagate SSHD in my son's early 2011 MacBook Pro and unfortunately it does not work quite as expected. We get a lot of I/O errors, sometimes so many that it's not even possible to log in. Here's what we've found out:


1) The 320GB ordinary HD that came with the mac seems to work perfectly

2) The 750 GB ordinary HD that was in the mac before worked fine

3) When mounted in an external enclosure via USB, the 1 TB SSHD seems to work without errors at all (the mac boots fine from the disk and logs no I/O errors)


So there seems there might be a problem with high speed SATA on this machine. I forgot to check the negotiated speed when the 320GB disk was mounted internally, but the speed for the SSHD is 6 Gigabit/s.


So my questions are:


- are there known problems with this mac and high speed SATA?

- if not, what is the most likely problem - cable?




MacBook Pro with Retina display, OS X Mountain Lion (10.8.3)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.