1 2 Previous Next 16 Replies Latest reply: Oct 19, 2013 9:25 PM by drkmenon
ARMartinez0984USN Level 1 Level 1 (0 points)

I have a Macbook Pro with Mountain Lion v. 10.8.4 and it will not automatically connect to wifi after waking from sleep. Any advice I've tried everything I've seen already anything new that might help.

 

Thank you,

Alex

  • 2. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    ARMartinez0984USN Level 1 Level 1 (0 points)

    I've tried that already also, every time the MacBook goes to sleep, when it wakes up, it will show the wifi searching icon in the bar, then all the signal strength bars will go grey as if there is no connection. I have to go to that wifi menu in the bar and click on my access point to get it to actually connect. This issue happened after upgrading to 10.8.4

  • 3. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    Linc Davis Level 10 Level 10 (117,820 points)

    Is the network listed as a Preferred Network in the Network preference pane, and if so, do you have the same problem with other preferred networks?

  • 4. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    ARMartinez0984USN Level 1 Level 1 (0 points)

    Yes its in the preffered networks, I tried all the things i've seen, Keychain, plists etc and still it wouldn't reconnect after sleep.

     

    When asked for my password when connecting to wireless if i put it to remember it says connection failed, if i unclick the remember it will go as usual with no issues. but when i put my mbp to sleep if i wake it it will not automatically connect to the internet i have as my favorite. it seems to be an issue with mountain lion 10.8.4 it only happened after i updated to the 10.8.4.

     

    But it wont automatically reconnect after waking from sleep as usual idk what the problem is im thinking its something to do with the OS and Apple hasnt found a fix for it.

  • 5. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    Linc Davis Level 10 Level 10 (117,820 points)

    Are there any other preferred networks, and if so, do you have the same problem with them?

  • 6. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    ARMartinez0984USN Level 1 Level 1 (0 points)

    No when i did yes i had the same issue

  • 7. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    Linc Davis Level 10 Level 10 (117,820 points)

    Back up all data before making any changes.
         
    Step 1
      
    Take all the applicable steps in this support article.
      
    Step 2
       
    If you're running OS X 10.8.4 or later, run Wireless Diagnostics and take the remedial steps suggested in the summary that appears, if any. The program also generates a large file of information about your system, which would be used by Apple Engineering in case of a support incident. Don't post the contents here.

    Step 3

    If you're not using a wireless keyboard or trackpad, disable Bluetooth by selecting Turn Bluetooth Off from the menu with the Bluetooth icon. If you don't have that menu, open the Bluetooth preference pane in System Preferences and check the box marked Show Bluetooth in menu bar. Test. Continue if you find that Wi-Fi is faster with Bluetooth disabled.

    From that same menu, select Open Bluetooth Preferences. If the box labeled Discoverable is checked, uncheck it. Click the Advanced button, and in the sheet that opens, uncheck the top three boxes, if any are checked. Click OK. Enable Bluetooth and test again.

    If the application called "Bluetooth Setup Assistant" is running, quit it.

      
    Step 4

    This step will erase all your settings in the Network preference pane. Make a note of them before you begin, and recreate them afterwards. It may be helpful to take screenshots of the preference pane.

    Triple-click the line below on this page to select it:

    /Library/Preferences/SystemConfiguration

    Right-click or control-click the highlighted line and select

    Services Reveal

    from the contextual menu.* A folder should open with an item named "SystemConfiguration" selected. Move the selected item to the Trash. You may be prompted for your administrator password.

    *If you don't see the contextual menu item, copy the selected text to the Clipboard (command-C). In the Finder, select

    Go Go to Folder...

    from the menu bar, paste into the box that opens (command-V). You won't see what you pasted because a line break is included. Press return.

    Reset the System Management Controller.

  • 8. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    bureljo Level 1 Level 1 (0 points)

    Hi ARMartinez0984USN,

     

    I recently had the same issue you were having where my computer would force me to manually select my preferred network.  I found your thread and read a few other articles online and was able to fix the problem.  I hope you have solved the issue by now, but if not this article helped me: http://www.askdavetaylor.com/how_to_have_mac_autoconnect_wifi_network.html

     

    Essentially all I had to do was delete my network from the preferred networks list and then ad it back.  After this my problem was solved.  Hope this helps with your problem.

  • 9. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    ARMartinez0984USN Level 1 Level 1 (0 points)

    I've tried it all still nothing has helped. Still I have to manually connect to my preffered network and still it will connect and say connection timed out, BUT HERE'S THE KICKER, it stays connected with no issue it just wont automatically connect i feel as if its a software issue from Apple and nothing more. I just hope they figure it out and fix this i hate how the update is for 10.8.4 this is crappy.

     

    All I want is to automatically connect to my preffered network when i turn on or wake my MBP and nothing I've seen works.

  • 10. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    Brianfit Level 1 Level 1 (0 points)

    I had the identical issue after upgrade to 10.8.4


    The recommendation to simply delete my network and re-add it didn't work. And the down side of deleting com.apple.network.identification.plist is that you lose all your Network preferences.

     

    An alternate, less destructive fix that worked for me: add a location, change to that location. Bam. Done.

     

    >SystemPreferences >Network > Location > Edit Locations +to add a new location, Apply, then Reboot.

     

    I kept all my preferred networks intact AND solved the issue of Wifi not connectiong automatically.

     

    Not sure what the root issue is, and that bothers the geek in me, but having lost my Saturday Morning trying different solutions, I'm going to let that sleeping dog lie and be glad it's working. ;-)

  • 11. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    3000ways Level 1 Level 1 (0 points)

    I finally fixed this annoying issue. Here is what I did (I'm not sure which step actually fidex the problem).

     

    Remove all networks.

    Remove all wifi passwords stored in keychain.

    Re add the network(s).

    (still not connecting after waking up from sleep at this point)

    Update OS to latest version 10.8.4

    Restart!

     

    Bazinga it WORKS!!!

  • 12. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    kkulkarni Level 1 Level 1 (0 points)

    I had tried deleting and the network several times before, to no avail.

     

    This is what I noticed:

    On the 'Advanced' page where it lists all the networks, notice the entry in the Security column.

    For mine it said 'None', this was even after I had picked WPA2 Personal and added the password several times before.

     

    Here is what worked:

    I deleted the offending network, while adding the new network selected the security type as "Any (Personal)", entered the password and saved. Now the security type says "Any (Personal)" and the network starts on wake up from sleep

  • 13. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    ARMartinez0984USN Level 1 Level 1 (0 points)

    I finally found a solution to my issue it turns out in my 'Keychain' I didn't have the airport password saved under the 'system' keys. This as of now has solved my issue. This is what I did.

    "Go to Keychain Access and remove all airport passwords for this network from Login and System keychains.

    Then create a new password in System. Enter as password the network password. Item Name and account name: name of the network. Click add. Then double click the new item in list. Change kind to 'airport password'. Then click Access Control and select Allow all applications to access this item.

    Restart your computer if it doesn't joins automatically join it manual, next startup it will works fine again."

     

    http://apple.stackexchange.com/questions/80224/mountain-lion-not-joining-preferr ed-wpa2-wifi-network/81750#81750

  • 14. Re: Macbook pro 10.8.4 will not connect automatically to wifi
    Linc Davis Level 10 Level 10 (117,820 points)

    That was in Step 1 of my comment of July 21.

1 2 Previous Next