Skip navigation

Unable to enter new info on Ical,

412 Views 2 Replies Latest reply: Aug 30, 2013 7:40 AM by gmitch_uk RSS
LynneFranco Calculating status...
Currently Being Moderated
May 4, 2013 8:06 AM

I'm a longtime Ical use, suddenly I am getting message "Calendar encountered a critical error while saving to the database, and recent changes may be lost. More information may be available in the console. What's up with that?

  • pjdube Level 3 Level 3 (830 points)
    Currently Being Moderated
    May 4, 2013 9:14 AM (in response to LynneFranco)

    Please explain what you have tried already doing to handle this, i.e. have you restarted iCal? Have you looked in the Console log?

  • gmitch_uk Calculating status...
    Currently Being Moderated
    Aug 30, 2013 7:40 AM (in response to LynneFranco)

    I had this exact issue after migrating to a new iMac.  I tried the following recommended on another post:


    Quit iCal. In Finder, from the Go menu select 'Go to Folder...'. Enter the path~/Library/Calendars/ . A new Finder window should open. From that window move the file Calendar Cache to your Desktop. Re-open iCal.


    No joy.


    But I had elsewhere has permissions issues caused by the migration.  So I went to the folder about.  Clicked on "Get Info" in Finder - and gave myself (my user) explicit permission to read write - and applied this to all folders and files within the folder. 




    Hope this is useful to someone.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.