Skip navigation

When I play a movie through iTunes, audio has no issues but video stutters and skips

658 Views 1 Reply Latest reply: Sep 2, 2013 10:39 AM by griff w RSS
MooreSA Calculating status...
Currently Being Moderated
Aug 31, 2013 2:27 PM

Hey everyone,

 

I have a Dell 17R, Windows 8 64 bit, intel i7-3630QM at 2.4 GHZ, 8gb ram, Nvidia GT-650M at 1920x1080 using driver 320.49

 

When I play a movie in iTunes, the audio works flawlessly but the video will be smooth for a few seconds, stutter and then skip small 2-3 second spots. I haven't noticed that the parts skipped are any more graphically intense than other spots and there is no discernable pattern.

 

In the past, I have been able to play movies through iTunes with absolutely no problem but when I downloaded this most recent one a few days ago all of my movies have been experiencing the same issue.

 

When I stream other videos from other sources I do not experience the same problems as I do when I use iTunes. Streaming 1080P over youtube or a similar services is no issue.

 

I have updated my video drivers to the latest version as well.

 

I am at a loss, any suggestions would be appreciated.

Thanks!

Microsoft windows 8.iTunes, Windows 8

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.