Skip navigation

iTunes 11 not showing movies I add from External

22345 Views 20 Replies Latest reply: Oct 5, 2013 10:41 AM by airhead75/5 RSS
  • Kittihawk Calculating status...
    Currently Being Moderated
    May 9, 2013 3:20 PM (in response to dunner17)

    It is difficult to give an excoriative enough condemnation of iTunes 11 for such a pig-headed timewasting misunderstanding of how people work with their own movies.

     

    iTunes 11 -that suggests eleven iterations of this software, not some amateur Beta version of an arrogantly interfaced travesty of all that Wozniak and Jobs strove to achieve. I could go on but you get the idea, although sadly no one at Apple actually reads this stuff - it's just an automated self serving PR exercise, that gets the punters to do all the heavy lifting. Goodness knows where the employees actually are, even though some of them are pretty bright, if lacking in common sense.

     

    So here's what's wrong: THERE IS NO DIALOGUE BOX TO TELL YOU SOMETHING IS NOT WORKING.

     

    There may be several reasons why your movie won't import, or will import but won't show you it has. The two most common are most likely that it is the wrong format (BUT iTunes 11 won't tell you that  - it just does nothing), or that the movie location on your computer has been accidently moved (BUT iTunes 11 won't tell you that - it just does nothing). Without knowing that there's a problem you will go round and round on this like a deranged hamster on steroids as it spins its wheel off its bearings.

     

    For pity sake this is meant to be a user friendly catch all media programme for the masses. HELLO ... HELLO ... IS THERE ANYOJNE OUT THERE?

  • anuragsharma Calculating status...
    Currently Being Moderated
    Aug 12, 2013 8:34 PM (in response to dunner17)

    I had the same problem on my Windows machine. I checked the properties and the mp4 files were 'read only'. Removed the 'read only' permission and then I was able to add them to iTunes.

  • Dougalan Calculating status...
    Currently Being Moderated
    Aug 24, 2013 7:55 PM (in response to dunner17)

    I have found that adding movies to iTunes using "Add to Library" (Command-O) makes them land up in the Home Videos section instead of the Movies section were they used to end up and I still want them to end up there. Lucky for me in found the solution. When I open up my iTunes program and click Movies on the left side then once in Movies I click on Home Videos and see all those movies I want in the movie folder, this is what to do.

     

    I simply click on a single movie file "Get info" (Command-I) or "Select All" (Command-A) (side note if you select all and "Get info" (Command-I) you will confronted with a dialogue box asking you, "Are you sure you want to edit information for multiple items?" ). Click yes.

     

    Do not attempt to change the Genre of the file to "movie" or for that matter anything in the "Info" tab. Instead select the "Options" tab and under "Media Kind" change the information from Home Video to Movie. Then click OK and wait a few seconds and whatever Home Video you've selected for this process will disappear and reappear in the movies section of Movies.

     

    I'm sure there are tricks to make sure this doesn't happen again but if you just want to take about one minute to correct the existing problem files this works flawlessly.

     

    I have a MacBook Air 13 inch 2011 running OSX 10.8.4 and my iTunes version is 11.05

     

    Thank for taking the time to read this.

  • Paul E! Calculating status...
    Currently Being Moderated
    Sep 2, 2013 8:32 AM (in response to dunner17)

    Hi had the same issue, found that going to

     

    itunes > preferences > advanced - - - click off (no check in box) - - - keep itunes media folder organized

     

    then i clicked reset cache - all my movies showed up

  • chuckrogers Calculating status...
    Currently Being Moderated
    Sep 24, 2013 4:29 AM (in response to Dougalan)

    Dougalan, thank you.

  • airhead75/5 Calculating status...
    Currently Being Moderated
    Oct 5, 2013 10:41 AM (in response to Dougalan)

    This worked for me!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.