8 Replies Latest reply: Sep 4, 2013 2:44 PM by Carolyn Samit
pirhan Level 1 Level 1 (25 points)

Today Safari is only showing the domain name of the website I am on and not the actual URL. Why? I don't like this and I find it very confusing. I want to see the whole domain name. There should be more to the web URL than just "discussions.apple.com". How do I get it like before? Why did it change? I don't remember changing any settings.

 

Screen Shot 2013-09-03 at 12.29.13 PM.png


MacBook Pro, OS X Mountain Lion (10.8.3)
  • 1. Re: Why is Safari only showing domain name?
    Carolyn Samit Level 10 Level 10 (89,730 points)

    Might be a cache issue ..

     

     

    Open a Finder window. From the Finder menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Caches/com.apple.Safari/Cache.db

     

    Click Go then move the Cache.db file to the Trash.

     

     

    Quit and relaunch Safari to test.

     

     

    BTW, your profile indicates your Mac has v10.8.3 installed. If that is correct, the v10.8.4 update is available.

     

    Either click Software Update from your Apple menu  OR open System Preferences > Software Update then click Check Now.

  • 2. Re: Why is Safari only showing domain name?
    pirhan Level 1 Level 1 (25 points)

    Hi Caroyln,

     

    Thanks for the quick reply. It doesn't look like I have Safari/Cache.db...

     

    Screen Shot 2013-09-03 at 1.56.51 PM.png

     

    I do believe there are updates avaialble, however I don't like updating. My MacBook Pro is just a few weeks old, my last compter was an iBookG4, so I'm not comfortable yet with the MacBook. There are lots of things that I don't like (having cookies and cache in one place where I can't clear it without clearing the saved cookies for instance) and I want to get comfortable before I go changing it again. Too many things happen on this laptop where I don't know why or how to correct it.

  • 3. Re: Why is Safari only showing domain name?
    Carolyn Samit Level 10 Level 10 (89,730 points)

    You missed the Tilde character  ~

     

     

    ~/LibraryCaches/com.apple.Safari/Cache.db

     

     

    This doesn't change anything as far as important system files go. It only deletes the cache database associated with Safari.

     

    The next time your relaunch Safari, a new Cache.db file will be generated.

     

    This is used for troubleshooting purposes.

     


     


     


  • 4. Re: Why is Safari only showing domain name?
    pirhan Level 1 Level 1 (25 points)

    I don't know where else to look:

     

    Screen Shot 2013-09-03 at 2.19.40 PM.png

  • 5. Re: Why is Safari only showing domain name?
    Carolyn Samit Level 10 Level 10 (89,730 points)

    You're in the root folder. You need to be in your Home folder

     

    Open a Finder window. From the Finder menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Caches/com.apple.Safari/Cache.db    

     

    Click Go then move the Cache.db file to the Trash.

     

     

    Quit and relaunch Safari to test.

     

     

    /Library is root

     

    ~/Library is user     ~ Tilde character repsents your Home folder

  • 6. Re: Why is Safari only showing domain name?
    Linc Davis Level 10 Level 10 (118,385 points)

    From the Safari menu bar, select

            

    Safari Preferences Extensions

         

    Turn all extensions OFF and test. If the problem is resolved, turn extensions back ON and then disable them one or a few at a time until you find the culprit.

     

    If you wish, you may be able to salvage the errant extension by uninstalling and reinstalling it. Its settings will revert to their defaults. If the extension still causes a problem, remove it permanently or refer to its developer for support.

  • 7. Re: Why is Safari only showing domain name?
    pirhan Level 1 Level 1 (25 points)

    Thanks! This solved it.

  • 8. Re: Why is Safari only showing domain name?
    Carolyn Samit Level 10 Level 10 (89,730 points)

    You're welcome