Skip navigation

iMovie says I do not have enough disk space or permission

2137 Views 6 Replies Latest reply: Oct 11, 2013 2:53 AM by craigspofford RSS
craigspofford Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 6, 2013 3:59 AM

I continue to periodically get an error that says "Cannot create project.  Please check the disk to ensure that there is enough free space and you have permission to write projects."

I have almost 250 GB of free space and I have full admin on my Mac Book Pro.  iMovie and my OS are all up to date on updates.  I have repaired permissions (more than once) and I have restarted iMovie.  Not sure what's going on.

 

I'm trying to think of what I have not tried....

Is there a way for me to see where I am creating my project?  My concern is that it might be looking for a currently disconnected external drive, except that I have had this same error when that drive is connected (and I am pretty sure I never pointed anything to that drive anyway).

 

Any help here is appreciated.

 

Craig

MacBook Pro, OS X Mountain Lion (10.8.4)
  • Karsten Schlüter Level 7 Level 7 (29,450 points)

    could be lots of things ...

     

    • do you use external hard-drives?
    • do you use usb-sticks to transfer media into actual iMovie Projects/Events?
    • do you use 'disk images'?
    • do you use 'NAS' drives?
    • do you use TimeCapsule for any iMovie related media?
    • did you change anything in iMovies folder structure on your drive? (e.g. putting iM-Events/-Projects into sub-folders)?

    hard to tell nor narrow down from remote …

  • Karsten Schlüter Level 7 Level 7 (29,450 points)

    it's not solved at all!

     

    My assumption is just:

    iMovie permanently read/writes data; not only when you import from cam or you quit iMovie. There are lots of background tasks happening, … that's why BY CONCEPT, all media should be on your internal drive! This guarantees a 100% accessability.

     

    Another example: iM, by concept, can handle only hfs/'Mac' formatted drives; very few network drives are formatted that way… (more fat/Windows, or NTFS, which Mac reads, but can not write!)

     

    So, in a 'networked' surrounding, it could happen, you access some music, or a photo or a video from 'some' drive, iM tries to update some meta-data - and fails.

     

     

    I have imported movies into events from the network,…

     

    I dare to say, this is the culprit. …

     

    In case, all your media is now local, you could try the 'trash prefs'-routine, in hope, iMovie 'forgets' any external connections:

     

    follow advice given in this user tip:

    >>click>>                  How do I trash the iMovie Preferences File? and Why?

     

    fingers crossed, this helped

  • angus cooney, angus cooney Level 1 Level 1 (10 points)

    Try renaming the movie.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.