Skip navigation

iMessage not working for phone number

51032 Views 32 Replies Latest reply: Feb 20, 2014 11:11 AM by Strive268 RSS
1 2 3 Previous Next
gjn6595 Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 7, 2013 4:23 PM

I'm currently traveling internationally and have my data turned off and my phone NOT on airplane mode. For the first 2 days I was here and connected to WiFi iMessage was working normally. After- it stopped working all together and after trying a bunch of methods to fix it, I only got it to work for my apple ID and n ot my phone number anymore.

PLEASE HELPP

iPhone 4S, iOS 6.1.4
  • appletechexpert Level 1 Level 1 (30 points)
    Currently Being Moderated
    Sep 7, 2013 4:30 PM (in response to gjn6595)
    • Have you verified that you still have iMessage activated on your phone?
    • Try turning off/on iMessage in settings
  • Noahwhite2014 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Sep 7, 2013 4:44 PM (in response to gjn6595)

    gjn6595, Try this:

     

    Go into your phone settings
    Go to Messages

    Go down to Send & Receive
    Next to it it should say "X Addresses" (1 Address, 2 Addresses, etc)
    Go into that setting pane and look at the addresses.
    Make sure your Phone number is checked and that "Start New Conversations From" is set to your Phone number (Scroll down in that settings pane if you can't see it)

     

    If that doesnt work, In the same settings pane, tap on your apple ID at the top and sign out and back in and try repeating the process. If that doesnt work, go to the icloud settings pane and log out and back in and let me know how it works out!

     

    Good Luck!
    Noahwhite2014

  • Noahwhite2014 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Sep 8, 2013 2:36 PM (in response to gjn6595)

    I just went ahead and deactivated my iMessage to see if i could replicate what you were at.
    From my testing around with activating my phone number for iMessage AND Facetime, I found that you need to 1. Turn off both iMessage and facetime.
    2. Go into Facetime settings and select use Apple ID for facetime
    3. From there log in and select ONLY your iCloud email to recieve text messages at (If its not there select ONLY the email you originally made your apple ID with) [You can change it after activation so dont worry]
    4. Once facetime is activated go to iMessage and turn it on, Log in using the iCloud email as your Apple ID (Or the original Email you made your Apple ID with)
    5. Again select only the same email that you used to log in. You should be activated with your email and it should say "waiting for activation" under the imessage on and off switch

    6. Go to the PHONE settings pane, and change your number from +1 (123) 456-7890 (the numbers are place holders for your phone numbers digits) to (123) 456-7890. And tap Save
    7. Your settings app may crash or it may go back, to the previous screen.

    8. From there go back into iMessage and see if your Phone number is now there.

    9. If not go to the app switcher and quit the settings app by holding down and pressing the minus button.
    10. Re-open settings and go back to phone, and re-add the +1 before your number and go back to iMessage and wait for activation.

     

    I did this 3 times and it worked all 3 times so please follow each step carefully!

     

    NOTE: +1 is the United state country code, make sure you know your country code for this. As far as I know only United States users have the iMessage activation issue.

     

    Good Luck and let me know how it turns out!

  • Ocean20 Level 6 Level 6 (12,380 points)
    Currently Being Moderated
    Sep 9, 2013 1:59 AM (in response to gjn6595)

    Does you normal phone number work overseas?  Just remember that activation of imessage requires the sending of an sms message and in most cases that is an international one.  So unless you have the ability to send such messages do not deactivate imessage otherwise you will not be able to activate it again

  • Noahwhite2014 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Sep 9, 2013 2:05 AM (in response to Ocean20)

    SMS messages work internationally at I believe 50 cents per message on ATT even with unlimited messaging. And for one charge of 50 cents and getting iMessage back, im sure he would be fine with it. The last time i was out of the country the issue was my phone number as well as the time zone.

  • Ocean20 Level 6 Level 6 (12,380 points)
    Currently Being Moderated
    Sep 9, 2013 2:08 AM (in response to gjn6595)

    That could be part of your problem

  • Ocean20 Level 6 Level 6 (12,380 points)
    Currently Being Moderated
    Sep 9, 2013 2:11 AM (in response to Ocean20)

    Like I said if your phone number does not work then you cannot send SMS so if you turn imessage off you have no way of activating it because you have no way of sending SMS.  If you can use it with wifi just leave it like that until you get home

  • Ocean20 Level 6 Level 6 (12,380 points)
    Currently Being Moderated
    Sep 9, 2013 2:19 AM (in response to gjn6595)

    Try and activate imessage when you are connected to wifi it will just continue to say waiting for activation but I read this on how to use an iphone as an ipod and it may well work even if you do not restore the phone as new.  See if you can send imessage from your email address but don't restore your phone as new but just read below

     

    USING AN IPHONE AS AN IPOD

    Restore your phone as new. Place a SIM card into the phone and connect it your computer with iTunes open and follow the activation assistant to activate the iphone.  Once the iphone have been activated remove the SIM card and turn on imessage in settings/messages.  Only your Apple ID should appear in the “You can be reached by imessage at” and “Start new conversation from” fields.  Read the following article for help http://support.apple.com/kb/HT3406

  • Noahwhite2014 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Sep 9, 2013 2:45 AM (in response to Ocean20)

    The only reason for the phone to go through activation is after restoring, so it won't allow him to activate his phone with his SIM card unless he restores it.

     

    @Gjn6595

    Can you make phone calls?

     

    Try to turn off your automatic time zone setting and turn it back on. Its in General>Date & Time> Set Automatically

  • Noahwhite2014 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Sep 9, 2013 2:51 AM (in response to gjn6595)

    Try this after checking your automatic time zone setting.

    1: Turn off iMessage (and FaceTime)

    2: Turn on the Airplane mode. Wifi will be turned OFF automatically.

    3: Turn ON Wifi

    4: Head back to Messages and turn ON iMessage

    5: You’ll be prompted for your Apple ID if you haven’t added it yet. (else, you don’t get any notification)

    6: Now, head back to Settings and turn OFF Airplane mode.

    7: Mostly, you’ll be shown a notification that says "Your carrier may charge for SMS" – Tap on OK (you may be charged 50 cents)

    8: If not, go to Messages, turn OFF iMessage and then turn it ON again.

    9: In a short while, iMessage should get activated.

    10: You’ll see a grayed out number and an email ID. The number should be checked a little later.

    Let me know if this works

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.