1 2 3 Previous Next 40 Replies Latest reply: May 6, 2014 7:31 PM by John Prokos Go to original post
  • 30. Re: ical keeps reverting all appointments to UTC time
    seemaxwork Level 1 Level 1 (10 points)

    @kaz78

     

    No. I just checked and it's reverted to UTC again.

    (mumbles a bunch of curse words).

     

    I'm gonna get in touch with apple about it. I have an open ticket because I thought this might happen.

    Will report back.

  • 31. Re: ical keeps reverting all appointments to UTC time
    coastrman7 Level 1 Level 1 (0 points)

    Having this same issue. It turned out that when Ical tried to sync with an Android phone, it would take Google Calendar's settings. Having never really paid any attention to Google Calendar since I go to Ical all the time, I finally went into the settings of Google Calendar and changed the time zone to my local city and saved it. That fixed the issue immediately. I am in no way a teck guru but it fixed the issue for me. Hopefully it helps.

  • 32. Re: ical keeps reverting all appointments to UTC time
    cdjoyce Level 1 Level 1 (0 points)

    I too have this issue, and the only "fix" has been to turn off Time Zone support.  Since I don't travel much, it's not an issue for me, but can see how it would be, if I did.  Just a thought, it may not be an Apple issue, and instead a Google issue.  I have both a Google Apps calendar, and a iCloud calendar, the issue never happens with events on my iCloud calendar.

  • 33. Re: ical keeps reverting all appointments to UTC time
    paradoxicles Level 1 Level 1 (0 points)

    i found an easy workaround.

     

    the problem occurs:

    1. in the connection between apple calendar and google calendar
    2. when i try to create a new event in apple calendar with the google calendar set as the default calendar.

     

    the problem doesn't occur:

    1. when using the iphone or other mobile device.

     

    assuming, that you've:

    1. correctly set the time zones in your google calendar settings (see previous posts).
    2. you've left time zone support on in the calendar preferences.

     

    solution:

    1. set the default calendar to your icloud or local calendar.
    2. create an event.
    3. change the event's calendar to your google calendar.
    4. done. 
    5. no more utc issue.

     

    i'm operating in mountain lion 10.8.4.

  • 34. Re: ical keeps reverting all appointments to UTC time
    signenoerly Level 1 Level 1 (0 points)

    I had the same problem.

    When I entered an event in Calendar for my google calendar it switched to UTC.

     

    What I did was:

    Go to the Preferences in calendar: Preferences > Advanced > uncheck "Turn on timezone support"

     

    After doing that it all worked like a time.

     

    A few people have suggested that this also plays a part in it, but it doesn't influence anything on my part:

    System Preferences > Date & time: "Set date and time automatically". For me it doesn't matter if this i checked or unchecked. It works either way.

  • 35. Re: ical keeps reverting all appointments to UTC time
    ShiningPrince Level 1 Level 1 (0 points)

    With the very same problem, and after reading this and also having spent quite a bit of time with Apple support (not quite as smart of the people @seemaxwork talked to!), I also tried it.  At first it didn't work, but it occurred to me it didn't work because I never opened Calendar, Mail or Messages after removing the accounts, which would make their settings and folders change from the missing accounts. 

     

    In other words, the first time I tried it, I left everything intact and nothing changed, but I was patient and tried it again, this time making sure to open all three apps before restarting (and then again after restarting), and this time after restoring the accounts and opening Calendar, it was successful!  As @seemaxwork points out, the old appointments still show UTC time zone, but new appointments made using my gmail account (set again to default) stays on my time zone.

     

    I need Time Zone Support so this problem was driving me nuts!  Thanks Max.

  • 36. Re: ical keeps reverting all appointments to UTC time
    wbmiami Level 1 Level 1 (0 points)

    ISSUE FIX 

     

    All my invites from sent to me from coworkers using the Google Apps Calendar were showing the right time ONLY when viewing iCal in "week" view. HOWEVER when I opended the event itself by double-clicking, the time zone within the event was off by 8 hours and showed the actual event time being 8 hours later and also showing GMT: 4:30 for a 9:30 AM event

     

    So to summarize. when viewing iCal by "week" the event was in the right time slot, but when opening event and to edit for example, or to set an alarm reminder, the time zone with in the event was off

     

    To SOLVE this I went to iCal > Preferences > Advanced (tab) > and unchecked Time Zone support. All my events times then went to the correct time! Woo hoo!

     

    System: OS X 10.6.8 Snow Leopard

     

     

    Hope it helpos

    Aslo, Forget using Outlook 2011 as email client with Google Apps., as Google like j*rks stopped supportiung Active Sync that Outlook uses, so not calendar or contct syning.

     

     

    Un effing believable in 2013.

     

    Would you three big companies PLEASSE stop wasting hours and hours of our time to do something as simple as Calndar ad Contact syncing. I had these problems in 1987 on and everytime we get it cross-platfomr, cross-s/w working you nasty companies stop supporting each other costing us users to become VERY ******!

     

    C'mon already, you are not wining marketshare with these tactics! Just making us angry to the point of ridiculousness.

     

    Apple Freak since 1985 but slowly getting tired of these games!

     

    Apple Google and MS marketing: STOP IT ALREADY!

  • 37. Re: ical keeps reverting all appointments to UTC time
    Khilari Level 1 Level 1 (0 points)

    Just to say I have this problem and do not use any google calendars.

     

    I only use iCloud calendars and the problem only occurs on OS X, not on my iPhone or iPad.

     

    With Time Zone Support on, United Kingdom shows in the top right hand corner.

    Despite choosing UK when creating a new event, within a few seconds it reverts to UTC.

    So I just have to turn off Time Zone support on my Mac, though not sure why it doesn't work.

     

    On iOS 7, I have it turned on and it's not a problem.

     

    So I don't think this is only a problem when using Google Calendars.

    __________________________________________________________

    Running

    Mac: Macbook Pro Unibody 13-inch, Mid 2010, OS X Mavericks

    iPhone / iPad: iOS 7

  • 38. Re: ical keeps reverting all appointments to UTC time
    Cat Songs Level 1 Level 1 (25 points)

    Thanks for all the advice!

     

    Moved to Hawaii. MacBook recognized that I was in Hawaii.

     

    But iCal? Kept "translating" times to... EST!!!!!

     

    The only way to stop it from setting a 7:30 HST PM alert to 12:30 EST was to turn off Time Zone Support.

     

    Which leaves me wondering... so if TZS doesn't work... and messes up alerts... what purpose does it serve?

     

    Cheers,

     

    Cat

  • 39. Re: ical keeps reverting all appointments to UTC time
    John Prokos Level 1 Level 1 (0 points)

    This works. It's unfortunate that there is one more step added. What's happening is that the Google API is converting the time to GMT/UTC but not shifting the actual time of the appointment. If you look in day view the appointment hasn't shifted. One of those "features" that we'll have to live with.

    paradoxicles wrote:

     

    i found an easy workaround.

     

    the problem occurs:

    1. in the connection between apple calendar and google calendar
    2. when i try to create a new event in apple calendar with the google calendar set as the default calendar.

     

    the problem doesn't occur:

    1. when using the iphone or other mobile device.

     

    assuming, that you've:

    1. correctly set the time zones in your google calendar settings (see previous posts).
    2. you've left time zone support on in the calendar preferences.

     

    solution:

    1. set the default calendar to your icloud or local calendar.
    2. create an event.
    3. change the event's calendar to your google calendar.
    4. done. 
    5. no more utc issue.

     

    i'm operating in mountain lion 10.8.4.

  • 40. Re: ical keeps reverting all appointments to UTC time
    John Prokos Level 1 Level 1 (0 points)

    Wanted to add one thing. If you create the event using Google Calendar instead of with Apple Calendar the event's time doesn't get converted to GMT in Apple Calendar. So odd. This is definitely a programming issue.

     

    Three options:

     

    1. Turn off time zone support in Apple Calendar

    2. Make a local calendar your default calendar in Apple Calendar preferences instead of the Google CalDAV calendar then change your event to the remote Google calendar after creation.

    3. Enter all of your events using Google Calendar instead of Apple calendar.

1 2 3 Previous Next