Skip navigation

Cannot share internet to phone after using USB LAN adapter - problem with obtaining IP?

446 Views 2 Replies Latest reply: Sep 8, 2013 7:18 PM by Selina_c RSS
Selina_c Calculating status...
Currently Being Moderated
Sep 8, 2013 12:26 PM

I have always used internet sharing (from LAN to Android Smartphone) on my Macbook pro 10.7 and it worked fine.


Recently i have switched to use a Macbook air 10.6, there is no RJ45 slot so i bought a USB-Ethernet adapter (model :KY-RD9700) to get Internet. From then on internet sharing doesn't work any more with my phone. The computer configuration seems normal, but when I typed in my internet sharing password, the phone seems to try to be connecting to the shared network, but stops proceeding at "Obtaining IP address...." and finally fails to connect.


I am aware that the USB LAN adapter has a built-in modem (as the shop keeper told me) and Macbook air also has a built in modem. I dont know if this is related to the said problem.


Does anyone has a similar problem, and does anyone have a solution?


A million thanks!

MacBook Air, Mac OS X (10.6.5)


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.