Skip navigation

Why does iMessage randomly send as text instead?

149989 Views 58 Replies Latest reply: Jan 25, 2014 9:00 AM by S M Williams RSS
  • rockmyplimsoul Level 5 Level 5 (5,375 points)
    Currently Being Moderated
    Aug 1, 2013 6:56 PM (in response to Awnex)

    Awnex wrote:

     

    For some people, i message them and it sends an imessage with wifi no problem but with others, i just get the error message.

    That could be due to a number of things like:  they don't have an iPhone, or they have iMessage turned off, or the iMessage servers are down.

     

     

     

    Awnex wrote:

     

    In addition, often when i return to cell range i will get duplicate messages from people.  That is, the messages received as imessages while out of cell range will come in later as text messages once back in cell range.  Not only is this annoying, but it defeats the whole potential cost saving advantages of imessage.

    That part doesn't sound right.  At my home I have terrible cell service so I usually put my iPhone into Airplane mode and turn on Wi-Fi.  I'll get iMessages no problem, and when I return to LTE service I do not get repeats of the iMessages I received over Wi-Fi.

     

    One possibility for you is that your Wi-Fi coverage is spotty, so the sender's message tries to go out as iMessage but fails, so then reverts to SMS (which also fails, or sits in limbo).  Once you get into Wi-Fi range, perhaps the original attempt comes through as iMessage, then the re-try comes through as SMS once you get back to cellular service.

  • jayf1981 Level 1 Level 1 (0 points)

    Funny because I have been having the same problem with one recipient who has an iphone. Last night, I sent her 2 messages that did not imessage deliver but went through as text. Se replied with imessage. Then today, I sent her another which did not get delivered as imessage, but went through as text.

     

    I assumed yesterday she was on the phone and replied when she got off, but today, my only assumption is that her phone was turned off overnight and it turned back on this morning yet.

     

    Thoughts?

  • Meg St._Clair Level 8 Level 8 (37,475 points)
    Currently Being Moderated
    Aug 2, 2013 1:20 PM (in response to jayf1981)

    jayf1981 wrote:

     

     

    Thoughts?

    For iMessage to work, both parties must have an active data connection at the time the message is sent and received. If the message went through as text, one or other of you did not have an active data connection at that time.

  • ronfromtoronto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2013 5:57 PM (in response to XMasta19)

    I have the opposite problem. Instead of receiving text messages my friend with an iPhone is only sending out iMessages so unless I check my iPad or computer I won't know they are trying to message me.  Any recommendations?

  • uberzack Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2013 5:23 PM (in response to razmee209)

    Thanks. The linked article cleared it up for me.

  • mammarun Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2013 10:22 AM (in response to dancbr)

    I guess a plus to imessaging is that you can imessage from a phone hooked to wifi to other iphone users. I know this bc I have a new phone and it is not serviced but i still get imessages on it from my sister and my husband, the problem is that, although I can recieve text from my husband who is an iphone user I am unable recieve texts from my sister who is an iphone user, but I get her imessages on the other iphone that is not serviced right now. It is ver annoying. She is able to recieve my texts from my new phone but I do not get her responses on my new phone.

     

    Is there a setting that she can change so that she can send me texts?

  • rockmyplimsoul Level 5 Level 5 (5,375 points)
    Currently Being Moderated
    Nov 12, 2013 10:32 AM (in response to mammarun)

    You need to go to Settings/ Messages/ Send & Receive and check your settings for:

     

    • You can be reached by iMessage at:
    • (should be your phone number, and optionally add one or more e-mail addresses)

     

    • Start New Conversations From:
    • (should be your phone number, but could be an e-mail ... but one or the other)

     

    Your contacts should be sending messages to you by how your settings are defined above.

  • icerabbit Level 3 Level 3 (765 points)
    Currently Being Moderated
    Nov 16, 2013 7:23 AM (in response to bonehed)

    bonehed wrote:

     

    This has been a bug in iOS ever since iMessage was introduced.  Despite having "Send as SMS" turned off, my phone will occasionally send texts (confirmed by viewing texting usage on AT&T).  It is a problem with individual recipients for sure (I have not encountered it with group message, but I'm sure it still happens).

     

    I have even observed a message change from blue to green AFTER sending.  Being well aware of this issue, I am always very careful to ensure that the Send button is blue before sending (I generally make sure it's blue for a few seconds before clicking).  One time, I sent an iMessage, went to Messages, and confirmed that it was "Delivered" as an iMessage.  Later, I checked again and it had changed to green (text).

     

    Annoying problem for sure!

     

    I think this exact same thing happened to me the other day.

     

    Our iPhones have iMessage ON, Send SMS OFF, etc. I was sending several travel progess updates throughout the day of a long multi-leg trip. I did not see anything as far as can't send imessage, send as txt instead.  And, even though we use iMessage infrequently, we know blue = free and green = $$$.

     

    I'm checking the VZW app today, to check on our data & minutes usage (as we've used our phones well above avg in the past month) and come to find out we texted each other?!   I check iMessage and one of the bubbles among the blue ones is green? Which I admit didn't register with me the other day. I only had the app open a few secs at a time and went on with whatever goes on when you travel.

     

    The only thing I can think of is that, as the plane was taxiing and I took the phone off airplane mode, that iMessage defaulted to send it as a text because the phone hadn't established a data link yet.

  • Tamara1982 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2014 3:41 AM (in response to XMasta19)

    Hey, ok I can't find the original guy's post in here which TOTALLY WORKED FOR ME SO, I'm going to tell u what I did.

     

    First: settings, messages, turn off iMessages.

     

    Next: settings, general, reset, then reset network settings

     

    Enter ur passcode and the restart will commence. (YOU WILL NOT LOSE ANY DATA WHATSOEVER, except u will sometimes have to re-enter ur password for ur wifi... Not a big deal. I still had all my open apple chats avail when I got back on!!!

     

    Now make sure ur wifi is working first, (as I said may need to re-enter ur password) once wifi is back,

     

    Last: settings, messages, turn iMessages ON. It should deactivate it and voila...

     

    It worked for me!!!!! So great flu for this forum! Hope it helps u guys...  

  • Tamara1982 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2014 3:43 AM (in response to Tamara1982)

    Ha,... That last bit where I say 'deactivate it' I meant 'reactivate it' bloody auto-correct! Haha

  • Tamara1982 Level 1 Level 1 (0 points)

    Hey, when I send 'iMessages' to friends who don't have an iPhone or have 'iMessages' turned off, it usually just sends a regular text... It just takes a bit longer to get them is all. It tries I think a few times to send via wifi, and when it is unable to retrieve the signal then sends a mobile signal instead. Not sure why else that cud be happening. Sorry!

  • ronfromtoronto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2014 4:17 PM (in response to Tamara1982)

    I experience the following issues with messages

     

    1) when messaging my friends who have iPhones and have exchanged iMessages before ( blue colour in ios7 ) if I send them a picture it will send it as an mms. I'm sure my carrier loves Charging me a 1.50 per mms

    Workaround: send to an Apple ID that is an email address and use an iPad . If using an iPhone temporarily turn off cellular data

     

    2) messes not being delivered or received even though the phone says delivered

     

    3) messages aren't  received on other devices or messages are delayed

     

    4) messages fail to send. Sometimes this is due to poor coverage or bad signal.

     

    5) messages are sent as an mms to an email address and actually arrive as an email

     

    In general the messages app needs more options available in the settings.

  • georgiainaustin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 21, 2014 7:01 AM (in response to Tamara1982)

    Super helpful! That worked. Thanks.

  • S M Williams Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jan 25, 2014 9:00 AM (in response to Tamara1982)

    Thanks so much, worked for me too.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.