Skip navigation

I have sharing to everyone on Mac HD no access now locked out

3888 Views 10 Replies Latest reply: Sep 10, 2013 5:29 AM by Bharath.k RSS
Macaroni323 Calculating status...
Currently Being Moderated
May 13, 2012 12:28 PM

I am having problem with my entire MAC HD being shared to anyone on my home network and wanted to remove this access.  The following paths are approximate since I can't get into the machine.  I went to "Finder" and selected "Macintosh HD" and then "Get Info."  On sharing at the bottem it listed System, Wheel and Everyone as users.  System and Wheel had "Read & Write" privledges and "Everyone" has "Read only."  I thought this was for file sharing on the network but I know now that this is for ANY access to the Macintosh HD.  My system could not be shut down, no applications could be selected.  I could do nothing on the machine at all.  I shutdown hoping to get to the boot version of the "Disk Utility" and try to repair permissions but that is not accessable and the spinning timer is all that appears on boot.  Nothing else.  I can get into single user mode though.  Is there a way to recover or reset the "Everyone" user on the "Macintosh HD" (I assume that is the root of the drive).to "read only" privledges?

Mac mini, Mac OS X (10.7.4), 16GB Memory, Samsung 60" HDTV
  • captfred Level 7 Level 7 (26,225 points)

    Neil has a good user tip here:

     

    https://discussions.apple.com/docs/DOC-2240

  • Kappy Level 10 Level 10 (221,005 points)

    Repair the Hard Drive - Lion

     

    Boot from your Lion Recovery HD. When the recovery menu appears select Disk Utility. After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list.  In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive.  If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported then click on the Repair Permissions button. Wait for the process to complete, then quit DU and return to the main menu. Select Restart from the Apple menu.

     

    Boot to the Recovery HD:

    Restart the computer and after the chime press and hold down the COMMAND and R keys until the menu screen appears. Alternatively, restart the computer and after the chime press and hold down the OPTION key until the boot manager screen appears. Select the Recovery HD and click on the downward pointing arrow button.

     

    If you have to repair the permissions of all the data in the Home folder, then while still running from the Recovery HD above:

     

    select Terminal from the Utilities menu. Enter resetpassword at the prompt and press RETURN. Follow instructions in the dialog window that will appear. You can reset your admin password or reset the ownerships and ACLs for user accounts. It's the latter that you want to do.

  • pairochjulrat Calculating status...

    Macaroni323, your solution has save my life

  • johnnymac5150 Calculating status...

    Happend to me also.  I was foolin around with permissions on my Mac and gave "everyone" no access to the root of the system drive.  System would boot and just hang on startup.  I clicked on captfred's link and followed Neil's A1 tip and it worked!  20 seconds of typing and my system rebooted back to its old self.  Here is what I did copied from Neil's info (thanks Neil!):

     

    (From Neil)

    A1. If the disk in question is your Mac OS X startup disk and your computer stops starting up at the blue screen, restart with the Command and S keys held down, and enter the following commands:

     

    mount -uw /

    chown root /

    chmod 1775 /

    exit

  • mccoolpix Calculating status...

    Thanks johnnymac5150 for Neil's info. This saved my rear.

  • Branbillapuzz Calculating status...

    Hi when I repair my Macintosh, DU sais that one file cannot be repaired (Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAg ent" has been modified and will not be' repaired. ) and other differ (ex. Permissions differ on "System/... "; should be drwxr-xr-x ; they are lrwxr-xr-x. ") what's should I do?

  • noondaywitch Level 6 Level 6 (8,130 points)

    Totally ignore it - it isn't a problem.

     

    http://support.apple.com/kb/TS1448

  • Branbillapuzz Level 1 Level 1 (0 points)

    Thanks but when I restart my Mac the screen is white. I've repaired the Macintosh HD and it sais that it is ok and I've repaired the permissions even if there are errors as you know. Then I restart my Mac and a white screen appears. How can I fix it?

  • Bharath.k Calculating status...

    Thanks, This worked for me

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.