Skip navigation

iCal not connecting to Google Calendar - HTTP 404 error

68093 Views 119 Replies Latest reply: Apr 10, 2014 6:51 AM by remi.rpn RSS
  • RRepsaj Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 31, 2013 2:18 AM (in response to Ziru)

    Thanks Ziru  - your tip worked for me too.  

     

    I've just been doing some routine security maintenance to Gmail and Gcal, which I access through Mac Mail and Mac Calendar.

     

    The Mail wasn't connecting to the G server and the Calendar was syncing, etc but inexplicably giving error messages (e.g. 'Your calendar couldn’t be refreshed.")

     

    As you suggested, I un-checked (or un-ticked as we say in England) the accounts in the System Preferences… shut down Mail/Calendar…re-opened…Ta da!

     

  • MattJED Level 1 Level 1 (0 points)

    I still have a problem with this.

     

    If I follow the steps of:

    1. Removing the calendar accounts and restarting
    2. Follow this thread, the problem solves for max 1 hour http://kb.mit.edu/confluence/pages/viewpage.action?pageId=12386508

     

    Has anybody got other ideass?

     

    Thanks!

  • Steven Trooster Level 1 Level 1 (5 points)

    I had the same issue, but I figured out what caused the problem. I was doing some testing with my Google account and mail. I don't use GMail, but for the testing I needed to set up a GMail account to figure out how GMail handles e-mail aliasses of e-mail addresses that aren't pop, but just forewarding addresses. (To answer that question too: no, GMail can't create an alias of an e-mail forewarding address, only real pop/imap addresses are allowed)

     

    At one point in the whole Google-GMail-account circus, I was asked (or forced?) to set my GMail.com address as a primary address for my Google account. That's when iCal/Calendar syncing problems started. I tried all tips above, but none worked.

    I then deleted the GMail account on my Mac in the system settings and created a new account with my GMail.com address as username (in stead of my own -emailaddress) And voilá: iCal/Calendar works fine again!

     

    It's realy strange, since Google still allows me to login on their site with my secondary (own) e-mail. But apparantly Google is picky when it comes to syncing calendars. (And Google does not allow me to set my own mailaddress back to a primairy address. Once your part of the GMail family, you can't get out... )

     

    Be aware: iOS doesn't give you an error message. Though you can add calendar items to your Google calendar on your device, syncing doesn't work either. So those items won't be added to Google and your other devices.

    You have to reset your account too on your iOS devices.

     

    Oh, and one advice: if you do some testing whith Google (or any other service your digital life depends upon), create a new account and don't mess with your excisting account.

  • kiranbiliyawala Level 1 Level 1 (0 points)

    Finally got something that worked with my iCal/Calendar.

    Thanks man.!!

  • kidhack Level 1 Level 1 (0 points)

    Found this on Google forums.

     

    1. Go to https://www.google.com/calendar/syncselect

     

    2. Select the calenars your want tot sync. Click "Save".

     

    3. Go to Calendar.app, hit Command-R to refresh and sync calendars.

     

     

     

     

    This seemed to solve the issue for me after trying everything else (deletion, cache clearing, etc). Not sure how long, but it's working for now. I'll update if it fails again.

  • kidhack Level 1 Level 1 (0 points)

    Still working the next day!

  • barbr Level 1 Level 1 (0 points)

    I've been having this problem since buying the new 2013 Macbook pro w/ Mavericks this week. Tried your method, it works but now iCal keeps asking me for my gmail login again and again every other second!!

  • kidhack Level 1 Level 1 (0 points)

    I didn't have that problem. I haven't had any issues since updating to Mavericks either.

  • EricBobrow Level 1 Level 1 (0 points)

    Kidhack -

     

    Thank you so much for posting the link to the Google calendar sync settings:

    https://www.google.com/calendar/syncselect

     

    I had been trying to subscribe without success in iCalendar to a calendar of a business partner that I access easily in Google Calendar. I was trying to follow instructions from another forum post and use the private ICAL link I had copied from the Google calendar. I kept getting an error saying there was no calendar available at that address.

     

    However, once I went to the syncselect page, and added that calendar for syncing, then it worked like a charm.

     

    My iCal was already connecting to my Gmail account, and synchronizing both ways (my calendar items can be created or updated in either iCal or in Google Calendar, and they appear and update in the other one). The trick was telling Google that I wanted to ALSO sync this "guest" calendar, using the checkbox  on the syncselect page.

     

    Thanks so much for posting this!!

     

    Eric Bobrow

    http://www.bobrow.com

  • Robbo2010 Level 1 Level 1 (0 points)

    Just a note.

     

    The last two updates of OS X have progressively fixed the problems that I was experiencing when receiving meeting invitations from Microsoft Outlook users in the company.

     

    Originally I was getting Error 403 errors whenever I received an Outlook invitation.

     

    The first update sorted that out - but didn't sort the situation when I had received an invitation but the originator then changed and updated the invitation.  As soon as that happened, when Calendar tried to sync, it would bounce and give me the 403 error.

     

    Mavericks sorted this issue out too.

     

    So right now, I haven't had any problems with receiving meeting invitations from Outlook clients since Mavericks was released.  I haven't had any problems period - but I can't say that google calendar invitations work, because I don't know that I've had any!

  • nnr.noah Level 1 Level 1 (0 points)

    This just worked for me:

     

    I went onto my iCloud and delete all my accounts linked to it. Then, I added again my iTunes account and done

  • tuckerca Level 1 Level 1 (0 points)

    My Calendar was doing the same thing. I noticed that it started doing it after I downloaded a "Calendar feed" iCal update (a pop-up pictured below with an "http:" link that will also download an ".ics" icon in your download folder when you select the "click here to view feed" button).

     

     

    Screen Shot 2014-01-30 at 4.57.30 PM.png

     

    NOTE: I deleted the web link for obvious reasons but an http: link will be in the white box outlined in blue in the picture above.

     

     

    I noticed this started happening after I would drop the .ics file (pictured below) into my apple calendar. This file will download to your computer when you click the "click here to view feed" button

     

     

    Screen Shot 2014-01-30 at 4.59.15 PM.png

     

     

     

    Here is how I fixed it:

     

     

    1) delete your calendar and reinstall it

    Calendar --> Preferences-->Accounts-->choose you calendar that you dropped the .ics folder into--> hit the (-) button.

     

    Screen Shot 2014-01-30 at 4.41.41 PM.png

     

    To reinstall, hit the (+ ) button and go through the set-up.

     

    Now, instead of trying to drop the .ics file directly into your Apple calendar, Go to your Google calendar and go to the heading that says "Other Calendars" and select the little down arrow. You will then see "Add by URL".

     

    Screen Shot 2014-01-30 at 4.45.09 PM.png

     

    Paste your Live feed link here and click add calendar.

     

    Then go to this link https://www.google.com/calendar/syncselect and select the boxes for the calenders you want to sync across all your devices. Click save.

     

    Then restart your Apple Calendar and everything should be working and your Google Calendar, Apple Calendar and Apple devices Calendars should all be working, communicating with one another and without the error messages. By communicating to one another I mean you can make a change on any of the calendars and it will update the rest of them (could take a minute or 15 depending on how you have your refresh settings set-up). Now all you have to do is select which calendars you want to see on your Gcal, Ical and Apple Devices (if you are seeing two of the same appointments, you have too many calendars selected. The easiest way to figure this out is by looking at the colors of the appointments and seeing which calendar it correlates to. This gets a little hairy when you have multiple calendars synced like I do.

     

    I hope this helps!

  • jameshsi Level 1 Level 1 (0 points)

    Kidhack -

     

    Thank you so much for posting the link to the Google calendar sync settings:

    https://www.google.com/calendar/syncselect

     

    Really solved my problem, I want to kiss you, Thanks a lot!

  • sabor Level 1 Level 1 (5 points)

    This is what worked for me (portions from others in this thread)

     

    1. Went to https://www.google.com/calendar/syncselect
    2. Unselected Selectable Calendars, clicked Saved
    3. Went to Calendar.app, hit Command-R to refresh and sync calendars.
    4. Went back to https://www.google.com/calendar/syncselect
    5. Selected Selectable Calendars, clicked Saved
    6. Problem persisted...
    7. Opened System Preferences --> Internet Accounts
    8. Unselected "Calendars" from Gmail account
    9. Went to Calendar.app, hit Command-R to refresh and sync calendars.
    10. Back in System Preferences --> Internet Accounts
    11. Enabled again "Calendars" from Gmail account
    12. Error gone
  • remi.rpn Level 1 Level 1 (0 points)

    Did not work for me either.

    Even when unselecting my gmail calendar from "account" i still got the error message. Despite reboot, anything.

    Still seeking for answer.    

1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.