Skip navigation

Time machine says: An error occurred while creating the backup folder

4992 Views 14 Replies Latest reply: Sep 12, 2013 10:02 PM by IMRAN RSS
fasterfox Calculating status...
Currently Being Moderated
Jul 24, 2011 12:49 PM

I noticed the time machine icon showing an error in the menu bar, and it displayed the following error message: Unable to complete backup. An error occurred while creating the backup folder.

 

This has happened 2-3 times. If I remount the drive the Time Machine works fine for about a day before giving me the same error again. I have Time Machine set to use one of the partitions on my 2TB external usb hard drive.

 

I used Time Machine Buddy to look at the logs and it says this:

 

Starting standard backup

Backing up to: /Volumes/TIME/Backups.backupdb

Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/TIME/Backups.backupdb/grasshopper size:37

Backup failed with error: 2

MacBook Pro, Mac OS X (10.7)
  • Pondini Level 8 Level 8 (38,710 points)
  • Thomas Goetz Calculating status...

    I have the same problem when trying to use time machine to backup the internal HD to an external USB HD.

    No solution so far...

  • Thomas Goetz Level 1 Level 1 (5 points)

    It seems that the problem is relatedd to the external USB drive, not to the iMac nor Lion.

    I used a Verbatim 1.5TB HD and always got the problem.
    Now I use a Wester Digital Elements 1.5 TB - without any problems!

     

    After googling a bit, I found out that the Verbatim drive has some sort of "Green Mode" to save power (at least they claim it does so). But I assume, thanks to this green mode, the drive falls asleep after 10min and then has to wake up, if it is needed by time machine. But it seems to take too long to wake up, and I get one of those error messages.

  • wirtes Calculating status...

    I'm having the same problems, but they only started with my upgrade to Lion.  The same backup disks worked just fine for months under Snow Leopard.  I never once saw this message under Snow Leopard.

     

    I can get a successful back by right-clicking on my time machine disk on my desktop and ejecting it.  First I get an dialog that says my disk "wasn't ejected beause one or more programs may be using it." But if I "Force Eject" and remount the disk using Disk Utility. My next backup runs just fine.

  • Johnusa2 Calculating status...

    I'm getting the exact same error, exact same circumstances.  UPgraded to Lion and bam.  Also, I'm having the same problem with the disk not unmounting and having to force it to unmount after Time Machine tries and fails to run.  Really frustrating.  It's clear that several of us are having the exact same problem.  Also, my backup disk that isn't working is a new Toshiba 1T.  I'm going to try my old Toshiba 1T and see if maybe it's this particular backup drive.  (I also am backing up Time Machine to a partition, so that's another variable I changed since I got the new drive - basically need to eliminate the drive as the problem, by using the old drive that worked before I upgraded to Lion, and then I'll try to backup on the new drive without a partition and see if that's the problem.

     

    Oh, and I did everything that was suggested above - ran disk utility, ran disk warrior, plugged the drive directly into my computer, unplugged it, rebooted, reset time machine preferences, etc.  Everything.  It did the same thing again, it works the first time or few times, then it refuses to back up and gives the same folders error.

  • Manzola Calculating status...

    Same, identical problem but with snow leopard. The external drive is a LaCie 1TB connected (USB) to an IMac. If I force eject and reconect I can do the back manually but the next automatic scheduled back up will fail.  I also have a disk partition. Disk utility found no errors.

  • magnificentnile1 Calculating status...

    I just unplug / turn off the external disk. Then the backup works fine. Pretty clunky and disconcerting when you get the "improperly disconnected drive" error but what else can you do? I particulary like the can't eject because tone or more programs are using it" error. Can't eject because a program is using it but the program can't use the disk bcause of the error. Good one.

  • Pondini Level 8 Level 8 (38,710 points)

    A clue may be lurking in your logs.  Use the widget in #A1 of Time Machine - Troubleshooting to display the backup messages from your logs.  Locate one of the backups in question, and see if there are any "indexing" messages.  If there are a lot of them, the Spotlight index may be damaged. 

     

    If so, see the pink box in #D2 of the same link.

  • phraxos5 Calculating status...

    I think this is not just a problem with time machine because I had the same problem with a 4 drive raid array that was created on my MBP, then when I bought my MP i hooked it up and there were immediately problems similar to your description. First the array would spin up but was very slow to copy to. I tried to delete the array but was unsuccessful.  ultimately i had to re boot the array as an incomplete (3 drives instead of 4) then zero the drives and creat a new set. I used 3 instead of 4 this time just in case it was a power issue.  The new array worked fine and copied files at acceptable speeds.  Then after working in itunes for about 2 hours, i started getting spinning balls which is strange for a MP 6 core with 16 gb ram and a 5870 with a striped "0" work disk. It was the raid set again. I realized that it must have something to do with conflicts between a program indirectly using the drive(mds,spotlight,time machine etc.) and the program diirectly using the drive(itunes). Anyway...this worked for me.

     

    the instructions in the following thread fixed for the time being.

     

    https://discussions.apple.com/thread/3200951?start=0&tstart=0

  • IMRAN Level 2 Level 2 (470 points)

    Fast forward 15 months, same problem here.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.