Skip navigation

My g5 power pc will not recognise an external usb2 DVDRW

479 Views 7 Replies Latest reply: Sep 13, 2013 8:16 AM by BDAqua RSS
djrjawa Calculating status...
Currently Being Moderated
Sep 10, 2013 12:47 PM

Right: running power pc tower, dual proc, a number of external HD (mainly firewired), also two external DVDRW s.

Recently had an internal drive failure , but now up and running fine, except that now it won't recognise either of the drives' existance, just the main optical.

Tried Disk Utils, USB overdrive, even booted into open firmware to see if they'll help to see the drives (both off USB ports), used the USB fix package. So am confused. Have tried every which way of ordering the turning on, plugging in and wiring up options but to no avail.

I'm not too familiar with command line, but can execute them if properly instructed.


  • BDAqua Level 10 Level 10 (114,685 points)

    Hi, are  other USB things recognized in those USB ports?

  • BDAqua Level 10 Level 10 (114,685 points)

    I was thinking you needed a USB Reset possibly, due to USB overcurrent draw, but apparently not.


    Are these devices Bus Powered or do they have AC... which can still be a problem on a wide variety off devices, ignor the hissing, failure to mount or intermitent mounting was far more common...


  • BDAqua Level 10 Level 10 (114,685 points)

    Yes elimnate all, then try one.


    Open Console in Utilities & see if there are any clues or repeating messages when this happens.

  • BDAqua Level 10 Level 10 (114,685 points)

    reset FW bus, same goes for USB reset...

    Reset the Firewire/USB bus

    If your Firewire or USB isn't recognizing any device.  A solution which has worked for some whose hard drive became invisible in 10.4 was simply to follow these four steps to reset the Firewire/USB bus:

    1. Shut the machine down.

    2. UNPLUG the power lead to the computer and any firewire/USB drive or devices.

    3. leave it for 10 minutes.

    4. Connect back up and reboot.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.