1 Reply Latest reply: Sep 13, 2013 8:44 AM by Niel
Kay Elaine Level 1 Level 1 (0 points)

I have an IMac made in mid-2007 with a 10.4.11 operating system.  Can I upgrade it to a more current version?  If so, how?  Thanks.


iMac, Mac OS X (10.4.11)