Skip navigation

Safari not displaying all images

25024 Views 18 Replies Latest reply: Jan 2, 2014 9:14 AM by MikeChrista RSS
1 2 Previous Next
Kiraku Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 10, 2012 2:50 PM

Safari does not seem to display all images on certain pages. For example, on

feed : // news.google.com/?output=rss

all images for news headline items show the "questionmark" icon.

 

And yes, "Display images when the page opens" is checked in Safari preferences.

 

Has anyone had the same problem, and found a solution?

 

Using: Safari Version 5.1.3 (7534.53.10), OS X (10.7.2).

  • Carolyn Samit Level 10 Level 10 (84,050 points)
    Currently Being Moderated
    Mar 10, 2012 2:55 PM (in response to Kiraku)

    Hi Kirk ...

     

     

    Try deleting the cache file associated with Safari.

     

    Quit Safari.

     

    Go to      ~/Library/Caches/com.apple.Safari/Cache.db

     

    Move the Cache.db file from the com.apple.Safari folder to the Trash.

     

    Relaunch Safari.

     

     

     

    ~ (Tilde) character represents the Home folder.

     

    For Lion:   To find the Home folder in OS X Lion, open the Finder, hold the Option key, and choose Go > Library

     

     

    edited by:  cs

  • Carolyn Samit Level 10 Level 10 (84,050 points)
    Currently Being Moderated
    Mar 10, 2012 5:12 PM (in response to Kiraku)

    Ok... 

     

     

    Go to Safari > Preferences then select the Privacy tab then click Details.

     

    Type in the name of websites you are having problems with images one at a time in the search field top right corner of that window; click Remove All > Done

     

    If you don't mind removing all cookies just click:  Remove All Website Data

     

    Quit then relaunch Safari to test.

     

     

    Using: Safari Version 5.1.3 (7534.53.10), OS X (10.7.2).  <  your profile

     

    If you aren't aware, there's a Lion update for v10.7.3 available from your Apple menu > Software Update... it may or may not help the Safari issue, just letting you know.

  • Linc Davis Level 10 Level 10 (107,520 points)
    Currently Being Moderated
    Mar 10, 2012 6:34 PM (in response to Kiraku)

    It's the same for everyone.

  • GrandSwiss Level 1 Level 1 (20 points)
    Currently Being Moderated
    Mar 28, 2012 11:07 PM (in response to Kiraku)

    With the feed "Google News" it's partly Google's fault, partly Apple's.

     

    In the RSS feed, Google provides to the browser something not 100% standard; the link to the image in the Google feed is

       <img src="//nt1.ggpht.com/news/tbn/EVRrcIItcrqKMM/6.jpg">

     

    The "http:" is missing! Although that link would (by accident) work as is, Safari checks if the link starts with "http:" and if it doesn't, adds (in this case wrongly) "http://news.google.com" in front of it. The resulting links is then

       <img src="http://news.google.com//nt1.ggpht.com/news/tbn/EVRrcIItcrqKMM/6.jpg">

    That link does not exist, and hence the image is not displayed.

     

    The question: Should Safari change or Google?

  • Rrobbins6111 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 30, 2012 1:23 PM (in response to Kiraku)

    I seem to have a similar problem.  I am running Windows 7 with Safari 5.1.7.  Everything was working OK until about 4 weeks ago some of the images are not displaying.  It happens from all sights including CNN.  If I right click on where a image is an click Open Image in A New Wingow, the image displays in the new window.

     

    Any suggestions ?

  • GrandSwiss Level 1 Level 1 (20 points)
    Currently Being Moderated
    May 30, 2012 7:34 PM (in response to Rrobbins6111)

    Please specify the URL that is not working.

  • Rrobbins6111 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 31, 2012 5:50 AM (in response to GrandSwiss)

    It affects all URL's but for instance www.cnn.com.  The images display correctly with Windows Internet Explorer but are blank  with Safari.  This use to work but like I described before one morning it just seemed to stop displaying them.

  • GrandSwiss Level 1 Level 1 (20 points)
    Currently Being Moderated
    May 31, 2012 10:48 PM (in response to Rrobbins6111)

    Okay. Please check in your Safari "Preferences" under the tab "Appearance" whether the option "Display images when the page opens" is ticked.

  • Rrobbins6111 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 1, 2012 6:14 AM (in response to GrandSwiss)

    That was it.  Thank you so much.  I don't remember ever un-checking this but that solved my problem.  Thanks again.

  • MLSReality Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 28, 2012 11:44 AM (in response to Kiraku)

    I recently downloaded Mountain Lion, and now have Safari 6.0.  I heard so many good things about this new version I decided to try Safari again as my main browser.  But now, I get this old problem.  Images not displaying.  Not sure if I will go back to Chrome or Firefox.

     

    There is no Appearances Tab in Safari 6.0 Preferences, and in thumbing through the tabs, I don't see anything under any of them re. displaying images.

     

    It has happened many times, but the particular site I am at now is

    http://www.businessinsider.com/wall-street-analyst-commentary-2012-7?op=1

    I do get pics at http://news.google.com

     

    Hmmm, I get pics at http://www.businessinsider.com/wall-street-analyst-commentary-2012-7#

    but they have an ability to see the next 12 pages all on one page which is

                    http://www.businessinsider.com/wall-street-analyst-commentary-2012-7?op=1

     

    Does this mean the site is doing something "wrong"?  and Safari therefore won't show the pics?  perhaps I will go back to Firefox that will show "wrong" pics

  • Tony Farrelly Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 11, 2013 11:52 AM (in response to Kiraku)

    Ok, I had this problem and just sorted it this minute. I'm using OS X 10.8.2, intel Mac. To fix the problem of images not showing in Safari - go to Safari preferences and under the GENERAL tab,tick the check-box that has 'OPEN  "safe" files after downloading."safe" files include movies,pictures,sounds,PDF and text documents,and archives. I dont ever remember unticking this box, but then I could have done so some time in the past. Anyway, the minute I ticked the box, images that were not displaying (even on facebook - which is probably where most people notice this issue), are all present and displaying without a problem. I had thought it was a slow connection issue until now, but I've discovered that was not the problem. Hope this helps some of you out.

  • burnik Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 13, 2013 2:04 PM (in response to Kiraku)

    Check the date of your mac. It is usually connected with the certificates. So kindly check your dates and change it to current date.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.