Skip navigation

Mail app shows 3 unread emails when there isn't.

197967 Views 101 Replies Latest reply: Apr 2, 2014 9:50 AM by jalley1987 RSS
  • MADevlin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 28, 2013 12:55 PM (in response to atyree)

    Fastest way to fix this:

    To clear the “ghost” unread messages, do the following:

    • Open Settings
    • Select Mail, Contacts and Calendar
    • Select the mail account that is showing the incorrect unread messages icon
    • Change “Mail” setting from ON to OFF
    • Press the “Home” button (the round button just below the screen) to exit the Settings app
    • “Double-tap” the “Home” button to show running apps
    • Press and hold on any of the running apps. These will change and show a red circle with a “-” in the upper left corner of each.
    • Click on the red circle to close the Mail app (if you’ve never done this, closing all of these apps is a good battery life extender)
    • Press the Home button again to exit out of the open apps screen
    • Open Settings
    • Select the mail account that is showing the incorrect unread messages icon
    • Change “Mail” setting from OFFN to ON
    • Press the “Home” button to exit the Settings app
    • Open the Mail app
    • After the Mail app updates, your unread messages count should now be correct
  • J_amie4 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 30, 2013 1:43 AM (in response to shaarp)

    Thanks for this! It has been driving me insane for the last few weeks! This resolved the problem right away.

  • qwertykey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 13, 2013 11:30 AM (in response to atyree)

    Thanks MADevlin, it worked like a charm!

  • A.vandesteeg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2013 1:30 PM (in response to atyree)

    What worked for me was to go to gmail.com where I found out I had a few unread Hangout messages in my inbox. After I marked these ase read the problem was finally finished! I never went to gmail.com, because I always use my gmail account in the app or in Mail on my desktop. That worked for me, finally!

  • ivey0822 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 17, 2013 9:09 PM (in response to bd1212)

    bd1212, I literally created an Apple forums account JUST to say thank you for your solution.  However the heck you figured it out, I don't know, but it worked perfectly.  THANK YOU!

  • Robhair Level 1 Level 1 (0 points)

    Ok, I fixed this issue. I have multiple email accounts looked to see which acct was showing unread and used search on that acct. just put unread in search window. Up came the unread mail from gmail support which you cannot delete only archive. You must at least open before archiving .

  • shonhoo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2013 8:51 AM (in response to Robhair)

    Thanks a lot. Your solution solved my problem. I had same problem that shows unread mail alert.

  • khspolo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2013 11:00 AM (in response to atyree)

    I had same problem-

    thisnis how I cleard it up- click Edit in the mail.-  Mark All-  Mark as Unread-  At this point all the mail will be marked as UNREAD.  Don't freak. 

    Now do the steps again but you will be given the "Mark as Read" option.

    so Edit--- Mark All--- Mark as Read.

  • joeyraff Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2013 5:37 AM (in response to atyree)

    To view all (and only) unread messages in your Gmail account:

    • Type "is:unread" (not including the quotation marks) in the Gmail search field.
    • Click Search Icon.
    • Select every unread email.  To do this you check off the select all check box AND look for a link in the top middle that says "Select all 875 conversations in Inbox" and click that too.  This will select every single mail item in gmail that is unread
    • Mark all of the results as read - I know this can be annoying, so for the items that you want to remain unread - throw a tag on them so you can find them easily later. 
    • Refresh your iPad/Pod/Phone/Whatever and it will be fixed.

     

    This is so annoying, and I can't figure out what happens to cause it.  Even more annoying is that it only happens every year or so, so in one year, I will have completely fotgotten this fix, and I will spend 40 minutes figuring it out again.  Maybe I will find my own post and read this.  See you in a year!

  • Boomer2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 26, 2013 7:15 AM (in response to MADevlin)

    THANK you for your solution-my 8 phantom unread emails were driving me crazy. Not anymore :-)

  • Boomer2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 26, 2013 7:33 AM (in response to Boomer2)

    Bummer,,,,,,they are back :-(

  • pjl123 Level 5 Level 5 (5,440 points)
    Currently Being Moderated
    Oct 26, 2013 7:50 AM (in response to atyree)

    As near as I can figure, when you loaded iOS 7, as it set up mail, it went back to each account and got the number of un read messages from that source.  Even if those unread messages are from way back, and are not on your pad.  The way to get rid of them forever is to go to that account on a computer, and find those messages and either read them or delete them.  ( as described in the earlier post)

  • 1MrBean Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 26, 2013 11:58 AM (in response to khspolo)

    This has been bugging me for a while now.

    Tried your solution and it works.

    Thanks so much.

  • Topopardo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 2, 2013 1:52 AM (in response to JagAC)

    This worked for me, thanks!

  • Poki8 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 2, 2013 5:32 PM (in response to MADevlin)

    I have 1700+ unread ghost messages. It is making me crazy! I followed your instructions exactly, but it did not work. With the IOS7 update (which I hate!) to close out the applications, you have to swipe up to close them. I tried touching down on the app to bring up the red minus button, but it no longer appears. Any other suggestions? I have a POP email account ie: xxx@centurytel.net. Thanks to everyone who know more that me

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.