Skip navigation

QuickTime Player quits when opening a file

5544 Views 123 Replies Latest reply: Sep 30, 2013 1:25 AM by Alvin Koh RSS
  • Alvin Koh Calculating status...
    Currently Being Moderated
    Sep 16, 2013 4:32 PM (in response to kingfisher500)

    I updated to 10.8.5 the day it was released and so far no crashes. Hope it stays that way.

  • Linc Davis Level 10 Level 10 (107,860 points)
    Currently Being Moderated
    Sep 16, 2013 6:37 PM (in response to kingfisher500)

    When a problem defies all explanation, the last resort is to erase the boot drive and restore from a backup, on the theory that it has bad sectors.

  • Alvin Koh Level 1 Level 1 (45 points)
    Currently Being Moderated
    Sep 16, 2013 6:45 PM (in response to kingfisher500)

    Yes I still have the Security Update installed when I updated to 10.8.5. In an earlier post I mentioned that restoring QTKit.framework and QuickTime.framework fixed the QuickTime Player crash although temporarily. The 10.8.5 update includes QTKit.framework and QuickTime.framework. I did file comparisons and found a number of differences with my backup copy of the frameworks so I am hopeful 10.8.5 resolves the problem permanently.

  • Alvin Koh Level 1 Level 1 (45 points)
    Currently Being Moderated
    Sep 16, 2013 6:49 PM (in response to Linc Davis)

    Linc, I scanned my boot drive and did not find any problems. I'm pretty much convinced the Security Update was the problem. Perhaps it doesn't work well with some per-2010 Macs.

  • TStam Level 1 Level 1 (75 points)
    Currently Being Moderated
    Sep 17, 2013 1:24 AM (in response to Alvin Koh)

    10.8.5 since the day it was released.No problems with QT. Ihave Sophos running and have since reinstallled latest Skype. Still working. My installation was 10.8.4 clean install with the security update before doing so.The last thing I will try to install is QT Pro. Previously, when having the problem, both versions crased, fYI.

  • betaphase Calculating status...
    Currently Being Moderated
    Sep 22, 2013 8:38 AM (in response to kingfisher500)

    Hi All,


    So I've been following this post as I have an 09 iMac which developed the same problems with quicktime after I had to install a new hard drive, and restored my system and updated the OS. Quicktime crashes when opening, MS Office would crash when trying to save files, etc. All these problems would thenbe resolved by installing the Security Update 2013-003.


    I have now installed 10.8.5 hoping that it would resolve my problem except. Unfortunately, all the same problems with quicktime remain; but now that that the new updated is installed it actually made it so that I can no longer run SecUpd2013-003. If I try to run SecUpd2013-003 I get to a screen where it asks me to select a destination drive drive but wont actually let me select one becuause it says "Security Update 2012-003 can't be installed on this dist. This update requires OS X version 10.8.4 or rearlier.


    Is there some way I can manually repair quicktime now? Does anyone perhaps have a script that fixes the broken symlink? Do I have any hope of actually permanently repairing this problem?

  • Calculating status...
    Currently Being Moderated
    Sep 22, 2013 5:45 PM (in response to kingfisher500)

    10.8.5 has worked for me so far, it's been ten days since I installed it & haven't had any problems yet. Before 10.8.5 I had to install the security update every 3 days

  • Alvin Koh Level 1 Level 1 (45 points)
    Currently Being Moderated
    Sep 22, 2013 5:58 PM (in response to betaphase)

    Hi betaphase,


    Sorry to hear you are still having problems after installing 10.8.5. I have not had QuickTime Play crash since I updated to 10.8.5. Did QuickTime Player work for a while after you installed 10.8.5?


    I would not try applying SecUpd2013-003 since 10.8.5 also supplies a possibly updated QTKit.framework and Quicktime.framework. What I would try is get hold of Pacifist if you haven't already got it and install those 2 frameworks and see if QuickTime Player will run. If it works, use the steps in my earlier post to make a backup of the framework files so you can restore them as needed.



  • TStam Level 1 Level 1 (75 points)
    Currently Being Moderated
    Sep 23, 2013 8:18 AM (in response to Alvin Koh)

    I believe the key may lie in fixing the problem before you upgrade to 10.8.5. I had all the symptoms including quicktime and office issues. Reinstalling the Security Update fixed it for a few days, then it came back. I was getting tired of the whole thing so I backed up and did a complete clean reinstall of 10.8.4 with the security update. Then I reinstalled my programs. It was working fine for a few days then the 10.8.5 update came out. I upgraded and it has been working fine ever since.


    My computer flies now and it is very quiet and snappy. Quicktime works all the time. I had upgraded all the way from Leopard and I think it needed a good cleaning out.

  • betaphase Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2013 11:47 AM (in response to Alvin Koh)

    Thanks Alvin,


    No, quicktime never worked after I installed 10.8.5. I now wish I had installed the security update first. I'm wondering if the security update would have fixed the broken symlinks, and then the 10.8.5 updated would have kept them from breaking.


    Oh well, I'll have to give your other solution a try. I've never used pacifist so I hope it's relatively straightforwar repair/install the QTKit.framework and Quicktime.framework.





1 ... 5 6 7 8 9 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.